Bug 38764 - Crash closing document in Ubuntu 11.04
Summary: Crash closing document in Ubuntu 11.04
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 40178 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-29 02:16 UTC by pavel223344
Modified: 2013-11-24 21:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Error message recieved upon crash (111.27 KB, text/plain)
2011-06-29 02:16 UTC, pavel223344
Details
First file used to replicate a crash. (39.89 KB, application/vnd.oasis.opendocument.text)
2011-08-27 01:21 UTC, dnh
Details
Second file used to replicate a crash. (39.89 KB, application/vnd.oasis.opendocument.text)
2011-08-27 01:21 UTC, dnh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pavel223344 2011-06-29 02:16:42 UTC
Created attachment 48543 [details]
Error message recieved upon crash

Some documents crash upon saving or closing in LibO Writer 3.4 in Ubuntu 11.4.

This happens in Ubuntu 11.04. It doen‘t happen in Windows 7 and not in Debian stable. The documents must be of some complexity. Newly created docs work as expected, but some, but not all, papers I have been working on for a while crashes.

I guess that there is something in some of my docs that doesn‘t work properly in LibO 3.4. I have not been able to pinpoint what it is. I have made a test document (2 pages) with the error present out of a much bigger document. If I shorten the document further or insert dummy text instead of real text the document does not crash. 

I am reluctant to post even a small part of my document publicly. If I change to dummy text the error is gone so its the real thing. Perhaps I could mail the file to someone for further analysis?

How to recreate:
Open the document in LibO 3.4 on Ubuntu 11.04
Close the document
Writer crashes
When Writer is restarted you are prompted to recreate the document

The document works fine in LibO 3.3 (and earlier versions of OOo). 

I get error reports in my home folder every time LibO crashes. I post one of them. It says something about Java. I have tested LibO 3.4 with SUN Java and Open JDK. The document crashes with either. 

I have also tested with LibO 3.4.1 RC3 and the documents still crash. 

This is a serious bug since data is lost upon crash, especially if you are working on several documents, since all open documents crash without saving.
Comment 1 pavel223344 2011-07-07 01:26:12 UTC
The bug is present in LibO 3.4.1 in all OS, Windows and Debian, I was wrong earlier. Several of my documents crash in all systems I have available. 
I suspect it has something to do with fields. I use endnotes and footnotes in the documents that crash. I think that the documents must be of some length and complexity for the crash to appear. 
I still have a document to test for any developer interested...
Comment 2 Rainer Bielefeld Retired 2011-08-15 00:26:05 UTC
@reporter:
Please attach one of those documents causing a crash!
Can you please check <https://bugs.launchpad.net/ubuntu/+source/libreoffice> for similar bugs?
Comment 3 dnh 2011-08-17 11:53:07 UTC
I have a similar problem on both Kubuntu 11.04 and W7 which I reported as bug 40178.
Comment 4 Rainer Bielefeld Retired 2011-08-17 23:16:55 UTC
*** Bug 40178 has been marked as a duplicate of this bug. ***
Comment 5 Rainer Bielefeld Retired 2011-08-24 03:24:46 UTC
Without sample document nothing can be done, closing Bug due to reporters' inactivity as WFM.

@reporters:
Please feel free to reopen this bug if you find out that the problem still exists with the current stable LibreOffice version and if you can contribute requested additional information due to <http://wiki.documentfoundation.org/BugReport> (especially BugReport Details)!
Comment 6 dnh 2011-08-27 01:21:27 UTC
Created attachment 50610 [details]
First file used to replicate a crash.
Comment 7 dnh 2011-08-27 01:21:46 UTC
Created attachment 50611 [details]
Second file used to replicate a crash.
Comment 8 dnh 2011-08-27 01:22:06 UTC
I have now understood how to replicate a crash. I tried it a couple of times, it always crashes.

Setup two odt-files with a fairly large amount of text (copying this page into the files worked for me: http://www.spiegel.de/panorama/0,1518,782809,00.html, I have attached both files).

Close LO. Reopen both files. Attempt to close one of the files by hitting the small close-button in the upper right corner - LO crashes.

Best,
dnh
Comment 9 dnh 2011-09-03 07:18:14 UTC
Updating to 3.4.3 is to no avail, it still crashes.
Comment 10 dnh 2011-09-03 07:19:33 UTC
Let me by the way add that I use a 32-bit system, not a 64 as originally reported by Pavel.
Comment 11 Rainer Bielefeld Retired 2011-09-03 10:56:27 UTC
[Reproducible] with reporter's sample documents and "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]". 

I open document as the only one, scroll down with scroll slider, wait until missing objects or pictures have appeared, scroll on until bottom of document, scroll up quickly again, close document close it clicking the right top little close-"x".
Expected: should close document, open LibO Start Center
Actual: crash.

The crash does no longer appear with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: a6adae1-4eb4f62-09af278)]".

@Reporter
can you confirm that the problem is no longer visible with Master (please see <http://wiki.documentfoundation.org/Installing_in_parallel>!)?
Comment 12 digital ant 2011-09-07 13:10:10 UTC
3.4.3 Mac OSX 10.6.8, Apple Java 6u26, EN US

The doc opens for me and does not crash, but scrolling up and down causes LibO to hang for about 5-8 secs on the pictures with links. I did notice the pictures, menu items and undefined objects are all just links, it takes a while for it to populate over the net. Possibly a timeout issue.

I right-clicked on the images, saved them all to my computer and everything worked smoothly with no delay.
Comment 13 Julien Nabet 2011-09-11 05:27:58 UTC
It doesn't crash on my laptop (Debian testing x86 on master updated today).
But here are some console logs (debug mode) :
Error: <SwNoTxtNode::SetObjTitle(..)> - missing <SdrObject> instance From File /home/maryline/compile-libreoffice/libo/sw/source/core/layout/atrfrm.cxx at Line 2945
Error: Don't close the medium when loading documents! From File /home/maryline/compile-libreoffice/libo/sfx2/source/doc/objmisc.cxx at Line 1301
Error: SVRect() without Width or Height From File /home/maryline/compile-libreoffice/libo/sw/inc/swrect.hxx at Line 306
Error: SVRect() without Width or Height From File /home/maryline/compile-libreoffice/libo/sw/inc/swrect.hxx at Line 306
Error: SVRect() without Width or Height From File /home/maryline/compile-libreoffice/libo/sw/inc/swrect.hxx at Line 306
Error: SVRect() without Width or Height From File /home/maryline/compile-libreoffice/libo/sw/inc/swrect.hxx at Line 306
Error: SVRect() without Width or Height From File /home/maryline/compile-libreoffice/libo/sw/inc/swrect.hxx at Line 306
Error: SVRect() without Width or Height From File /home/maryline/compile-libreoffice/libo/sw/inc/swrect.hxx at Line 306
Error: Special modes not compatible with hidden mode! From File /home/maryline/compile-libreoffice/libo/sfx2/source/view/sfxbasecontroller.cxx at Line 1377
Error: assertion failed! From File /home/maryline/compile-libreoffice/libo/sw/source/ui/app/apphdl.cxx at Line 698
Error: Don't close the medium when loading documents! From File /home/maryline/compile-libreoffice/libo/sfx2/source/doc/objmisc.cxx at Line 1301
Error: SVRect() without Width or Height From File /home/maryline/compile-libreoffice/libo/sw/inc/swrect.hxx at Line 306
Error: SVRect() without Width or Height From File /home/maryline/compile-libreoffice/libo/sw/inc/swrect.hxx at Line 306
Error: invalid type for InteractionHandler From File /home/maryline/compile-libreoffice/libo/sfx2/source/appl/appuno.cxx at Line 518
Error: <SwNoTxtNode::SetObjTitle(..)> - missing <SdrObject> instance From File /home/maryline/compile-libreoffice/libo/sw/source/core/layout/atrfrm.cxx at Line 2945
Error: SVRect() without Width or Height From File /home/maryline/compile-libreoffice/libo/sw/inc/swrect.hxx at Line 306
Error: SVRect() without Width or Height From File /home/maryline/compile-libreoffice/libo/sw/inc/swrect.hxx at Line 306
Error: assertion failed! From File /home/maryline/compile-libreoffice/libo/sw/source/ui/app/apphdl.cxx at Line 698
Error: SVRect() without Width or Height From File /home/maryline/compile-libreoffice/libo/sw/inc/swrect.hxx at Line 306
Error: SVRect() without Width or Height From File /home/maryline/compile-libreoffice/libo/sw/inc/swrect.hxx at Line 306
Error: <SwAnchoredObject::GetObjRectWithSpaces> - cache for object rectangle inclusive spaces marked as valid, but it couldn't be. Missing invalidation of cache. Please inform OD. From File /home/maryline/compile-libreoffice/libo/sw/source/core/layout/anchoredobject.cxx at Line 670
Error: <SwAnchoredObject::GetObjRectWithSpaces> - cache for object rectangle inclusive spaces marked as valid, but it couldn't be. Missing invalidation of cache. Please inform OD. From File /home/maryline/compile-libreoffice/libo/sw/source/core/layout/anchoredobject.cxx at Line 670
Error: Small world, isn't it? From File /home/maryline/compile-libreoffice/libo/sw/source/ui/uiview/viewport.cxx at Line 1157
Comment 14 Rainer Bielefeld Retired 2011-09-14 01:02:53 UTC
The question is: what will we do with this one? I think a new report for observations in Comment 13?
Comment 15 Björn Michaelsen 2011-09-29 09:49:53 UTC
Crash stacktrace at:
https://launchpadlibrarian.net/80761759/Stacktrace.txt
Comment 16 Björn Michaelsen 2011-12-23 13:24:59 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 17 Björn Michaelsen 2012-10-06 09:45:20 UTC
closing as worksforme as there seems to be no crash on this with 3.5.x+