Download it now!
Bug 38810 - font color icon does not work (add some functionality)
Summary: font color icon does not work (add some functionality)
Status: RESOLVED DUPLICATE of bug 45688
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-30 06:57 UTC by wpiis
Modified: 2012-10-14 20:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wpiis 2011-06-30 06:57:19 UTC
The font color icon does not work (clicking on it does nothing).

+++ Please make the font color icon work like it does in Writer (see below/next).

font color icon use in Writer:
If I have not previously selected a color, clicking on the font color icon should bring up the color pallet.
If I have previously selected a color then clicking on font color icon should apply the previously selected color.

If I need another color, I will click on the (drop-down arrow/drop-down triangle/fly-out) icon to bring up the color pallet.

Thanks, Tracey
BTW the back ground color icon has issues, but I will post that next/separately.
Comment 1 Björn Michaelsen 2011-12-23 12:23:22 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 sasha.libreoffice 2012-01-27 08:44:45 UTC
Currently, in Calc "Font color" and "Background color" not remember setting and load color each time from selected cell.
in MSExcel 2007 both tools remember color and we can select some color and then paint some cells with it.
Both behaviours my be useful. No one is better. My be we need some options to switch behaviour?
And Writer has tool for font color : when click on it, cursor becomes as brush and we can paint text with selected color.
Comment 3 sasha.libreoffice 2012-01-27 08:46:25 UTC
Let ask experts
Comment 4 Kohei Yoshida 2012-01-27 08:51:24 UTC
"it works as designed"(TM).  Not a bug.

So, enhancement is the right category for this.  FWIW this is one of the often requested enhancements, but is a bit hard to implement.

I personally prefer the MS Excel behavior, and I'm sure loads of others would agree.
Comment 5 Kohei Yoshida 2012-01-27 08:51:54 UTC
BTW, there may be a duplicate for this somewhere...
Comment 6 Stefan Knorr (astron) 2012-10-14 20:21:26 UTC
Resolving here, in hopes that the new behaviour is more or less what the bug opener wanted

*** This bug has been marked as a duplicate of bug 45688 ***