Download it now!
Bug 45688 - Calc: Formatting toolbar: Turn Button Font Color into Split Button
Summary: Calc: Formatting toolbar: Turn Button Font Color into Split Button
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other All
: medium normal
Assignee: Winfried Donkers
URL:
Whiteboard: target:3.6.0
Keywords:
: 38810 (view as bug list)
Depends on:
Blocks: 45671
  Show dependency treegraph
 
Reported: 2012-02-06 04:03 UTC by Stefan Knorr (astron)
Modified: 2012-10-15 06:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2012-02-06 04:03:46 UTC
We should try to use split buttons for all toolbar color choosers, for a longer
rationale, see: bug 45671.

How to get to see the button:
* Open Calc
* In the Formatting toolbar, find the Font Color item (icon: an "a" with a colored line below it)

See that the button is a simple button, not a split button.
Comment 1 Not Assigned 2012-03-05 23:52:57 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4236f5e19c5d3f3a5007c7a596868d09a7e39bee

fdo#45688: Split button for Calc cell font color
Comment 2 Stefan Knorr (astron) 2012-03-06 02:41:29 UTC
Great stuff, Winfried! Thank you!
Comment 3 Winfried Donkers 2012-03-06 07:50:57 UTC
transparent colour is a choice in the palette, but the cell background does not get transparent. That'll have to be fixed, so I reopened the bug.
Comment 4 Winfried Donkers 2012-03-09 06:18:34 UTC
fixed under bug 45671
Comment 5 Stefan Knorr (astron) 2012-10-14 20:21:26 UTC
*** Bug 38810 has been marked as a duplicate of this bug. ***