Download it now!
Bug 55989 - Calc FORMATTING, UI: incorrect behaviour of Background color tool
Summary: Calc FORMATTING, UI: incorrect behaviour of Background color tool
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: All All
: low minor
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-15 06:07 UTC by sasha.libreoffice
Modified: 2014-05-15 19:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2012-10-15 06:07:44 UTC
Some strange behaviour of Background color tool reproduced in 3.6.1 on Fedora 64 bit.
Steps to reproduce:
0. Start Calc
1. Place table cursor on any cell, click on triangle next to "Background color" tool. Palette with colors appears.
2. Select any color on palette
3. Click on triangle next to "Background color" tool again (while in the same table cell). We see that around selected color is small rectangle)
4. Click on triangle next to "Background color" tool again for palette disappear
5. Click on another cell in table.
Expected: "Background color" tool will keep previous color
Actually: it becomes "No fill" color

I understand that in such situation tool works as Eye Dropper. But it is so unintuitive. Users expect that they will change color and paint with this color several cells. But it takes color from cell.

This bug is split of Bug 38813
Resolution of Joel Madero:
Verified. I'm marking as a low priority minor bug. 

Reason: 
Can make it somewhat harder to make professional quality work -- requires an additional step of changing the color again, furthermore, if you're using similar colors, figuring out the same color you used previously can be tedious.

The # of users really affected by this is probably low (only those using background colors really often), and even then, the workaround is just one additional step of choosing the color again.

Not an enhancement as the behavior is inconsistent. If you change the color of a cell and then immediately select another cell, behavior is as expected, if you change the color of a cell and then choose the arrow drop down again, then move on to another cell, it shows no fill. Behavior should be consistent and this isn't working as it's intended to work
Comment 1 Larsen 2012-10-15 15:43:03 UTC
confirmed on Win XP SP3 with LO 3.6.2.2
Comment 2 Joel Madero 2014-02-27 22:55:19 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise