Download it now!
Bug 39227 - TABLES border formatting preserved
Summary: TABLES border formatting preserved
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL: http://temporaryland.wordpress.com/20...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-14 08:49 UTC by rm42
Modified: 2011-07-19 16:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots, see Comment 6 (240.51 KB, application/pdf)
2011-07-18 22:40 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rm42 2011-07-14 08:49:22 UTC
A document was created with LibreOffice 3.3.3, and it contains a simple table with borders.  When opening that file with LibreOffice 3.4.1 (Final) the table borders formatting changes.  I made a blog entry to describe the problem here:

http://temporaryland.wordpress.com/2011/07/14/libreoffice-3-4-1-problem/

There you will be able to find the original 3.3.3 document as well as the 3.4.1 one.
Comment 1 rm42 2011-07-14 12:53:40 UTC
I installed 3.4.1 back on to do a further test.  I created a table from scratch in 3.4.1.  I then tried to change the border thicknesses.  It just doesn't do it.  The border remains at the original .25 thickness. This has been confirmed by a second user of LibreOffice 3.4.1 in Linux.
Comment 2 Jeffrey 2011-07-14 19:32:20 UTC
Reproduced on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux. I see the same differences as the one you posted on your blog.
Comment 3 rm42 2011-07-18 07:13:58 UTC
Correction on my last comment.  Creating a table from scratch on 3.4.1 does allow one to change the thickness.  The problem is that when you close the table properties dialog and then go back to it, if you click on any of the borders in the preview, it doesn't tell you what the thickness of the line is.  It just shows you the default thickness.   The preview in the Table Properties dialog box shows no different in thickness until one reaches 2.0.  So, it seems to be impossible to tell what the assigned thickness is for any of the borders.

I see that the op bug has been marked as fixed. I'll submit the above as a new bug.  Although it may be more of a feature request.
Comment 4 Rainer Bielefeld Retired 2011-07-18 11:05:42 UTC
@reporter:
What's the difference between this one and "Bug 39336 - Table Properties Dialog doesn't show existing border thicknesses"?
Comment 5 rm42 2011-07-18 19:08:46 UTC
@ Rainer,

The difference is explained on that bug's comments.  They are very different issues.
Comment 6 Rainer Bielefeld Retired 2011-07-18 22:39:34 UTC
That's a 3.3.3 bug that has been fixed for 3.4.
I know that old OOo bug although I can't find the Issue.
I opened "test1.odt" with LibO3.4.1 and found double border (correct) 
I opened "test1.odt" with OOo 3.1.1  and found double border shown in Table Properties dialog (correct?), but rendered only simple thick line (incorrect)
I created an own test document showing 1 cell table with double line border with OOo 3.1.1 and found double border shown in Table Properties dialog (correct), but rendered only simple thick line (incorrect).

So this one is INVALID

@rm42:
Thank you for your attention!
Comment 7 Rainer Bielefeld Retired 2011-07-18 22:40:26 UTC
Created attachment 49285 [details]
Screenshots, see Comment 6
Comment 8 Steve Kelem 2011-07-19 16:03:00 UTC
Can someone please look at bug 38542. It's a related issue, and has been open since June 21 without any comments.

That bug contains an example of a file containing tables created in OpenOffice. When opened in LibreOffice 3.4.x, the table rules are huge, obscuring the contents of the table cells. The example is representative of hundreds of tables in my documents that are wrecked by the change to table border functionality.

It will be a huge hit to convert all my tables to the new format (there aren't Styles for tables, as in Framemaker, are there?) individually, by hand.

If the upgrade to 3.4 doesn't convert the tables to look the same in the new dialog, there should be some sort of guidance for the user to understand how the new options relate to the old ones. (The different double-lines look identical in the dialog until you apply them into a table!)