Download it now!
Bug 39336 - UI: Table Properties Dialog should show thicknes, style and color of a selected existing border line
Summary: UI: Table Properties Dialog should show thicknes, style and color of a select...
Status: RESOLVED DUPLICATE of bug 46583
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-18 07:26 UTC by rm42
Modified: 2012-08-20 20:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rm42 2011-07-18 07:26:09 UTC
When clicking on a border preview inside the Table Properties dialog the dialog should show the current thickness of the border.  Instead it remains at the default thickness of 0.25 pt.  And, since the preview in the Table Properties dialog box shows no different in thickness until one reaches 2.0, there is no way to tell what the existing thicknesses of the borders are.  This makes editing tables with borders of various thicknesses very hard.
Comment 1 Rainer Bielefeld Retired 2011-07-18 11:03:17 UTC
NOT reproducible with "LibreOffice 3.4.1  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:103)]" 

I believe this one is a DUP of "Bug 39227 - (rm42) 3.4.1 does not preserver table border formatting"?

@rm42:
You know that the preview shows borders of a selected (=highlighted) cell, not of the one where the caret is flashing?

May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport> carefully?
Then please:
- Write a meaningful Summary
- Attach a sample document (not only screenshot)
- Attach screenshots with comments (you can add information using LibO DRAW
  and then attach your screenshot with comments as PDF) if necessary
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem
- add information 
  -- what exactly is unexpected
  -- and why do you believe it's unexpected
  -- concerning your PC 
  -- concerning your OS
  -- concerning your LibO version and localization (UI language)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  –- If you can contribute an OOo Issue that might be useful
  -- everything else crossing your mind after you read a.m. URL
Can you please file Bug reports with status UNCONFIRMED if your are not absolutely sure that you contributed all required background information and that the problem will be reproducible with information you can provide? 

Thank you!
Comment 2 rm42 2011-07-18 13:37:27 UTC
This is not a dup. Bug 39227 was about a problem specific to 3.4.1.  This problem affects all versions of LibreOffice and OOo.  I tried explaining it in a few words.  Maybe I need to elaborate.

I understand what the preview show.  Say for example that we have a table with 2 rows and two columns.  We give the leftmost border of the table a thickness of 1.0 pt.  We close the table properties dialog.  Now we select the bottom left cell and go to Table Properties.  The preview shows a cell with left and bottom borders.  We know that the left border has a thickness of 1.0, because we just created it, but there seems to be no way to know that in the dialog.  The two borders look identical in the preview and when clicking on them nothing happens.  This is what I think is a problem.  When clicking on the left border of this preview the Width setting on the dialog should change to reflect the current width of that border, namely 1.0.  Is that clearer.
Comment 3 rm42 2011-07-18 13:47:31 UTC
Also, the current Style of the selected line should be displayed when clicked on in the preview.  If more than one line is selected in the preview, and they do not all share the same style, the Style setting should be blank.  

Similarly, when more than one line is selected in the preview, and they do not all share the same thickness, the Thickness setting on the dialog box should be blank.
Comment 4 Rainer Bielefeld Retired 2011-07-18 23:06:28 UTC
(In reply to comment #2)
> This is not a dup. Bug 39227 was about a problem specific to 3.4.1. 

Please excuse me, I was a little worried concerning some later comments and additional comments in the blog, but indeed, that was something completely different.

Concerning this one I still do not understand the exact problem, your comments are to rare to decide. Please avoid imprecise terms like "we see ...", but write, in pane xxx '1.25px'" is shown or similar. Please attach a sample document and screenshots for the various steps (please see my attachment in Bug 39227 for an example.

For me the borders always are shown correctly in the graphical preview of the Table Properties dialog, but a known problem is that you can't show the style and thickness of a particular line in the value panes or pickers, at least until today I did not find any way to do that. 

May be the problem you want to report is the following (names of menu items translated from German UI):
0. Create new WRITER document
1. Insert new table 2 rows 2 columns using 'Insert Table' icon from 
   Standard Toolbar
2. select left column (move mouse pointer above table above left column 
   until mouse pointer view changes to "select column", then click)
3. Menu 'Table -> Table Properties -> Borders'
4. Click on left border in preview
5. Increase width value to 5 pt,  <ok>
   As expected: thick left border

Now I want to modify width of that left border from ppt to 2,5 pt.
Expected: there should be a way to select the border, see the current width, decrease value from 5pt to 2,5

so 
6. If necessary, select row again as per step 2 
7. Menu 'Table -> Table Properties -> Borders'
   As expected, borders are shown in preview
   Unexpectedly border width will be shown 0.25pt. Why? When I create
   a table with all different borders, none 0,25pt, although default value
   0,25pt will be shown
8. Now try to get 5 pt for left border into the width value pane 
   (to have the possibility to decrease it afterwards), I did not find any.
Comment 5 rm42 2011-07-19 05:46:46 UTC
Yes, I think you got it.  Please note the following after step 7 (in your list):

8. Click on a border line in the preview. Hold down Ctrl and select another border line with different thickness.  Now both border lines are selected.

Expected: The Thickness setting should be either blank or say "Various".

Instead:  The Thickness value remains at 0.25 pt.
Comment 6 Rainer Bielefeld Retired 2011-08-17 01:12:57 UTC
Not a trivial problem, you can have a dozen lines in the preview, but only value pane. And selecting one of them to show the valueis a tricky thing.

But I agree, that can be improved.
Comment 7 Björn Michaelsen 2011-12-23 12:28:41 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 8 sasha.libreoffice 2012-01-27 10:52:24 UTC
problem remains in LibO 3.6.0 master
Comment 9 Michael Stahl (allotropia) 2012-08-20 20:31:49 UTC
there is already another enhancement request tracking almost
exactly the same thing that i've already easy-hackified (but
no takers yet), so resolving this one duplicate.

*** This bug has been marked as a duplicate of bug 46583 ***