Bug 39271 - Impress PDF export should support notes pages only
Summary: Impress PDF export should support notes pages only
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: Other All
: medium enhancement
Assignee: David Tardon
QA Contact:
URL:
Whiteboard: target:5.2.0
Keywords:
: 43034 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-15 13:10 UTC by gleppert
Modified: 2016-10-25 19:08 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
File created with pdf99s printer (8.44 KB, application/pdf)
2013-02-27 02:20 UTC, bugquestcontri
Details
Notes export as pdf for reference (41.63 KB, application/pdf)
2013-02-27 02:21 UTC, bugquestcontri
Details
Example-presentation-notes-printout-PDF.odp (13.17 KB, application/vnd.oasis.opendocument.presentation)
2014-01-13 10:38 UTC, Gerry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gleppert 2011-07-15 13:10:24 UTC
Currently, it is not possible to simply export the notes pages of an Impress presentation to PDF. 

If the option "Export Notes Pages" is enabled, the PDF export generates all the slides and appends the slides with notes. So the PDF-document has double the pages. Currently, there is no way to only export the notes pages.

There seems to be only an option missing to not export the slides, but only the notes pages. Hence, this must the an Easy Hack.
Comment 1 Björn Michaelsen 2011-12-23 12:28:44 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 gleppert 2012-03-23 00:40:25 UTC
This request for enhancement is still valid in 3.5.1
Comment 3 sasha.libreoffice 2012-03-29 00:37:36 UTC
Thanks for bugreport
For workaround on Linux, use File->Print instead of export to PDF
Comment 4 sasha.libreoffice 2012-03-30 04:49:59 UTC
*** Bug 43034 has been marked as a duplicate of this bug. ***
Comment 5 gleppert 2012-05-09 12:40:04 UTC
Could anyone mark this as EasyHack? IMHO it seems to be easy to solve.
Comment 6 Uwe Dippel 2012-09-07 08:48:14 UTC
(In reply to comment #3)
> Thanks for bugreport
> For workaround on Linux, use File->Print instead of export to PDF

Which does not work. So no work-around. I am on LibreOffice 3.5.4.2 
Build ID: 350m1(Build:2) (Ubuntu 12.04)
And when I File->Print, I can select Print->Document->Notes. And what I get, are the slides and the notes. No way to extract the Notes only.
Comment 7 sasha.libreoffice 2012-09-10 06:14:05 UTC
Indeed, not working. Prints exactly what we see on tab "Notes".
Comment 8 bugquestcontri 2013-02-27 02:17:16 UTC
Almost 3 years later I can confirm the same problem as described by gleppert@gmx.de.

I am on Version 3.6.5.2 (Build ID: 5b93205) with XPprof /SP3.

It would really be great if this bug could be fixed soon.

The workaround by sasha.libreoffice@gmail.com printing the Notes Pages via a normal pdf-printer also has a bug: When printed in portrait format a part of the information is cut off; see attachment: NotesPrintOutTest.pdf

For comparison I added a pdf-export of the same file

I can be contacted in case of additional questions.
Comment 9 bugquestcontri 2013-02-27 02:20:30 UTC
Created attachment 75615 [details]
File created with pdf99s printer

Steps done:

create presentation with LibO default template
clicked NOTES tab 
added information in the NOTES field
File / Print /  Select pdf995
Properties: Portrait and Advanced Paper size: A4
Print
Comment 10 bugquestcontri 2013-02-27 02:21:16 UTC
Created attachment 75616 [details]
Notes export as pdf for reference
Comment 11 retired 2014-01-12 16:22:12 UTC
Can we have exact repro steps and a test document for this bug? That would be very helpful to test and work on this.
Comment 12 Gerry 2014-01-13 10:38:39 UTC
Created attachment 91940 [details]
Example-presentation-notes-printout-PDF.odp

Here are the simple steps to reproduce this enhancement request. I think this enhancementshould be really easy, because the notes pages actually are exported in addition to the slides, but there is no option to ONLY export the notes pages. This, however, is a standard use case, e.g. to give students the notes pages.

Steps to reproduce:
* Open attached ODP file. It has 3 slides and each slide has notes.
* Click on file -> Export PDF and tick the "export notes" field and export it.
* The result is a PDF with 6 pages. The first 3 pages are the slides and the page 4-6 are the notes pages.

There should be an additional option to export ONLY the notes pages (in the example PDF page 4-6), because this is usually what is given to the students to study the presentation.

Current workarounds:
* Either one opens the PDF in a PDF reader and prints the pages 4-6 into a PDF.
* Or one opens the PDF in an PDF editing programme and cut out pages 1-3.

-> This is an annoying additional step which could be avoided by simply adding a new option: "Export only notes pages"
Comment 13 Frank 2014-05-17 19:13:06 UTC
I can confirm all of the behavior described in the above comments occur using LibreOffice 4.3 alpha.

I also agree that simply adding another check box for the slides themselves (probably checked by default??) and then just exporting/printing the elements checked (i.e. slides, notes, etc.) would be fine.
Comment 14 Commit Notification 2016-03-24 14:36:10 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6392347e27ed500b30acc62e9e27618eab5a8ee0

tdf#39271 allow to export only notes pages

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.