Download it now!
Bug 39454 - allow (show/hide) comments for selected cells (cell range)
Summary: allow (show/hide) comments for selected cells (cell range)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: Other All
: medium enhancement
Assignee: Rodolfo
URL:
Whiteboard: target:4.1.0
Keywords:
: 51193 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-21 09:48 UTC by wpiis
Modified: 2013-05-30 22:24 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wpiis 2011-07-21 09:48:46 UTC
Allow (show/hide/delete) comments for selected cells.
I tried to hide comments for a selected range of cells, but could not.

I had a comment (that was showing) that I wanted to past to other cells.
The paste worked OK, but all the comments were showing (I should have hidden the comments first).
I had to hide the comments individually.

Thanks, Tracey
Comment 1 Jeffrey 2011-07-24 19:40:21 UTC
Confirmed for LibreOffice 3.4  340m1(Build:103) on OpenSuse Linux. Right now the ability to show and delete comments only works for the selected cell in the marker. It does not apply to those that are highlighted in blue, and I guess it would be a nice functionality to include hiding multiple cells at once.
Comment 2 Björn Michaelsen 2011-12-23 12:28:53 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 gleppert 2012-04-08 10:50:36 UTC
This request for enhancement is still valid in LibreOffice 3.5.1
Comment 4 Cor Nouws 2012-11-23 23:06:56 UTC
It is possible already to delete comments from a cell range.
Comment 5 Cor Nouws 2012-11-23 23:08:04 UTC
I looked at the code to change this. Have saved some pointers and an idea how to change this. Will ask other devs for advise.
Comment 6 Not Assigned 2012-12-20 02:37:48 UTC
Rodolfo Ribeiro Gomes committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aa6373650746c261d76e61f9e00de12d521dcb75

fdo#39454 Allow (show/hide) comments for selected cells (cell range)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Cor Nouws 2012-12-20 07:48:06 UTC
ah, great news Rodolfo :-) Thanks!
Comment 8 Not Assigned 2012-12-20 13:26:34 UTC
Rodolfo Ribeiro Gomes committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9123db4ce8f1c20cf7b4f5a8ceaa66b6321ede14

Group undo actions when showing/hiding several notes once, fdo#39454



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Cor Nouws 2013-04-27 22:10:18 UTC
tested on a recent build. Is fine, thanks again!
Comment 10 Cor Nouws 2013-05-30 22:24:25 UTC
*** Bug 51193 has been marked as a duplicate of this bug. ***