Download it now!
Bug 51193 - VIEWING: Missing feauture: Show/Hide all comments in Calc
Summary: VIEWING: Missing feauture: Show/Hide all comments in Calc
Status: RESOLVED DUPLICATE of bug 39454
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-18 01:05 UTC by Zeki Bildirici
Modified: 2013-05-30 22:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zeki Bildirici 2012-06-18 01:05:44 UTC
Problem description: 
There is no option to Show/Hide All comments in Calc. It causes a big usability problem!

Steps to reproduce:
1. Create a spreadsheet document
2. Add some comments
3. Try to close them all by a single option.

Current behavior:
There is not such an option for Calc, while the other apps has it https://translations.documentfoundation.org/tr/libo_help/translate.html?unit=14560326

Expected behavior:
As to be focused on usability, to have this feauture

More: Similar to the bug https://www.libreoffice.org/bugzilla/show_bug.cgi?id=47753 

Think that someone have sent you a spreadsheet, has 50 comments on each page, which opens by default. Nightmare

Alternative workaround(not a realistic one): http://en.libreofficeforum.org/node/2811
Comment 1 Laurent Godard 2012-06-18 01:23:40 UTC
you may have a look at this extension
http://extensions.libreoffice.org/extension-center/shownotes
Comment 2 Zeki Bildirici 2012-06-18 01:52:45 UTC
(In reply to comment #1)
> you may have a look at this extension
> http://extensions.libreoffice.org/extension-center/shownotes

Hello,

Thanks for this extension. 

A small issue, the LibreOffice extension has the .ods file extension. I've changed it to oxt, even i have manage to install but it did not work :(

Then i installed it from AOOO extension site:
http://extensions.services.openoffice.org/en/project/ShowNotes Then it worked.

Could you update the LO's extension as a oxt file.

Btw i think you are the author of the extension. And thank you for this beautifull tool. 

But, imho, it is a neccessity and this extension or as anpther feature must be implemented to the deafult installation.

Regards,
Zeki
Comment 3 Laurent Godard 2012-06-18 02:30:35 UTC
done.
Comment 4 Zeki Bildirici 2012-11-17 13:10:49 UTC
It will be very nice to have this extension bundled in future releases.

Also it is a key point ppl devote LibreOffice with interoperability in business.

People receive spreadsheets related to their business, which are created by MS Office. They open it and recevie a full page with lots of comments, and no visible area. Seriously, it is funny to spend time to close all comments one by one, to see the content.[1]

People have not much time and patiance everytime.

I hope it will be fixed soon :)

Best regards,
Zeki




http://help.libreoffice.org/Common/Comment_1
Comment 5 Kohei Yoshida 2013-01-04 00:59:16 UTC
Confirming a feature request.
Comment 6 Cor Nouws 2013-05-30 22:24:25 UTC
:) is solved for 4.1
(sorry that I'm unable to hunt BugZilla for duplicates ;) )

*** This bug has been marked as a duplicate of bug 39454 ***