Bug Hunting Session
Bug 39477 - Mac Keyboard shortcut "Option" key doesn't show properly in the Customize dialog.
Summary: Mac Keyboard shortcut "Option" key doesn't show properly in the Customize dia...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.4.0 target:4.3.2 target:4.2.7
Keywords:
: 49280 (view as bug list)
Depends on:
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2011-07-22 08:57 UTC by daz-bugzilla
Modified: 2014-08-14 15:08 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Inconsistent key icons for Option and Control keyboard Shortcuts (Mac) (130.94 KB, image/png)
2011-07-22 08:57 UTC, daz-bugzilla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description daz-bugzilla 2011-07-22 08:57:40 UTC
Created attachment 49430 [details]
Inconsistent key icons for Option and Control keyboard Shortcuts (Mac)

I added a keyboard shortcut which used the Option key (on a Mac). The keystroke I wanted was Command-Option-Shift-S. However, the Tools -> Customize -> Keyboard dialog shows the wrong key icon, the "control" key instead of "option" key.

The menu and the actual shortcut to execute my "Sort" shortcut is Command-Option-Shift-S, and it shows up in the menu correctly.

However the Customize dialog box shows the Control Key, not the Option Key. 

The screenshot shows both the Customize dialog on the right (with the incorrect key symbol) and the Format menu, which shows the Sort... command with the correct symbol for Option.
Comment 1 Björn Michaelsen 2011-12-23 12:22:07 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Florian Reisinger 2012-08-14 13:58:27 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 3 Florian Reisinger 2012-08-14 13:59:44 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:04:20 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:06:32 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 daz-bugzilla 2012-08-14 17:00:40 UTC
Re-confirmed with LibreOffice 3.5.5.3

Changed status to "Reopened"
Comment 7 daz-bugzilla 2012-08-14 17:03:04 UTC
After reading FAQ, I'm setting status back to NEW on my bug.
Comment 8 Roman Eisele 2012-09-20 10:48:38 UTC
Bug was never confirmed by an independent reviewer, therefore reset Status to
UNCONFIRMED.

(No offence -- this does not mean that I doubt the existence of this bug --
when status is UNCONFIRMED, the chance is even better that a bugwrangler will
try to reproduce this issue or search for duplicates, while with Status NEW the
bug will probably just be overlooked.)

Also reset the Version field to 3.3.2. Please note that the Version field should always contain the FIRST version in which a bug is known to exist, NOT the last one, therefore please do NOT “update” the Version field.
Comment 9 Roman Eisele 2012-09-25 15:48:32 UTC
First, just a hint:

This could be a general problem, I mean, that the symbol for the Alt=Option key is wrong everywhere in the LibreOffice UI; cf. bug 49280 - “UI: Forms "next record" tooltip shows wrong shortcut”.
Comment 10 Roman Eisele 2012-09-25 17:20:25 UTC
Still REPRODUCIBLE with 
* LibreOffice 3.5.7.1 (Build ID: 3fa2330-e49ffd2-90d118b-705e248-051e21c)
* LibreOffice 3.6.2.1 (Build ID: ba822cc)
* LOdev 3.7.0.0.alpha0+ (Build ID: 6a8694d, pull time: 2012-09-20 05:53:26)
all on Mac OS X 10.6.8.

In the dialog window “Customize” (available via “Tools > Customize...”), tab “Keyboard”, ALL keyboard shortcuts with the Option/Alt key show the wrong symbol: they show the symbol used by Apple for the Control key:

⌃ UP ARROWHEAD [U+2303]

instead of the symbol used by Apple for the Alt/Option key:

⌥ OPTION KEY [U+2325]

This seems to be a general problem in LibreOffice: while the actual menus use the correct symbol, do dialogs and tooltips use the wrong symbol (cf. bug 49280).
Comment 11 Roman Eisele 2012-09-25 18:04:51 UTC
Already in LibO 3.3.0 (so reset version number), and not limited to Calc, but a general UI problem, present in all components.
Comment 12 Roman Eisele 2012-09-26 15:53:27 UTC
@ Mac OS experts:

Hello Norbert, hello Thorsten --

this is a Mac OS UI issue, which seems minor at the first glance, but is nevertheless of importance, because it is very irritating especially for long-time Mac OS users.

For example I myself thought for a long time that it was *impossible* in OOo/LibreOffice to assign any keyboard shortcuts which involve the Option/Alt key, because the “Customize” dialog window seems to show only keyboard shortcuts combined with Shift and Control key. Only after some tests I realized that it is just the symbol which is wrong -- the dialog window uses the ⌃ symbol, but it should use the ⌥ symbol instead which is the standard Mac Option/Alt key symbol.

As daz-bugzilla has pointed out (see his nice screenshot!), this also means an important inconsistency: as long as we are in the “Customize” dialog window, the ⌃ symbol is used, but the real menus use the correct ⌥ symbol. This inconsistency is irritating, too.

NB: This may be very well a general problem, not limited to the “Customize” dialog. As bug 49280 -- “UI: Forms "next record" tooltip shows wrong shortcut” shows, the wrong Option/Alt symbol ⌃ is also used in tooltips (very probably in *all* tooltips, not only in “next record”), and I suspect that it will be also used elsewhere throughout LibreOffice.

So maybe there is just a single central definition of the symbol which is wrong and must be changed. (I have even searched the code for it, but LibreOffice is too complex and my code reading facilities are too limited to find where the problem lies.)

Can you please take a look at this bug? As said above, this looks like a minor issue, but it is really irritating.

Thank you very much!
Comment 13 Julien Nabet 2014-07-28 21:18:03 UTC
On MacOs 10.9.4 with master sources updated some days ago, I could reproduce this.
I submitted for review this patch: https://gerrit.libreoffice.org/10600
Comment 14 Commit Notification 2014-08-12 08:23:14 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=76e46a52706711c11f1f62373d0db5262dd2be2f

fdo#39477: Mac Keyboard shortcut Option key ko in Customize dialog



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2014-08-12 13:28:58 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e401d50cf6c2ab09b7dd13165a179a94d86e9301&h=libreoffice-4-3

fdo#39477: Mac Keyboard shortcut Option key ko in Customize dialog


It will be available in LibreOffice 4.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Julien Nabet 2014-08-12 19:15:44 UTC
As I indicated in the patch, there's still a problem of order of symbols between menu shortcut and the 2 shortcuts in Customize dialog
Comment 17 Julien Nabet 2014-08-12 19:16:29 UTC
*** Bug 49280 has been marked as a duplicate of this bug. ***
Comment 18 Commit Notification 2014-08-14 15:08:18 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d4928dde73ca036e6337eb089faca3c8c2c93445&h=libreoffice-4-2

fdo#39477: Mac Keyboard shortcut Option key ko in Customize dialog


It will be available in LibreOffice 4.2.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.