Bug 49280 - UI: Forms "next record" tooltip shows wrong shortcut
Summary: UI: Forms "next record" tooltip shows wrong shortcut
Status: RESOLVED DUPLICATE of bug 39477
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-29 12:38 UTC by gpircher
Modified: 2015-04-03 06:29 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
tool tip (72.51 KB, image/png)
2012-09-01 22:00 UTC, gpircher
Details
base as demo (140.88 KB, application/vnd.oasis.opendocument.database)
2012-09-01 22:23 UTC, gpircher
Details
English shortcut symbol problem (69.73 KB, image/png)
2012-09-25 16:57 UTC, daz-bugzilla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gpircher 2012-04-29 12:38:55 UTC
Problem description: 

Steps to reproduce:
1. Open form for editing records
2. Hover with mouse over button "next record" to see tooltip

Current behavior:
shows symbols for cmd-ctrl-right

Expected behavior:
cmd-alt-right is the correct shortcut

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; de; rv:1.9.2.28) Gecko/20120308 Camino/2.1.2 (MultiLang) (like Firefox/3.6.28)
Comment 1 Rainer Bielefeld Retired 2012-04-29 21:49:55 UTC
NOT reproducible with "LibreOffice 3.5.3.2 (RC2) German UI/Locale [Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80] on German WIN7 Home Premium (64bit) 

NOT reproducible width "LibreOffice 3.5.0 RC2 English UI/Locale [Build-ID: e371a95-bf68a13-5a1aa2b-d3c1ae9-b938258] on German WIN7 Home Premium (64bit) 

Seems to be Mac related
Comment 2 Jochen 2012-08-27 18:36:36 UTC
Hi reporter,

exits the problem still?
If yes: please attach a screenshot.
Comment 3 gpircher 2012-09-01 22:00:59 UTC
Created attachment 66473 [details]
tool tip

The tooltip displays the wrong shortcut cmd-ctrl-right which is frustrating.
Correct were cmd-alt-right.
Comment 4 Jochen 2012-09-01 22:05:19 UTC
Hi reporter,

please attach the concerned base-file
Comment 5 gpircher 2012-09-01 22:23:21 UTC
Created attachment 66475 [details]
base as demo

Just 3 record contained, but behaviour as described.
Open form Eingabe.
Comment 6 gpircher 2012-09-01 22:24:30 UTC
I used LO 3.5.1.2
Comment 7 gpircher 2012-09-01 22:47:18 UTC
Still the same with LO 3.6.1.2 (MacOS_PPC)
Comment 8 Jochen 2012-09-02 09:22:42 UTC
Hi reporter,

I try to reproduce your bugreport. But I found no error in LO 3.5.5 and LO 3.6.x (OS: Windows 7 and Windows XP).

First I would like to clarify what you mean with "bug".
In attach 1 I see "Nächster Datensatz(<symbol>^->)".
For LO 3.5.5 in German version of LO I see "Nächster Datensatz (Strg+Alt+Nach links" (i.e. no symbol but only text). This is correct.
For LO 3.6.1 in German version of LO same correct behavior.

Conclusion:
Perhaps a problem on your PC or a problem with OS MAC.

Proposal:
Look for a another MAC-User using LibreOffice in your circle of friends or post the problem on a mailing-list of LibreOffice (if you ar German e.g. on discuss@de.libreoffice.org
Comment 9 Roman Eisele 2012-09-25 15:43:58 UTC
To quote the original problem:

(In reply to comment #0)
> Current behavior:
> shows symbols for cmd-ctrl-right
> 
> Expected behavior:
> cmd-alt-right is the correct shortcut

Still REPRODUCIBLE with LibreOffice 3.5.7.1 and 3.6.2.1 (Build ID: ba822cc) on Mac OS X 10.6.8 (Intel).

Definitely a simple, Mac-only problem: The tooltip shows the symbols for Command-Control-Right, but the correct shortcut is Command-Alt(=Option)-Right, the symbol is just wrong. The same is true in the tooltip for “Previous Record”.

I suspect that there is a general problem with the symbol for Alt=Option in LibreOffice for Mac OS X; IIRC it is often (generally?) displayed with the Symbol for Control. Option=Alt should look (like on Apple’s keyboards and in all other Mac OS X applications):

----\--------
     \
      \
       ------

But currently the symbol for Control is used, similar/identical to an Ascii-Circumfluex:

  /\
 /  \
/    \

Some more research is necessary to show if this is a general problem, I mean, if the symbol is wrong everywhere.
Comment 10 Roman Eisele 2012-09-25 15:47:00 UTC
A first hint in the direction of a general problem: cf. bug 39477 - “Mac Keyboard shortcut "Option" key doesn't show properly in the Customize dialog”.
Comment 11 Jochen 2012-09-25 16:15:24 UTC
(In reply to comment #10)
> A first hint in the direction of a general problem: cf. bug 39477 - “Mac
> Keyboard shortcut "Option" key doesn't show properly in the Customize
> dialog”.

Question: can German localization-team help? IMHO: no. Who can solve the problem?
Comment 12 daz-bugzilla 2012-09-25 16:57:12 UTC
Created attachment 67690 [details]
English shortcut symbol problem
Comment 13 daz-bugzilla 2012-09-25 17:07:44 UTC
(In reply to comment #12)
> Created attachment 67690 [details]
> English shortcut symbol problem

My attachment shows the same problem, where the control symbol in the tool tip should be the Option/Alt symbol.

⌥ OPTION KEY [U+2325]
⌃ UP ARROWHEAD [U+2303]

This incorrect symbol is also in bug 39477. It does look like a more general problem than just these two specific locations in the UI on Macs.

LibreOffice 3.5.5.3 (English)
Build ID: 7122e39-92ed229-498d286-15e43b4-d70da21
Comment 14 Roman Eisele 2012-09-25 17:40:37 UTC
Already REPRODUCIBLE with LibreOffice 3.3.0, so the problem is very probably inherited from OOo.
Comment 15 Roman Eisele 2012-09-25 18:02:29 UTC
(In reply to comment #11)
> Question: can German localization-team help? IMHO: no. Who can solve the
> problem?

Good question. We can just ask some developers with Mac experience and hope that they look into it or (if they have no time for that) provide some hints about where in the code the problem is located:
* Thorsten Behrens <tbehrens@suse.com>
* Norbert Thiebaud <nthiebaud@gmail.com>
* maybe Stephan Bergmann <sbergman@redhat.com>
Comment 16 Roman Eisele 2012-09-26 15:54:31 UTC
(In reply to comment #15)
> (In reply to comment #11)
> > Question: can German localization-team help? IMHO: no. Who can solve the
> > problem?
> 
> Good question. We can just ask some developers with Mac experience and hope
> that they look into it or ...

I have forwarded bug 39477 (the more general issue) to Thorsten and Norbert, and *hope* that one of them finds the time to take a look at this issue.
Comment 17 Julien Nabet 2014-08-12 19:16:29 UTC
The problem was almost identical since there's a problem of key order in fdo#39477 (see https://bugs.freedesktop.org/show_bug.cgi?id=39477#c16)

*** This bug has been marked as a duplicate of bug 39477 ***
Comment 18 Adolfo Jayme 2015-04-03 06:29:55 UTC
Removing duplicate bug from the dependency list of bug 42082 for a cleaner view.