Bug 39599 - EDITING, FILEOPEN SVG TEXT INKSCAPE
Summary: EDITING, FILEOPEN SVG TEXT INKSCAPE
Status: RESOLVED DUPLICATE of bug 32248
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-27 06:16 UTC by cernym
Modified: 2013-06-19 06:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
SVG File with text "nazdar" (1.95 KB, image/svg+xml)
2011-07-27 06:16 UTC, cernym
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cernym 2011-07-27 06:16:00 UTC
Created attachment 49613 [details]
SVG File with text "nazdar"

When I make a .svg file in Inkscape with some text - "nazdar" and try to open it using LibreOffice 3.3.2 OOO330m19 (Build:202) or OpenOffice 3.2.0 OOO320m12 (Build:9483), text is missing. I don't know if this is bug in Libre(Open)Office or Inkscape. SVG file is included as an attachment.

Regards,
M.C.
Comment 1 Rainer Bielefeld Retired 2011-07-27 08:26:59 UTC
[Reproducible] with "LibreOffice 3.4.1 RC3 - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:203)]". Text also not visible with 3.3.3 Portable, So Version -> 3.3.3.
OOo 3.3.0 with external SVG Extension shows text.

We have some similar bugs with similar results for me (Seamonkey and OOo show
text, LibO not:
Bug 39554 - Insert->Picture->From File... *.SVG not correctly
Bug 32248 - FILEOPEN SVG no TEXT visible
Bug 37994 - Wrong import of SVG files

We should try to get some order into this issue.

@cernym@seznam.cz:
Your OS is?
Comment 2 cernym 2011-07-28 07:16:14 UTC
(In reply to comment #1)
> [Reproducible] with "LibreOffice 3.4.1 RC3 - WIN7  Home Premium (64bit) German
> UI [OOO340m1 (Build:203)]". Text also not visible with 3.3.3 Portable, So
> Version -> 3.3.3.
> OOo 3.3.0 with external SVG Extension shows text.
> 
> We have some similar bugs with similar results for me (Seamonkey and OOo show
> text, LibO not:
> Bug 39554 - Insert->Picture->From File... *.SVG not correctly
> Bug 32248 - FILEOPEN SVG no TEXT visible
> Bug 37994 - Wrong import of SVG files
> 
> We should try to get some order into this issue.
> 
> @cernym@seznam.cz:
> Your OS is?

My OS is: Linux - Fedora release 13 (Goddard) 2.6.34.9-69.fc13.x86_64 #1 SMP
Comment 3 tester8 2011-07-31 10:58:24 UTC
Reproduced with

LO 3.4.2 OOO340m1 (Build:202)
Ubuntu 10.04.3 x86
Linux 2.6.32-33-generic Russian UI
Comment 4 rk601 2011-08-16 17:46:49 UTC
We tested the "nazdar.svg" picture and have found the Master:

LibO-dev 3.5.0 
Build ID: 5849f74-15fcc2a-4eb4f62-260b7c1
On OSX 10.6.8

Located at:

http://dev-builds.libreoffice.org/daily/MacOSX_10.6.7_Intel_no-moz/master/2011-08-14_14.14.45

with

master~2011-08-14_14.14.45_LibO-Dev_OOO350m1_MacOS_x86_install_en-US.dmg  

to display the picture but with an INCORRECT FONT please see

Bug #40088 - ERROR in Font when insert SVG picture while EDITING
Comment 5 Björn Michaelsen 2011-12-23 13:24:57 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 6 ign_christian 2013-06-19 06:54:32 UTC
Very similar with Bug 32248
- texts on .svg created with Inkscape
- appear blank on Draw

*** This bug has been marked as a duplicate of bug 32248 ***