Bug 37994 - FILEOPEN: Text missing in SVG
Summary: FILEOPEN: Text missing in SVG
Status: RESOLVED DUPLICATE of bug 32248
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.0 RC1
Hardware: Other Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-06 07:55 UTC by Mario
Modified: 2013-12-09 11:09 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
ZIP file with example files. (288.54 KB, application/zip)
2011-06-06 07:55 UTC, Mario
Details
EDTA structure. (8.91 KB, image/svg+xml)
2012-01-26 02:29 UTC, kanyi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mario 2011-06-06 07:55:12 UTC
Created attachment 47607 [details]
ZIP file with example files.

I wanted to use a SVG file in Impress, but I couldn't import it properly.

I've added a zip file containing all relevant files.

"SVG-example.svg" is the original file.
"SVG-example Inkscape.pdf" is the correct looking PDF of the original SVG file.
"SVG-example via File-Open.pdf" is the result, when I open the svg file using the menue "File" and "Open ..."
"SVG-example via Insert-Image-From File.pdf" is the result, when I import the svg file using the menue "Import" / "Image" / "From File ..."

Opening the svg looses the text and some fillings, but importing the svg results in a totally unusable graphic.
Comment 1 tester8 2011-06-06 12:03:15 UTC
Reproduced with Ubuntu 10.04.2 x86
LO 3.4
Comment 2 Rainer Bielefeld Retired 2011-07-27 08:34:06 UTC
CONFIRMED Due to Comment 1
OS modified due to Comment 1

We have some similar bugs with text import problems
Bug 39554 - Insert->Picture->From File... *.SVG not correctly
Bug 32248 - FILEOPEN SVG no TEXT visible
Bug 39599 EDITING, FILEOPEN SVG TEXT INKSCAPE

We should try to get some order into this issue.

@Mario:
We can't handle such "SVG looks like crap" reports, here we will concentrate on Text import problem, it might be useful to file separate reports with reference to this one for different problems (only 1 problem / report!). 

Your OS is?
Comment 3 Björn Michaelsen 2011-12-23 13:23:34 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 4 kanyi 2012-01-26 02:29:10 UTC
Created attachment 56171 [details]
EDTA structure.

In Draw, the characters are in wrong place and wrong size.
Comment 5 Florian Reisinger 2012-08-14 14:03:24 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:04:19 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 14:08:51 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 8 Florian Reisinger 2012-08-14 14:10:52 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 9 sasha.libreoffice 2012-09-07 09:24:42 UTC
Reproduced in 3.6.1 on Fedora 64 bit using File->Open
Comment 10 ComputerHotline 2013-08-30 08:01:28 UTC

*** This bug has been marked as a duplicate of bug 68682 ***
Comment 11 Jorendc 2013-11-17 19:49:44 UTC
Unlinking duplicate + set again as NEW
Comment 12 Jon Grossart 2013-11-26 06:55:42 UTC
Are you using Inkscape?

I've found that using Inkscape, the text won't import correctly unless you either:

1) "Convert to Text" (from the FlowedText)
2) Covert object to path (which will make the file much bigger).

Otherwise, text will just import as a black box. Some of this is because the FlowedText is specific to Inscape and not to SVG.
Comment 13 Owen Genat (retired) 2013-12-08 10:47:24 UTC
(In reply to comment #2)
> We have some similar bugs with text import problems 
> ...
> Bug 32248 - FILEOPEN SVG no TEXT visible

In all honesty I think this bug can safely be closed a duplicate of the bug Rainer indicated. Comment #4 is an unrelated issue. This report was specifically about *missing* text.
Comment 14 retired 2013-12-09 11:09:51 UTC

*** This bug has been marked as a duplicate of bug 32248 ***