Bug 68682 - SVG Inkscape are not readed correctly
Summary: SVG Inkscape are not readed correctly
Status: RESOLVED DUPLICATE of bug 32248
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: x86 (IA32) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-28 19:59 UTC by ComputerHotline
Modified: 2013-12-08 10:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test SVG File (15.93 KB, image/svg+xml)
2013-08-28 19:59 UTC, ComputerHotline
Details
Screenshots of provided SVG under Inkscape and various LO versions. (751.75 KB, application/zip)
2013-12-08 10:19 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ComputerHotline 2013-08-28 19:59:09 UTC
Created attachment 84813 [details]
Test SVG File
Comment 1 ComputerHotline 2013-08-28 20:00:31 UTC
Open this file in Inkscape.
Open this file in LibreOffice.
There some differences :
* layout is modified
* some shapes are modified
* layers of this SVG file are not readed
* text not appear
Comment 3 ComputerHotline 2013-08-30 08:01:28 UTC
*** Bug 37994 has been marked as a duplicate of this bug. ***
Comment 4 ComputerHotline 2013-08-30 08:02:28 UTC
Not only the same bug nĀ°37994
Comment 5 Owen Genat (retired) 2013-12-08 10:19:05 UTC
Created attachment 90449 [details]
Screenshots of provided SVG under Inkscape and various LO versions.

This bug is very general and essentially a duplicate of a few other specific bugs, as pointed out in comment #2. For reference, earlier reports take precedence, so generally (except in special circumstances) the later bug is closed as a duplicate of the earlier bug. I am attaching a collection of screenshots indicating the appearance under Ubuntu 10.04 x86_64 of the provide SVG in Inkscape v0.47 and in these versions of Draw:

- v3.3.0.4 OOO330m19 Build: 6
- v3.4.6.2 OOO340m1 Build: 602
- v3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
- v3.6.7.2 Build ID: e183d5b
- v4.0.6.2 Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24
- v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

There has been general improvement in handling of SVGs. There is also a difference in display between using File > Open... and Insert > Picture..., with the second option offering correct rendering since v3.5.7.2. The main problems exhibited with the first option are:

- No text being displayed. This is bug 32248, and as indicated in comment seventeen: "The text is there, if you insert the *.svg image into a Draw document, but it is missing, if you use File > Open."
- Area fill of star is occluded. This is likely bug 48064. The W3C test file for this bug is almost identical i.e., a star without inner fill.
- Linear gradient fill of pentagon is rotated. This is bug 47439.

The problems reported here are already documented in other reports.
Comment 6 Owen Genat (retired) 2013-12-08 10:21:56 UTC
As per comment #5 I am marking this bug RESOLVED as a DUPLICATE of bug 32248 as that is the most prominent problem.

*** This bug has been marked as a duplicate of bug 32248 ***