Bug 39647 - Writer starts with LO document recovery
Summary: Writer starts with LO document recovery
Status: RESOLVED DUPLICATE of bug 39510
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.2 RC2
Hardware: Other All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Document-Recovery
  Show dependency treegraph
 
Reported: 2011-07-28 11:31 UTC by gleppert
Modified: 2017-10-07 09:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gleppert 2011-07-28 11:31:46 UTC
When using LibreOffice Writer 3.4.2rc2 with large documents, I encounter a reproducible bug when restarting LibreOffice: With large documents LibreOffice always starts into the "Document Recovery". However, there was no crash. There is no noticeable problem when exiting the application. Also, the files were always saved before exiting LO.

System: Ubuntu 11.04, gnome 2, LibreOffice 3.4.2rc2, Intel 32-bit

P.S. Maybe this bug is related to bug 39427. However, this problem here occurs in Linux and with .odt-files.
Comment 1 manj_k 2011-07-29 14:57:13 UTC
Maybe similar to 
'Bug 39447 - Writer crashes at closing a document with footnotes in a single paragraph over two pages',
'Bug 39510 - writer-file causes crash since version 3.4.2 rc1 and rc2'?

(Please have also a look at
https://bugs.freedesktop.org/show_bug.cgi?id=39427#c8)
Comment 2 Rainer Bielefeld Retired 2011-07-30 00:00:51 UTC
[Reproducible] with "LibreOffice 3.4.1 RC3 - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:203)]". I got a confidential sample document for investigation, all symptoms reminded me to, "Bug 39510 - writer-file causes crash since version 3.4.2 rc1 and rc2", and also the results of later investigation of manj_k showed reasons for the crash I see in the document: paragraphs with footnotes spread over 2 pages. So I am pretty sure that this one is a DUP of Bug 39510 (or at least related), what itself is a DUP of "Bug 39447 - Writer crashes at closing a document with footnotes in a single paragraph over two pages". 

I see something different to Bug 39447 and Bug 39510, sample for this document also crashes when I scroll.

But I am pretty sure that all those bugs have common roots, so DUP

This is a very serious problem, makes LibO unusable for documents with many footnotes like scientific documents.

@gleppert:
Can you please check whether FIX for Bug 39510 also will heal your problem?

*** This bug has been marked as a duplicate of bug 39510 ***
Comment 3 Rainer Bielefeld Retired 2011-07-30 00:47:22 UTC
Correction concerning Comment 2: of course it is "LibO 3.4.2 RC3"

@gleppert
One thing in your document is different to other documents I tested concerning all these footnote issues: For me your sample document also crashes with 3.4.2RC3 when I scroll down. The crash appears when I reach the table of contents. I can't tell whether that problem is related to the footnote problem.
Comment 4 gleppert 2011-07-30 05:06:50 UTC
@Rainer: I had consistent crashes with this document in 3.3.3 due to problems in the Graphite smart fonts stack. Could you refer your crash description to a developer being responsible for the Graphite stack? I am quite sure that this is related.
Comment 5 Björn Michaelsen 2011-12-23 13:23:04 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.