Download it now!
Bug 39815 - UI Paste with key shortcut in the Find bar is not working properly.
Summary: UI Paste with key shortcut in the Find bar is not working properly.
Status: RESOLVED DUPLICATE of bug 49853
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-03 13:28 UTC by Bogdan
Modified: 2012-05-27 00:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bogdan 2011-08-03 13:28:06 UTC
The problem appeared first when the new Find bar was introduced in 3.4.1 (I believe). The problem is that when you have the find textbox focused and use Commad+V to paste something the text will be pasted in the document body instead of the find textbox. Using Control+Click and Paste from the context menu works as expected, the pasted text appears in the find textbox.

Steps to reproduce:
1. copy some text in the clipboard;
2. open or create a new Spreadsheet or Writer document;
3a. press Command+F to bring up the Find bar;
3b. alternatively just click on the find textbox if it is already visible in the bottom bar
4. press Command+V to paste the text.
At this point the text should have been pasted in the find textbox, but instead it appears in the main document body.

I have experienced this problem on OS X 10.6.7, 10.6.8 and 10.7 with all versions of LibreOffice since the new find bar was introduced.
Comment 1 Jeffrey 2011-08-04 20:06:50 UTC
Failed to reproduce on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux. Do you mean select the find tool bar? I'm interpreting find textbox as the one with Find in grey. Because if you select that and copy it works fine. If you only click on the toolbar it does't work as expected.
Comment 2 Jean-Baptiste Faure 2011-08-21 08:06:03 UTC
Problem confirmed by another Mac users on LibreOffice 3.4.2. So problem specific to MacOS.
Using Cmd+Alt+F instead Cmd+F opens standard Find&Replace dialog and works as expected.

Best regards. JBF
Comment 3 Bogdan 2011-08-21 14:53:34 UTC
Yes, this is an OS X specific problem. I didn't test on Linux, but on Windows it did work as expected.
Comment 4 Tim 2011-09-29 07:46:25 UTC
I can also confirm this is happening in OS X 10.6.8, running LibreOffice 3.4.3 OOO340m1 (Build:302)
Comment 5 Björn Michaelsen 2011-12-23 12:29:47 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 6 Pete K. 2012-01-19 11:44:41 UTC

*** This bug has been marked as a duplicate of bug 42729 ***
Comment 7 Roman Eisele 2012-05-27 00:34:35 UTC
This is a known issue with LibreOffice for MacOS X, and the main bug report for
it is now bug 49853; therefore I mark this report as a duplicate of the
latter. Please refer to the report page for bug 49853 for further details and
discussion.

*** This bug has been marked as a duplicate of bug 49853 ***