Bug 39881 - Fixing the search feature in Calc
Summary: Fixing the search feature in Calc
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: All All
: highest enhancement
Assignee: Sean Mitchell
QA Contact:
URL:
Whiteboard: target:4.2.0
Keywords: difficultyInteresting, easyHack, skillCpp
: 47426 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-06 06:17 UTC by Leonard Brown
Modified: 2015-12-16 00:22 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Illustrates problem with LibO Calc search feature (647.70 KB, application/pdf)
2011-08-15 06:44 UTC, Leonard Brown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leonard Brown 2011-08-06 06:17:03 UTC
I have been waiting forever for OOo to implement a "Find all" feature that searches all pages by default and gives a list of clickable results. I am now hoping that LibreOffice calc will implement this soon.
Comment 1 Leonard Brown 2011-08-06 06:27:07 UTC
I have 3 files that I open at work daily using another application because Calc lacks this feature.
Comment 2 Leonard Brown 2011-08-15 06:44:11 UTC
Created attachment 50233 [details]
Illustrates problem with LibO Calc search feature

I have attached a file to further illustrate what the problem is.
Comment 3 Björn Michaelsen 2011-12-23 12:26:57 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 Leonard Brown 2011-12-23 22:31:25 UTC
No action has been taken to address the issues raised
Comment 5 labinnsw@yahoo.com.au 2012-04-20 05:13:37 UTC
Version 3.5 is out and this issue has not been addressed. Sadly, I didn't miss any of the improvements that we made. I am confident that if the developers wanted to, they could fix this problem. I just can not understand why they don't want to.
Comment 6 Roman Eisele 2012-05-03 09:43:35 UTC
This is a Calc issue, therefore changed the 'Component' field accordingly. This will make it easier to find this report, I hope.

This is an enhancement request, not a bug report, therefore changed the 'Importance' field accordingly.
Comment 7 labinnsw@yahoo.com.au 2012-05-12 07:47:17 UTC
I can appreciate the reasons for the changes even if I don't agree with them. Just want to point out that when anything bugs me, I regard it as a bug.

It really is a pity that the only attention I cannot get is that of the developers.

Yes I know it is free, but they will accept contributions so...
Comment 8 labinnsw@yahoo.com.au 2012-06-03 00:32:15 UTC
Do I really need to wait until I retire in another 15 years or so, plus another 2 or so years that it may take me to learn programming (If I live that long)  for this to be fixed?
Comment 9 Jean-Baptiste Faure 2012-06-03 02:57:08 UTC
*** Bug 47426 has been marked as a duplicate of this bug. ***
Comment 10 labinnsw@yahoo.com.au 2012-06-03 07:27:20 UTC
Hmm... dotting the Is and crossing the Ts of bug reporting protocol. I wonder if this means that action is being taken to fix the bug, or should I just consider all the time and effort I have already put into filing this bug in the hope of helping to improve Libre Office, a waste of time?
Comment 11 labinnsw@yahoo.com.au 2012-07-14 11:44:15 UTC
(In reply to comment #10)
> Hmm... dotting the Is and crossing the Ts of bug reporting protocol. I wonder
> if this means that action is being taken to fix the bug, or should I just
> consider all the time and effort I have already put into filing this bug in the
> hope of helping to improve Libre Office, a waste of time?

Answer: Yes.
Comment 12 Michael Meeks 2012-11-08 20:09:20 UTC
Hi there, thanks for your bug report - competitive analysis and write-up.

This is an enhancement request; as such it needs someone to take an interest in the issue and come up with a patch. In the absence of any volunteers to do that this might take some time:

> Do I really need to wait until I retire in another 15 years or so, plus 
> another 2 or so years that it may take me to learn programming

Well - you could interleave the tasks & learn to program now, and find a new job in S/W engineering with your new skills :-)

Anyhow - I'll make it an easy hack by adding some code pointers to your nice description.
Comment 13 Michael Meeks 2012-11-08 20:18:13 UTC
It looks like we should fix the find dialog to be modelled on the gnumeric one.

First we should convert that dialog to a .ui file so we can tweak the layout; cf.

http://wiki.documentfoundation.org/Development/WidgetLayout

and svx/inc/svx/srchdlg.hxx - SvxSearchDialog.

It needs to be 'tabbed' and glade-ified inside SvxSearchDialog and the sub-classes checked;

Then we can add this 'Matches' tab, and embed a table with the results (presumably as well as selecting them on the screen to avoid changing functionality).

Quite a big chunk of work - but hopefully with some positive results.

We should prolly rid ourselves of the expander, and move those less frequently used options to the Advanced tab.
Comment 14 Sean Mitchell 2012-11-21 11:13:42 UTC
I'm going to try to start working on this over the next week.
Comment 15 Leonard Brown 2012-11-21 13:06:17 UTC
(In reply to comment #14)
> I'm going to try to start working on this over the next week.

I am the happiest man in the world today.
Comment 16 Caolán McNamara 2013-05-03 09:26:28 UTC
The find and replace dialog is now converted to .ui format as svx/uiconfig/ui/findreplacedialog.ui
Comment 17 Commit Notification 2013-09-20 14:33:51 UTC
Matuš Kukan committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=09a546ed1f4ca691ab9a81e0a0a08ec53f99a558

fdo#39881 change Find All behaviour in Calc



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 Michael Meeks 2013-09-20 15:24:49 UTC
Wow - nice work Matus ! :-) don't forget:
https://wiki.documentfoundation.org/ReleaseNotes/4.2
when you're done ? :-)
Comment 19 Leonard Brown 2013-09-25 12:05:33 UTC
From the results of my tests, I would say the this bug is fixed in 4.2 Alpha0+ Master. I'm as proud as punch. Michael Meeks and Matúš Kukan are my new heroes.
I would love to have their autographed pictures.

Respect due to all Liberoffice Development crew.
Comment 20 Leonard Brown 2013-09-25 13:45:31 UTC
Guess I'm too excited to pay attention to spelling.
Comment 21 Michael Meeks 2013-09-25 13:52:36 UTC
Nothing to do with me - Matus is the main man here :-) nice work Matus !
Comment 22 Eike Rathke 2013-10-31 20:41:16 UTC
@Matúš:
Please don't forget to add your nice work to https://wiki.documentfoundation.org/ReleaseNotes/4.2#Calc :-)  best with a screenshot of the new result dialog.
Comment 23 Matúš Kukan 2013-11-13 12:27:54 UTC
(In reply to comment #22)
> @Matúš:
> Please don't forget to add your nice work to
> https://wiki.documentfoundation.org/ReleaseNotes/4.2#Calc :-)  best with a
> screenshot of the new result dialog.

Yep, sorry, only now briefly edited it
Comment 24 Leonard Brown 2014-06-26 13:44:48 UTC
This was fixed. As of tonight it is back to square one. I am no longer getting a list of results to click. 

Ubuntu 14.04
64 bit
Libreoffice 4.2.4.2
Build ID: 420m0(Build:2)
Comment 25 Leonard Brown 2014-06-28 02:30:18 UTC
Has anybody else tested this latest problem yet. Could it be an Ubuntu issue?
I am seeing a somewhat similar issue with Google Chrome. (A window I expect to load doesn't)
Comment 26 ign_christian 2014-06-28 04:03:18 UTC
(In reply to comment #24)
Not reproducible in 4.2.5.2 (installed from official PPA), it works flawlessly.

Tested with Ubuntu 12.04 32bit
Comment 27 Leonard Brown 2014-06-28 04:57:12 UTC
4.2.5.2 works perfectly
Ubuntu 14.04
64 bit

Thanks ign_christian
Comment 28 Robinson Tryon (qubit) 2015-12-16 00:22:15 UTC
Migrating Whiteboard tags to Keywords: (EasyHack,DifficultyInteresting,SkillCpp )
[NinjaEdit]