Bug 47426 - EDITING: Search feature inadequate
Summary: EDITING: Search feature inadequate
Status: RESOLVED DUPLICATE of bug 39881
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: All All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-16 22:26 UTC by labinnsw@yahoo.com.au
Modified: 2012-07-14 11:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This document illustrates the problem (647.70 KB, application/pdf)
2012-03-16 22:26 UTC, labinnsw@yahoo.com.au
Details

Note You need to log in before you can comment on or make changes to this bug.
Description labinnsw@yahoo.com.au 2012-03-16 22:26:46 UTC
Created attachment 58583 [details]
This document illustrates the problem

I have been waiting forever for OOo to implement a "Find all" feature that
searches all pages by default and gives a list of clickable results. I am now hoping that LibreOffice calc will implement this soon.

I have 3 files that I open at work daily using another application because Calc
lacks this feature.
Comment 2 labinnsw@yahoo.com.au 2012-03-18 08:14:32 UTC
(In reply to comment #1)
> http://extensions.libreoffice.org/extension-center/search-in-calc

The attached document illustrates why this solution is only a partial one. 
It can only search one sheet at a time.
It has no options
It must be relaunched for each new search

The attached document also illustrates how a perfect solution might work (Gnumeric) and how an adequate solution might work.(MS Excel)
Comment 3 labinnsw@yahoo.com.au 2012-04-20 05:17:11 UTC
Version 3.5 is out and this issue has not been addressed. Sadly, I didn't miss
any of the improvements that we made. I am confident that if the developers
wanted to, they could fix this problem. I just can not understand why they
don't want to.
Comment 4 m.a.riosv 2012-04-20 14:50:38 UTC
Please can you explain why an improvement must be highest an critical?
I can't see it. IMHO only regression or crashing bugs can have this status.
Comment 5 labinnsw@yahoo.com.au 2012-04-20 18:44:00 UTC
(In reply to comment #4)
> Please can you explain why an improvement must be highest an critical?
> I can't see it. IMHO only regression or crashing bugs can have this status.

If that is the case, I can't. Can you tell me how I can get the developers to give some attention to this bug for which finding a fix is of the highest importance and which needs the most urgent attention? I have been trying for years.

It is the only feature of any importance where both OOo and LibreOffice lag behind both MS Excel and Gnumeric.
Comment 6 m.a.riosv 2012-04-24 17:43:07 UTC
I am agree with you, it is an interesting feature.
But I think shout it is not the best to get right attention.
Get support from other user, would be good.
I don't see this improvement in the list of new features in 3.6:
http://wiki.documentfoundation.org/ReleaseNotes/3.6

May be is easy to get the attention from developer of the extension.
Comment 7 labinnsw@yahoo.com.au 2012-04-28 06:10:19 UTC
(In reply to comment #6)
> I am agree with you, it is an interesting feature.
> But I think shout it is not the best to get right attention.
> Get support from other user, would be good.
> I don't see this improvement in the list of new features in 3.6:
> http://wiki.documentfoundation.org/ReleaseNotes/3.6
> 
> May be is easy to get the attention from developer of the extension.

Guess what, of the features listed in the link, I already fixed what I needed by customising menus and using macros. I was not aware of a problem with the others.

    Ctrl-D - Fixed by customizing menu

    New option to specify a custom sheet - Unaware of any issues

    Improved performance of pivot table. - Unaware of any issues

    Marked cells in Calc can now be merged via the right mouse click - Unaware of any issues

    Improved error message for invalid sheet name. - Unaware of any issues

    Export conditional formatting to xlsx (Markus Mohrhard) - Unaware of any issues 

    Improved CSV file import. - Unaware of any issues

    Added a "Save cell formulas instead of calculated values" - Unaware of any issues

Cut and Insert (another request of mine which was ignored) Fixed with macro and menu costomising
Comment 8 labinnsw@yahoo.com.au 2012-06-03 00:33:12 UTC
Do I really need to wait until I retire in another 15 years or so, plus another
2 or so years that it may take me to learn programming (If I live that long) 
for this to be fixed?
Comment 9 Jean-Baptiste Faure 2012-06-03 02:57:08 UTC
Filling several identical bug reports, will not boost your request for enhancement.
Set as duplicate of bug 39881.

*** This bug has been marked as a duplicate of bug 39881 ***
Comment 10 labinnsw@yahoo.com.au 2012-06-03 07:17:27 UTC
Lots of advice about what won't work. Thanks for that. Any advice about what will?
Comment 11 labinnsw@yahoo.com.au 2012-07-14 11:42:44 UTC
(In reply to comment #10)
> Lots of advice about what won't work. Thanks for that. Any advice about what
> will?

Answer: Yes, nothing.