Bug 39905 - VIEWING: Shape with transparent gradient color filling only visible in presentation mode, not in edit mode.
Summary: VIEWING: Shape with transparent gradient color filling only visible in presen...
Status: RESOLVED DUPLICATE of bug 33591
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-07 11:22 UTC by Rainer Bielefeld Retired
Modified: 2013-11-24 22:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This file show some issues with transpareny gradients. (17.30 KB, application/vnd.oasis.opendocument.presentation)
2011-08-08 03:26 UTC, Raphaël
Details
Simple sample created due to Comment 1 (11.90 KB, application/vnd.oasis.opendocument.presentation)
2011-08-08 04:09 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-08-07 11:22:34 UTC
This problem has been reported by raph_82@hotmail.com with this sample document
<https://bugs.freedesktop.org/attachment.cgi?id=50017> (accidently attached in "Bug 36766 - [Task] Gradient and Transparency issues")

Steps to reproduce:

1. Open test document
   First slide seems to be completely black (with some white test at the top)
2. Start presentation mode
   Expected: First slide  completely black (with some white test at the top)
   Actual: a Ghost smiley picture

I see that with "LibreOffice 3.4.2  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:203)]", also with "LibreOffice Portable 3.3.3  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:301  Tag 3.3.3.1)]" 

OOo 3.1.1 does not show anything on slide 1, not in edit mode, not in presentation mode.

An sample document concerning a similar (or the same) problem you find here
<https://bugs.freedesktop.org/attachment.cgi?id=44974> in Bug 35681, attention, that one might have a wrong subject line.

@Fabian, Raphaël:
Can you find out with what version what of the problems started?

@Raphaël:
How has the sample been created with what software?
Comment 1 Raphaël 2011-08-08 03:05:04 UTC
The file in attachment was created with LibreOffice 3.4.2 OOO340m1 (Build:203). 

A way, among others, to reproduce the problem is the following:

1) Draw a shape (circle, square, ghost, ...);

2) Fill it with the color you want (in the attachment I chose black forms on black background to create the mystery, but the problem occurs with every color);

3) Right-click Area -> Transparency -> Gradient

All kinds of gradients are concerned (linear, radial, quadratic, ...).


The problem was already there in the first release of LibreOffice (3.3.0). But all was ok in OpenOffice 3.2, so probably this bug was introduced during the migration from OpenOffice to LibreOffice.
Comment 2 Raphaël 2011-08-08 03:26:12 UTC
Created attachment 50024 [details]
This file show some issues with transpareny gradients.

Note that problems occurs not only with dark background, but as well with white background. See my second attachment (Gradient_test.odp). 

Moreover, it seems that this strange behavior comes from two different issues:

1) There is a problem in the rendering process (objects with gradients are displayed differently in editing and in presentation mode);

2) Gradients are not always correctly displayed even in editing mode. See the two rectangles in my second attachment: by increasing the gradient transparency from 10% to 11%, you switch from completely white to completely green.

I created and tested this file with LibO 3.4.2, on Windows XP SP3.
Comment 3 Rainer Bielefeld Retired 2011-08-08 04:06:39 UTC
Wrong description, it's not a gradient, but color object filling with transparency gradient.

This one is a DUP of "Bug 33591 - Area transparency turns gray in presentation mode". Transparent black shape still is black in front of black page background and so it's invisible. That's shown correctly in edit mode. In Presentation mode some grey will be added to the transparency, and that grey makes the shape visible.

@Raphaël:
Than you for additional information.
Please! Do not spread around samples that have nothing to do with the bug report, I have some difficulties to recognize relation of your examples with the bug report subject line "Gradient picture only visible in presentation mode, not in edit mode". So I will delete the attachment in this bug.

But of course your sample shows really unexpected and intolerable effects. My tests seem to confirm your expectations in the last sheet, there is a problem (also in DRAW) with  transparent gradient color shape fillings if start value and end value are the same, but that's not a Presentation problem, but a DRAW problem. In presentation mode those transparencies are shown correctly.

I will check Bugzilla and file a new report using your example, if it's not already reported.

*** This bug has been marked as a duplicate of bug 33591 ***
Comment 4 Rainer Bielefeld Retired 2011-08-08 04:09:23 UTC
Created attachment 50025 [details]
Simple sample created due to Comment 1

Changing background to white you will see the smiley shape
Comment 5 Rainer Bielefeld Retired 2011-08-08 04:11:08 UTC
Comment on attachment 50024 [details]
This file show some issues with transpareny gradients.

Gradient_test.odp is concerning a completely different problem