Bug 39959 - Find-and-replace doesn't search all tables anymore
Summary: Find-and-replace doesn't search all tables anymore
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-09 07:32 UTC by Merlin
Modified: 2018-12-31 16:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Merlin 2011-08-09 07:32:18 UTC
Hello all,

I'm using LibreOffice 3.4.2. Using Calc's search-and-replace (Ctrl+Alt+F) dialog it was always possible to search all sheets in the document by pressing "more options" and activating the checkmark on the bottom "search in all tables" (not sure about the exact title of the checkmark - German localization: "in allen Tabellen suchen")

For some reason, the checkmark on the bottom appears to be ignored. Whether checked or unchecked - the search is only performed on the currently active sheet.

Reproducing is easy:
1. Open a new document
2. Enter "asdf" in A1
3. Activate Sheet2
4. Try Find-and-replace (Ctrl+Alt+F) to search for "asdf"
Whether the checkbox "in allen Tabellen suchen" is activated or not: LibO Calc 3.4.2 never seems to find the text.

(BW: Another faulty behavior also occured to me: The search never seems to include the current cell. In the above example, the search won't find "asdf" if cell A1 in sheet1 is marked. But that bug has been reported already.)

Thanks to the developers for their continued work!
Greeting from Germany,
Dirk
Comment 1 vitriol 2011-08-09 07:47:58 UTC
Reproducible only if you have previously used the FindBar, for me. Probably related to Bug 33593.
Analogous bug in OOo:

http://openoffice.org/bugzilla/show_bug.cgi?id=116250

See comment 8.
Comment 2 Merlin 2011-08-09 10:12:20 UTC
(In reply to comment #1)
> Reproducible only if you have previously used the FindBar, for me.
Yes, I agree. 
That might be a very helpful observation.

When the FindBar hasn't been used yet, the Dropdown field "Find in" (German localization: "Suchen in") is preset to someting, e.g. "values". Once the FindBar has been used, the "Find in" field is preset to empty. Maybe the change to "values" or "formulas" is ignored?

Greetings,
Dirk
Comment 3 Jeffrey 2011-08-13 22:30:33 UTC
Confirmed for LibreOffice 3.4  340m1(Build:103) on OpenSuse Linux.

On the English version the option is "Search in All Sheets". The search does not work across all sheets, and after the search and replace, the box automatically disables.
Comment 4 Paolo Basenghi 2011-08-21 06:52:48 UTC
Confirmed with LibreOffice 3.4.2 on Windows XP X64, italian translation.
When opened and not already used the search bar (CTRL+F), the search dialog (CTRL+ALT+F) works and search all sheets if checked the checkbox.
When used after the search bar, the search dialog works only in the current sheet even when the "Search in all sheets" checkbox is activated.
Comment 5 vitriol 2011-08-21 07:20:04 UTC
It seems fixed on 3.4.3 RC1, probably by the same fix of Bug 33593.
I mark this bug as work for me for now.
Comment 6 Merlin 2011-08-30 11:24:47 UTC
I tested with LibO 3.4.3RC2.

Like Vitriol discovered on RC1, it seems to be fixed in 3.4.3.

Thanks a lot to you all!
Dirk
Comment 7 Commit Notification 2018-12-31 16:35:08 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/3acc80fe226df82738b5738d018532913bbc432d%5E%21

uitest for bug tdf#39959

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.