Bug 40047 - Impossible to globally style hyperlinks in Impress
Summary: Impossible to globally style hyperlinks in Impress
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ImpressDraw-Styles Hyperlink
  Show dependency treegraph
 
Reported: 2011-08-12 10:08 UTC by Sean Carlos
Modified: 2018-12-12 18:52 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sean Carlos 2011-08-12 10:08:35 UTC
Usability guidelines say hyperlinks should be underlined to provide users with a visual clue that text can be clicked on to navigate to another part of a document or to another document.  This is of course important for digital versions of documents (odp, pdf), less so (if not at all) for hardcopy versions.

Unfortunately Impress does not underline hypertext links nor does it provide a way to globally style text links.  The link color can be changed by using LibreOffice's setting "Tools -> Options -> Appearence -> Unvisited / Visited Links.  But there is no way to underline all links without manually changing each one, a tedious task in the age of css and styles!

Writer provides a specific style for hypertext links, "Internet Link", internally called "Internet_20_link".  Unfortunately, this text style is not available in Impress.  I would like to see it added (actually Impress style management should be brought up to the level of writer in general, but this is the use case that most specifically impacts me).
Comment 1 Jeffrey 2011-08-13 06:56:48 UTC
Confirmed for LibreOffice 3.4  340m1(Build:103) on OpenSuse Linux.

I think it would be nice to add a formatting option in tools->option->appearance, so underline can be set on or off depending of preferences.
Comment 2 Björn Michaelsen 2011-12-23 12:35:14 UTC Comment hidden (obsolete)
Comment 3 sasha.libreoffice 2012-01-30 06:45:22 UTC
reproduced in LibO 3.6.0 master on Fedora 64 bit
and Impress try to go to link immediately after mouse click (expected use Ctrl-Click as in Writer)
Comment 4 Sean Carlos 2012-06-29 23:29:22 UTC
Updated to note problem still exists in 3.6.0.0.beta2
Comment 5 Roman Eisele 2012-07-09 06:57:44 UTC
(In reply to comment #4)
> Updated to note problem still exists in 3.6.0.0.beta2

Please note that the Version field should always the FIRST version in
which a bug is known to exist, and NOT the last one. So please don’t "update"
the version field, only state in your comments that a bug is still reproducible
in a specific new version of LibreOffice. Thank you!
Comment 6 Dennis Roczek 2017-04-03 16:33:40 UTC
problem still exists with 5.3. :-(
Comment 7 Cor Nouws 2018-12-12 18:52:44 UTC
is directly related to the fact that character styles are missing in Impress/Draw