Download it now!
Bug 128810 - Adding Character Styles to Impress
Summary: Adding Character Styles to Impress
Status: RESOLVED DUPLICATE of bug 40871
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-15 01:14 UTC by csongor
Modified: 2019-11-15 12:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description csongor 2019-11-15 01:14:49 UTC
Description:
I would like to have Character Styles in Impress. 

Now, if I create a style based on a selection of a single character and apply it later then it applies it for the whole paragraph, not just the selected characters. 

I want to write bullet points of normal texts with some code samples inside them. I wanted to define a style for the code snippets but if it gets applied to the whole paragraph then it does not help.

Example:

Data Types:
- string ("abcd")
- integer (12)
- float (3.14)

The characters that I surrounded here by parenthesis, should be written with a monospaced font (eg. Courier) and the name of the types should be written with a proportional font (eg. Arial).

Currently, I cannot do this with styles and if I have many code samples in my presentation then I need to do everything manually. 

Steps to Reproduce:
1. create a bullet point list with 2 points, two words in each
2. reformat a word in the first line to be bold (or red, whatever)
3. define a style based on the selection
4. apply the style on one word in the second bullet point

Actual Results:
The whole list becomes bold (red, whatever)

Expected Results:
Just the selected word should change


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2019-11-15 12:10:39 UTC
Thanks for reporting this issue.
Already reported in bug 40871

*** This bug has been marked as a duplicate of bug 40871 ***