Bug 40871 - [FORMATTING] Impress and Draw should support character styles (and maybe paragraph, list styles?)
Summary: [FORMATTING] Impress and Draw should support character styles (and maybe para...
Status: RESOLVED DUPLICATE of bug 152652
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ImpressDraw-Styles
  Show dependency treegraph
 
Reported: 2011-09-14 04:38 UTC by Aurelien Naldi
Modified: 2022-12-23 14:54 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Presentation with custom styles for paragraph and characters (12.92 KB, application/vnd.oasis.opendocument.presentation)
2021-05-25 13:29 UTC, Regina Henschel
Details
Screenshot from PowerPoint (22.11 KB, image/png)
2021-05-25 16:41 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aurelien Naldi 2011-09-14 04:38:05 UTC
It is common to highlight some words in a presentation, notably by using bold fonts and colors (at least for me). As far as I can tell, the presentation module doesn't have a GUI to select a character style so this has to be done manually, making it annoying to do and painfull to do in a consistent way, especially if we want to ajust the color later on.

As far as I can tell, the corresponding ODF relies on "local styles" anyway, so the backend should already support character styles, only the GUI is missing: the 

Would it be possible to change the stylist used in the presentation and drawing modules to also show text styles (both paragraph and character styles)?

Thanks!
Comment 1 Björn Michaelsen 2011-12-23 12:32:42 UTC Comment hidden (obsolete)
Comment 2 sasha.libreoffice 2012-03-22 08:16:30 UTC
Thanks for bugreport with new idea

> It is common to highlight some words in a presentation, notably by using bold
> fonts and colors (at least for me). As far as I can tell, the presentation
Please, attach presentation with described animation. Developers will see how it should be in presentation. And will improve UI for do it more handy.
Comment 3 Florian Reisinger 2012-08-14 13:57:27 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 13:58:48 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:03:22 UTC Comment hidden (obsolete)
Comment 6 Florian Reisinger 2012-08-14 14:05:37 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2015-09-12 15:04:17 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2015-09-12 15:05:26 UTC
*** Bug 93709 has been marked as a duplicate of this bug. ***
Comment 9 Alex 2016-04-11 18:29:39 UTC Comment hidden (me-too)
Comment 10 Buovjaga 2016-04-12 09:54:24 UTC
(In reply to Alex from comment #9)
> Is adding support for character styles in impress a very difficult problem?
> If it's something simple that developers won't get to because it's not a
> high priority, then I would be happy to explore a code fix myself.

Too many bugs & enhancements and too little hands :)
It would be fantastic, if you would explore it https://wiki.documentfoundation.org/Development/GetInvolved

You can join the developer IRC channel, if you get stuck: https://wiki.documentfoundation.org/Website/IRC
Comment 11 Xisco Faulí 2019-11-15 12:10:39 UTC
*** Bug 128810 has been marked as a duplicate of this bug. ***
Comment 12 Timur 2020-10-07 13:48:49 UTC
*** Bug 137297 has been marked as a duplicate of this bug. ***
Comment 13 Heiko Tietze 2021-05-25 11:58:41 UTC
Regina, Mike: Is it possible to use PS/CS in Draw/Impress? Don't think so.
Comment 14 Regina Henschel 2021-05-25 13:29:05 UTC
Created attachment 172326 [details]
Presentation with custom styles for paragraph and characters

The attached file has custom styles for paragraphs and characters. I have created the document by moving the styles from <office:automatic-styles> to <office:styles>. The ODF validator considers it as valid. PowerPoint shows it correctly.

It has a custom character style for yellow background color and one for bold, and a custom paragraph style for first line indent.

The presentation has a text box and a custom shape rectangle with text, that use these styles.

So yes, ODF allows custom styles for text in shapes. But it is no only a part to be added in the UI, the whole implementation is missing in LibreOffice.
Comment 15 Heiko Tietze 2021-05-25 16:28:55 UTC
(In reply to Regina Henschel from comment #14)
> It has a custom character style for yellow background color and one for
> bold, and a custom paragraph style for first line indent.

Don't get any character formatting. Please attach a screenshot too.
Comment 16 Regina Henschel 2021-05-25 16:37:00 UTC
(In reply to Heiko Tietze from comment #15)
> Don't get any character formatting. Please attach a screenshot too.

As I said, "not implemented in LibreOffice". Open it in PowerPoint.
Comment 17 Regina Henschel 2021-05-25 16:41:34 UTC
Created attachment 172334 [details]
Screenshot from PowerPoint
Comment 18 Heiko Tietze 2021-05-26 08:50:02 UTC
From UX POV we entries in the sidebar tab for PS and CS with the usual tree of styles and access to the property dialogs via context and main menu.
Comment 19 Ming Hua 2021-06-09 17:29:36 UTC
*** Bug 142743 has been marked as a duplicate of this bug. ***
Comment 20 Eyal Rozenberg 2021-06-09 17:41:46 UTC
The inaccessibility/unavailability of character styles is a proper bug. This is obvious both from the comparison from PowerPoint by Regina, and in light of my argument in the now-duped 142743, which I'll let myself repeat here...

In Impress, one definitely needs multiple paragraphs (and other slide objects) to have consistent style, and to be able to change that style for them all at once. But it is also the case that one may need sequences of text _within_ (different) paragraphs or slide objects to share a style, and to be able to change that style for them all at once. It is not an esoteric use-case to want to style:

* Internet Links
* Emphasized words/phrases
* Source code keywords
* Placeholder text
* Inline quotations

etc. So, marking this as a normal-severity bug.
Comment 21 Buovjaga 2021-06-09 17:58:36 UTC Comment hidden (off-topic)
Comment 22 Eyal Rozenberg 2021-06-09 18:13:29 UTC Comment hidden (off-topic)
Comment 23 Buovjaga 2021-06-09 18:16:21 UTC Comment hidden (off-topic)
Comment 24 Eyal Rozenberg 2021-06-09 18:55:44 UTC Comment hidden (off-topic)
Comment 25 Mike Kaganski 2021-06-09 19:00:06 UTC Comment hidden (off-topic)
Comment 26 Eyal Rozenberg 2021-06-09 21:15:59 UTC Comment hidden (off-topic)
Comment 27 Heiko Tietze 2021-06-11 08:19:06 UTC
*** Bug 142751 has been marked as a duplicate of this bug. ***
Comment 28 Heiko Tietze 2021-06-11 08:20:04 UTC
*** Bug 82664 has been marked as a duplicate of this bug. ***
Comment 29 Eyal Rozenberg 2022-10-03 09:58:44 UTC
I've clarified the title to also cover paragraph styles. If anyone believes the two issues should be split (character vs paragraph) - feel free to do that.
Comment 30 Cor Nouws 2022-10-04 13:48:29 UTC
On 2020-10-22 I've changed the Summary
from
   [FORMATTING EDITING UI] Presentation module should support paragraph and character styles
to
  [FORMATTING] Impress and Draw should support character styles (and maybe more paragraph styles?) 

For the following reason: formatting 'paragraphs' is basically provided for by the styles for Outline 1-10 and Header, that are part of each of the slide masters.

But indeed, as you suggest Eyal, a separate issue for 'paragraph' styles might make sense.
Comment 31 Eyal Rozenberg 2022-10-04 14:39:34 UTC
(In reply to Cor Nouws from comment #30)
> For the following reason: formatting 'paragraphs' is basically provided for
> by the styles for Outline 1-10 and Header, that are part of each of the
> slide masters.

That's only true for the elements which are already present in the slide master, but is not true for paragraphs anything you insert into the slide: Extra text boxes, callouts, table cells etc.

So, given that, and the wording of OP's first comment, and considering the example Regina created has both CS and PS's, are you sure we should separate the bugs?
Comment 32 Eyal Rozenberg 2022-12-19 21:29:36 UTC
So, I noticed Rafael Lima's dupe also requested list styles in Impress/Draw - which are also missing.

I therefore repeat my question - for Cor, Heiko, Aurelian, Rafael and others: 

Should we keep this as a single bug for adding Character, Paragraph and List styles, or should we split it up?

... if nobody answers, I will: 

1. Be disappointed
2. Create separate bugs for each of the three kinds of styles missing from Impress/Draw.
3. Create a meta-bug to track all of them and bug 151264
4. Close this bug as a dupe of the new meta-bug
Comment 33 Rafael Lima 2022-12-19 21:54:18 UTC Comment hidden (off-topic)
Comment 34 Heiko Tietze 2022-12-20 12:00:13 UTC
This ticket has received a lot attention (and is flagged as highly important therefore). Splitting it up has no benefit as the implementation of one styling likely brings also the other. My understanding is that we do have PS, yet limited, but not CS. But the question is ultimately up to the developers.
Comment 35 Eyal Rozenberg 2022-12-20 20:05:30 UTC
(In reply to Heiko Tietze from comment #34)
> Splitting it up has no benefit as the implementation of one
> styling likely brings also the other.

Really? I mean, if we had Character Styles, would that give us List Styles? And Table Styles?

> My understanding is that we do have PS, yet limited

There's no UI for it, so we don't have it. Or - do you mean at the ODF level?

> but not CS.

And not List Styles, nor Table Styles.


> This ticket has received a lot attention (and is flagged as highly important
> therefore). 

Well, we could ameliorate this by also putting everyone on the CC lists of the relevant specific bug and the meta bug, and make comments on the dupe explaining what has gone where. I'm willing to do that.

Alternatively, we could keep this bug as the meta bug.
Comment 36 Buovjaga 2022-12-21 06:02:27 UTC
(In reply to Eyal Rozenberg from comment #35)
> (In reply to Heiko Tietze from comment #34)
> > Splitting it up has no benefit as the implementation of one
> > styling likely brings also the other.
> 
> Really? I mean, if we had Character Styles, would that give us List Styles?
> And Table Styles?

We don't have real table styles to begin with: https://wiki.documentfoundation.org/Development/GSoC/Ideas#Implement_table_styles
Comment 37 Heiko Tietze 2022-12-21 06:48:05 UTC
(In reply to Buovjaga from comment #36)
> We don't have real table styles...

Maxim submitted a lot of patches recently to make TS shine in sd. See https://gerrit.libreoffice.org/q/owner:momonasmon%2540gmail.com
Cannot find quickly the ticket about harmonization of TS between Writer/Calc and sd.
Comment 38 Buovjaga 2022-12-21 07:04:36 UTC
(In reply to Heiko Tietze from comment #37)
> (In reply to Buovjaga from comment #36)
> > We don't have real table styles...
> 
> Maxim submitted a lot of patches recently to make TS shine in sd. See
> https://gerrit.libreoffice.org/q/owner:momonasmon%2540gmail.com
> Cannot find quickly the ticket about harmonization of TS between Writer/Calc
> and sd.

Better ref, see Mike's comment in https://wiki.documentfoundation.org/Development/Budget2022#Table_Styles_improvements
Comment 39 Eyal Rozenberg 2022-12-22 21:39:51 UTC
(In reply to Buovjaga from comment #36)
> We don't have real table styles to begin with:
> https://wiki.documentfoundation.org/Development/GSoC/
> Ideas#Implement_table_styles

I know, and we really should... that's bug 151264, which is currently marked related to this one.
Comment 40 Cor Nouws 2022-12-23 10:05:42 UTC
(In reply to Eyal Rozenberg from comment #32)

> 1. Be disappointed
If that helps, why not ;)

> 2. Create separate bugs for each of the three kinds of styles missing from
> Impress/Draw.
Yes, please do.
Wrt 'paragraph' styles, I think we need proper analyses on what makes sense in Impress/Draw.
Comment 41 Eyal Rozenberg 2022-12-23 14:23:42 UTC
The new meta-bug 152652 will track individual bugs for different style categories.

*** This bug has been marked as a duplicate of bug 152652 ***
Comment 42 Eyal Rozenberg 2022-12-23 14:54:53 UTC
So, have split up the bug. I've added you all to the CC list of the new meta-bug (152652) - please add yourselves to the CC lists for the specific bugs of the style categories you're interested in following (Character, Paragraph, List, Table, Page/Slide).