Download it now!
Bug 137297 - Improved styles handling in Impress (add List and Character Styles)
Summary: Improved styles handling in Impress (add List and Character Styles)
Status: RESOLVED DUPLICATE of bug 40871
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.0.1.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-06 17:40 UTC by Rafael Lima
Modified: 2020-10-07 13:48 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2020-10-06 17:40:59 UTC
On Impress there are two types of styles that currently are not present, however they would be very useful:

1) List Styles: would allow the user to define different list formatting to be quickly applied to each new line. Because most presentations are structured using list outlines, this could significantly improve user experience.

2) Character Styles: would enable the definition of character-based styles, which could be applied when the user inputs some text in a sentence such as an equation or programming code. With this feature the user will be able to alternate between styles inside the same sentence in a more productive manner.

Both of these types are available in Writer, but not in Impress. Currently Impress only supports Drawing and Presentation styles.

I am a very frequent user of Writer/Impress and I can tell that in Writer these types of styles help a lot. And on Impress it would make it much easier to prepare presentations with better styling.

Would this feature be too hard to implement into Impress as well?
Comment 1 Timur 2020-10-07 13:48:49 UTC
Looks duplicate. 
If so, feel free to write there a summary with this. 
If not, please explain.

*** This bug has been marked as a duplicate of bug 40871 ***