Download it now!
Bug 40088 - SVG import shows rectangles instead of text
Summary: SVG import shows rectangles instead of text
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Draw-Images SVG-Open
  Show dependency treegraph
 
Reported: 2011-08-14 14:26 UTC by rk601
Modified: 2018-06-20 17:03 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Pictures and SVG files of ERROR in Font Rendering when Insert SVG Picture while EDITING (408.45 KB, application/zip)
2011-08-14 14:26 UTC, rk601
Details
LibO 3.5 Renders SVG in ERROR on OSX - Examples (177.32 KB, application/zip)
2011-08-15 05:01 UTC, rk601
Details
FONT ERROR using nazdar.svg in LibO 3.5 Master (149.17 KB, application/zip)
2011-08-16 17:40 UTC, rk601
Details
Result + Screenshot, See Comment 5 (284.23 KB, application/vnd.oasis.opendocument.graphics)
2011-09-02 23:37 UTC, Rainer Bielefeld Retired
Details
font-error.svg (59.51 KB, image/svg+xml)
2015-12-01 10:44 UTC, Xisco Faulí
Details
nazdar.svg (1.95 KB, image/svg+xml)
2015-12-01 10:45 UTC, Xisco Faulí
Details
Insert-Image in 6.0.4 font-error SVG (160.11 KB, image/png)
2018-06-16 13:37 UTC, Roman Kuznetsov
Details
Insert-Image in 6.0.4 nazdar (17.13 KB, image/png)
2018-06-16 13:38 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rk601 2011-08-14 14:26:23 UTC
Created attachment 50210 [details]
Pictures and SVG files of ERROR in Font Rendering when Insert SVG Picture while EDITING

Excellent progress has been made with regard to SVG and LibreOffice! Kudos to everyone involved!

We have tested over 100 SVG pictures and have found the Master:

LibO-dev 3.5.0 
Build ID: 5849f74-15fcc2a-4eb4f62-260b7c1
On OSX 10.6.8

Located at:

http://dev-builds.libreoffice.org/daily/MacOSX_10.6.7_Intel_no-moz/master/2011-08-14_14.14.45

with

master~2011-08-14_14.14.45_LibO-Dev_OOO350m1_MacOS_x86_install_en-US.dmg  

to perform quite well with regard to rendering the picture and consistency.

However, on occasion, LibO-dev 3.5.0 (Build ID: 5849f74-15fcc2a-4eb4f62-260b7c1) renders Fonts incorrectly on OSX 10.6.8.

Please use the attached SVG file called "SVG_Font-Error.zip" and follow these steps to reproduce:
1. Download "SVG_Font-Error.zip" from attachment above
2. Extract the "SVG_Font-Error.svg" picture file
2. Open NEW empty DRAW document
3. Menu 'Insert -> Picture -> From file...'
4. Browse for "SVG_Font-Error.svg" and open
   Expected: Picture will be inserted with ALL monospaced fonts
   Actual: Picture will be inserted with SOME monospaced fonts.

Same FONT result when insert to WRITER document.

Please see the "OSX-Safari-Correct-Font.png" image of how the SVG file looks in Safari. Also see the "LibO3.5-Draw-Font-Error.png" image of how the same SVG file looks in LibO-dev 3.5.0 DRAW.
Comment 1 rk601 2011-08-15 04:59:05 UTC
Further SVG testing has shown that LibO-dev 3.5.0 has problems rendering SVG pictures with the following:

LibO-dev 3.5.0 
Build ID: 5849f74-15fcc2a-4eb4f62-260b7c1
On OSX 10.6.8

Located at:

http://dev-builds.libreoffice.org/daily/MacOSX_10.6.7_Intel_no-moz/master/2011-08-14_14.14.45

with

master~2011-08-14_14.14.45_LibO-Dev_OOO350m1_MacOS_x86_install_en-US.dmg

On occasion, LibO-dev 3.5.0 (Build ID:
5849f74-15fcc2a-4eb4f62-260b7c1) renders SVG pictures incorrectly on OSX 10.6.8.

Please use the attached SVG file called "SVG Error in WRITER - LibO 3.5 dev.zip" and follow these
steps to reproduce:
1. Download "SVG Error in WRITER - LibO 3.5 dev.zip" from attachment above
2. Extract the "Blue-Folder.svg" picture file
3. Open NEW empty WRITER document
4. Menu 'Insert -> Picture -> From file...'
5. Browse for "Blue-Folder.svg" and open
   Expected: Picture will be inserted and a Blue Folder will appear
   Actual: Picture "outline" appears.

Same result when insert to DRAW document.

Please see the "Blue-Folder in Safari OSX 10.6.8.png" image of how the SVG file looks in
Safari. Also see the "Blue-Folder Error in WRITER - LibO 3.5 dev.png" image of how the same SVG
file looks in LibO-dev 3.5.0 WRITER.

Thank you.
Comment 2 rk601 2011-08-15 05:01:02 UTC
Created attachment 50230 [details]
LibO 3.5 Renders SVG in ERROR on OSX - Examples
Comment 3 rk601 2011-08-16 17:40:22 UTC
Created attachment 50291 [details]
FONT ERROR using nazdar.svg in LibO 3.5 Master

Further investigation of this error shows that it may be related to 

Bug #39599 - EDITING, FILEOPEN SVG TEXT INKSCAPE 

LibO-dev 3.5.0 shows the TEXT but does NOT show the correct FONT when rendering SVG file "nazdar.svg" picture with the following:

LibO-dev 3.5.0 
Build ID: 5849f74-15fcc2a-4eb4f62-260b7c1
On OSX 10.6.8

Located at:

http://dev-builds.libreoffice.org/daily/MacOSX_10.6.7_Intel_no-moz/master/2011-08-14_14.14.45

with

master~2011-08-14_14.14.45_LibO-Dev_OOO350m1_MacOS_x86_install_en-US.dmg

Please use the attached SVG file called "FONT-ERROR-nazdar-svg-LibO-3.5-Master.zip" and follow these steps to reproduce:
1. Download "FONT-ERROR-nazdar-svg-LibO-3.5-Master.zip" from attachment above
2. Extract the "nazdar.svg" picture file
3. Open NEW empty WRITER document
4. Menu 'Insert -> Picture -> From file...'
5. Browse for "nazdar.svg" and open
   Expected: Picture will be inserted and Correct Font will appear
   Actual: Incorrect Font appears.

Same result when insert to DRAW document.

Please see the included "nazdar-svg-Safari-OSX.png" file to see how Safari renders SVG text, and see the "nazdar-svg-LibO-3.5-Master.png" to see how the file appears as an error in LibO 3.5 WRITER.
Comment 4 Jeffrey 2011-08-20 20:33:45 UTC
On LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux, when I insert the globe svg file into writer, there is no color and no text. Any reasons why? There is a bug but I do not know what the implications of this problem is.
Comment 5 Rainer Bielefeld Retired 2011-09-02 23:28:44 UTC
[Reproducible] with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: a6adae1-4eb4f62-09af278)]"

Inserting simple testcase is "nazdar.svg" into a new DRAWing shows only rectangles instead of characters. The same proceeding with LibO333 shows nwthing.

The most simple testcase is "nazdar.svg" from FONT-ERROR-nazdar-svg-LibO-3.5-Master, inserted into DRAWing


We have some similar bugs with text import problems
Bug 32248 - FILEOPEN SVG no TEXT visible
Bug 39599 - EDITING, FILEOPEN SVG TEXT INKSCAPE
Bug 37994 - FILEOPEN: Text missing in SVG

@rk601@yahoo.com:
One Bug - One Report! So I ignored problem from SVG Error in WRITER - LibO 3.5 dev / Blue-Folder.svg
Comment 6 Rainer Bielefeld Retired 2011-09-02 23:37:09 UTC
Created attachment 50854 [details]
Result + Screenshot, See Comment 5

My results with "SVG_Font-Error.svg" from "SVG_Font-Error".

Showing some rectangles with sample "nazdar.svg" from Bug 39599 - EDITING, FILEOPEN SVG TEXT INKSCAPE is a little progress compared to "shows nothing", but of course not a solution

50230: LibO 3.5 Renders SVG in ERROR on OSX - Examples is for a completely different problem
Comment 7 Björn Michaelsen 2011-12-23 13:25:28 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 8 tester8 2011-12-30 13:30:52 UTC
LOdev 3.5.0beta2 
4ca392c-760cc4d-f39cf3d-1b2857e-60db978
Ubuntu 10.04.3 x86
Linux 2.6.32-37-generic Russian UI

Description
NOT reproduced.

Comment 3.
Reproduced. Font is the same as in reporter's LO but also the same as in eog (Linux picture wiewing program).
Comment 9 retired 2013-11-16 16:44:19 UTC
So what's up with this? When I open SVG_Font-Error with LO 4.2 latest master I still get another font as when opening the svg with safari. Any dev willing to look into this?

Still a problem in Version: 4.2.0.0.alpha1+
Build ID: 868103846b9b32bfecd77c08055fdca69d0265c2
TinderBox: MacOSX-x86@48-TDF, Branch:master, Time: 2013-11-14_23:51:46
Comment 10 Regina Henschel 2013-12-03 19:47:19 UTC
If you open the file via File > Open the text is "nazdar" is missing, but it there, when inserting the *svg image via Insert > Image. This problem in already tracked in bug 32248.

When using File > Open in LO4.3 I see in addition that the globe is drawn wrong. It might have a common reason with the missing text, but I don't know. This issue should focus on the wrong rendering of the globe.
Comment 11 MarjaE 2015-09-17 23:01:27 UTC
In my experience, text disappears, and objects get scattered all over, when trying to open .svg.
Comment 12 Xisco Faulí 2015-12-01 10:44:15 UTC
Created attachment 120918 [details]
font-error.svg
Comment 13 Xisco Faulí 2015-12-01 10:45:34 UTC
Created attachment 120919 [details]
nazdar.svg
Comment 14 QA Administrators 2018-02-08 03:34:58 UTC Comment hidden (obsolete)
Comment 15 Roman Kuznetsov 2018-06-16 13:37:05 UTC
in 

Version: 6.0.4.2 (x64)
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: ru-RU (ru_RU); Calc: CL

importing both SVG from Xisco to Draw with Insert->Image gives fine result! (see. attach)

FIXED?
Comment 16 Roman Kuznetsov 2018-06-16 13:37:37 UTC
Created attachment 142793 [details]
Insert-Image in 6.0.4 font-error SVG
Comment 17 Roman Kuznetsov 2018-06-16 13:38:02 UTC
Created attachment 142794 [details]
Insert-Image in 6.0.4 nazdar
Comment 18 Xisco Faulí 2018-06-18 19:07:43 UTC
Closing as RESOLVED WORKSFORME after the replacement of the SVG filter by SVGio

Tested in

Version: 6.2.0.0.alpha0+
Build ID: d60d695fcc5064e1f16842387fdce23456a64694
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded