Bug Hunting Session
Bug 40113 - Calc Print Preview does not show page background content and formatting
Summary: Calc Print Preview does not show page background content and formatting
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:3.5
Keywords: regression
: 38651 41449 (view as bug list)
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-08-15 12:29 UTC by Olivier Hallot
Modified: 2012-02-14 22:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
image does not show in header background. (20.63 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-08-15 12:29 UTC, Olivier Hallot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2011-08-15 12:29:09 UTC
Created attachment 50244 [details]
image does not show in header background.

OOO340m1 (Build:203) LibreOffice 3.4.2

The attached spreadsheet was created in Calc 3.4.2 in Linux.

The spreadsheet header background image does not show in Calc 3.4.2  but does show in Calc 3.3.3 (windows).
Comment 1 Olivier Hallot 2011-08-15 12:34:40 UTC
It must be noted that the unseen graphic was inserted in all page styles.
Comment 2 Olivier Hallot 2011-08-16 05:52:02 UTC
*** Bug 38651 has been marked as a duplicate of this bug. ***
Comment 3 Olivier Hallot 2011-08-16 13:34:15 UTC
Update:
The images does not display in print preview.

It displays when exposted to PDF.

All images and color of the page background are not rendered in print preview mode, but are printed in PDF.
Comment 4 m.a.riosv 2011-08-18 07:37:46 UTC
Win 7x64 Ultimate LibreOffice 3.4.2 [OO340m1 build203]

Confirmed with a file from scratch.
All images and color of the page background are not rendered in print preview
mode, but are printed in PDF.

This seems a regression, works well in LibreOffice 3.3.3
Comment 5 Cor Nouws 2011-08-29 00:32:08 UTC
looks as Bug 36690 - Contents, header, footer appear outside sheet area in PRINTING preview
which maybe (looking at comment #6) is not yet pushed to 3.4 branch ?
Comment 6 cwchia 2011-09-09 03:23:10 UTC
Comment on attachment 50244 [details]
image does not show in header background.

I can confirm the same problem in my LO 3.4.2 in PCLinuxOS 2011 installed using LO Manager.

Not only graphics do not show up in header during preview, the same behaviour is also noted for footer.

However in my environment, it still prints out perfectly and also can be seen correctly in the small preview pane within the Print Dialog Box.

this is a regression from earlier version. Was able to do a preview in at least 3.1
Comment 7 Cor Nouws 2011-09-09 06:18:23 UTC
(In reply to comment #5)
> looks as Bug 36690 - Contents, header, footer appear outside sheet area in
> PRINTING preview
> which maybe (looking at comment #6) is not yet pushed to 3.4 branch ?

No, it is, according to this
http://lists.freedesktop.org/archives/libreoffice/2011-May/012330.html
Comment 8 vitriol 2011-10-04 07:12:55 UTC
*** Bug 41449 has been marked as a duplicate of this bug. ***
Comment 9 Kohei Yoshida 2011-11-17 07:51:21 UTC
Olivier, please check the latest version of 3.4.x and see if this bug has been fixed there.  I remember I fixed this, and I *believe* the fix is already in the 3.4.x code base.

But please double-check.
Comment 10 Olivier Hallot 2011-11-17 08:02:08 UTC
(In reply to comment #9)

I have 3.4.4 built by TDF. The problem continues, exactly as I described in comment #3.
Comment 11 Kohei Yoshida 2011-11-17 08:17:23 UTC
Whatabout the master build?  Can you check there as well?  Thanks.
Comment 12 Olivier Hallot 2011-11-17 08:33:31 UTC
(In reply to comment #11)
It appears that the issue is fixed. I have the background images back in the preview. Thanks
Comment 13 tommy27 2012-01-29 22:15:00 UTC
@Oliver

did you try 3.4.5? is the bug still present?

if yes, is there any chance to backport this to future 3.4.6 since the issue seems already fixed in the 3.5.x branch?

if no, we could close this bug
Comment 14 vitriol 2012-02-14 22:14:44 UTC
It seems OK in 3.5.0. I mark this bug as works for me, for now.