Bug 40325 - PRINTING: order of page not respected with Handout
Summary: PRINTING: order of page not respected with Handout
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Radek Doulik
URL:
Whiteboard:
Keywords:
: 46861 56398 66311 70544 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-23 13:23 UTC by Laurent BP
Modified: 2014-12-03 22:00 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2011-08-23 13:23:12 UTC
Hello,

This is continuation of OOo issue 117103:
Print order for slides in handouts mode is not set properly
http://openoffice.org/bugzilla/show_bug.cgi?id=117103

To reproduce:
- open or create a presentation with more than one page
- File > Print
- tab General, choose "Handouts" for Document
=> Whatever the number of slides per page, Order option has no effect. For instance for Default (Handout layout was 6 per page) order is top to down. If you change to 6, order is left to right.

Configuration: OOo 3.3.0, LibO 3.3.4, LibO 3.4.2
Comment 1 Rainer Bielefeld Retired 2011-08-24 02:47:55 UTC
I see the effect with "LibreOffice 3.4.3 RC1 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:301)]". Printing with selected 'Print -> Document=Handout' selection of "Order" picker is without influence, using sample from OOo bug I always get
1 4
2 5 
3 6

What is quite the opposite from the result in the OOo report. 

With OOo 3.1.1 printing works as expected:
"Horizontal"
1 2
3 4
5 6

"Vertical"
1 4
2 5 
3 6

Already a problem  with "LibreOffice Portable 3.3.3  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:301  Tag 3.3.3.1)]", so I modify 

Still a problem with Master "LibO-dev 3.4.5 – WIN7 Home Premium (64bit) English UI [(Build ID:d337f79-a24c961-2865670-9752b71-7f8fd43
	2fdd60d-fd28b6a-fd7bf20-aa369cb-28da3fb
	6a9633a-931d089-ecd263f-c9b55e9-b31b807
	82ff335-599f7e9-bc6a545-1926fdf)]"

@Radek:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 2 Björn Michaelsen 2011-12-23 13:22:58 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 3 Rob Snelders 2012-11-05 23:13:32 UTC
*** Bug 56398 has been marked as a duplicate of this bug. ***
Comment 4 Rob Snelders 2012-11-05 23:14:07 UTC
*** Bug 46861 has been marked as a duplicate of this bug. ***
Comment 5 Rob Snelders 2012-11-06 22:15:07 UTC
I have found a workaround. When you set the option of the number of slides on 1 page then it respects that option. So just set the number of slides from default to 6 then it works.

Tested with 3.5.4 and 3.7.0.0
Comment 6 Rob Snelders 2012-11-06 22:15:33 UTC
3.7.0.0 should be 3.7.0.0-master
Comment 7 Yves 2012-11-07 09:50:51 UTC
(In reply to comment #5)
> I have found a workaround. When you set the option of the number of slides
> on 1 page then it respects that option. So just set the number of slides
> from default to 6 then it works.
> 
> Tested with 3.5.4 and 3.7.0.0

Thank you, but this does not really solve my problem, since when I modify the size/position of each slide in the handout mode it is not reflected when printing in slide mode with 6 slides/page. I don't know if there is a mean to set the size and position of each slide on the page in the 6 slides/page printing mode (in fact I suppose if it was possible, the print handout option would not be necessary at all).

Tested with 3.6.2.2 on 32 bit Linux
Comment 8 Michael 2013-06-30 10:52:28 UTC
*** Bug 66311 has been marked as a duplicate of this bug. ***
Comment 9 Barnoid 2013-09-08 08:03:16 UTC
Bump - bug still present in LibreOffice 4.0.4.2.

This is quite an annoying bug and (in theory) doesn't sound too hard to fix. If someone can point me in the right direction (e.g., files where the UI dialog and the print routine are) I may be able to help.
Comment 10 Rob Snelders 2013-10-17 18:41:59 UTC
*** Bug 70544 has been marked as a duplicate of this bug. ***
Comment 11 sergio.callegari 2014-03-03 10:00:49 UTC
Still present in 4.2.2 RC 1
Comment 12 Cor Nouws 2014-07-05 21:48:55 UTC
In any case the print preview in 4.2.5 shows the change in order, when having 4 slides per page..
Comment 13 Laurent BP 2014-12-03 20:58:39 UTC
This bug is solved in
- Version: 4.3.4.1
Build ID: bc356b2f991740509f321d70e4512a6a54c5f243
- Version: 4.2.5.1
Build ID: 881bb88abfe2992c6cede97c23e64a9885de87de
Comment 14 Laurent BP 2014-12-03 21:54:08 UTC
Reproduced with:
- Version 4.1.6.2
- Version: 4.2.0.0.alpha0+
Build ID: 2f6cbe13e61c44d4bab8192a4708b698d3d9da33
TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-07-25_00:00:21

NOT reproduced with:
- Version: 4.2.2.1
Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f
- Version: 4.2.0.0.alpha0+
Build ID: 4a8f7ddc290d1ea3131de6611b6833b77ac7ab1f 2013-08-28

So this bug seems to have been fixed between 2013-07-25 and 2013-08-28 during development of 4.2.

@sergio.callegari@gmail.com Could you check your procedure, because I do not reproduce with your version:
1. Open https://issues.apache.org/ooo/attachment.cgi?id=75928
2. File > Print
3. Select: Print: Document > Handouts
Order indicates "Left to right, then down" and preview shows pages in the correct order (page 2 is in top right position)
Comment 15 Laurent BP 2014-12-03 22:00:54 UTC
Found commit which solved the problem:
http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-2-0&id=a6a04658fb46d9e5ec40438955b777e2eb76b8d2

Thanks to kendy :)