Bug 40540 - FILESAVE Losing shapes inside frame while saving to .DOC (MSO2003) (vector grafics)
Summary: FILESAVE Losing shapes inside frame while saving to .DOC (MSO2003) (vector gr...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
Inherited From OOo
Hardware: All All
: high major
Assignee: Not Assigned
Keywords: dataLoss, filter:doc
: 121508 121510 139169 (view as bug list)
Depends on:
Blocks: DOC-Frames DOC-Shapes MSO-XML2003
  Show dependency treegraph
Reported: 2011-09-01 02:15 UTC by user6
Modified: 2023-12-22 12:51 UTC (History)
14 users (show)

See Also:
Crash report or crash signature:

input file (13.28 KB, application/vnd.oasis.opendocument.text)
2011-09-01 02:15 UTC, user6
Input file picture (75.14 KB, image/png)
2011-09-01 02:15 UTC, user6
output file picture (50.13 KB, image/png)
2011-09-01 02:16 UTC, user6
simplified testcase (39.29 KB, application/vnd.oasis.opendocument.text-flat-xml)
2012-01-24 02:34 UTC, sasha.libreoffice
input file2 (13.44 KB, application/vnd.oasis.opendocument.text)
2012-01-26 12:08 UTC, user6
best example of input file (9.02 KB, application/vnd.oasis.opendocument.text)
2012-01-26 13:43 UTC, user6
Still reproduced in LO Win7 (119.71 KB, image/png)
2012-06-07 10:01 UTC, user6
Still reproduced in LO Win7 (111.94 KB, image/png)
2012-06-07 10:03 UTC, user6

Note You need to log in before you can comment on or make changes to this bug.
Description user6 2011-09-01 02:15:28 UTC
Created attachment 50798 [details]
input file

When you export some vector drwaing to DOC word97/2003 it is lost
Comment 1 user6 2011-09-01 02:15:57 UTC Comment hidden (obsolete)
Comment 2 user6 2011-09-01 02:16:29 UTC Comment hidden (obsolete)
Comment 3 user6 2011-09-05 03:38:54 UTC
To reproduce:
1. Open ODT "input file" in LibO
2. Save it as DOC format
3. Open DOC file in LibO or Word.
Drawing is lost
Comment 4 Björn Michaelsen 2011-12-23 12:38:18 UTC Comment hidden (obsolete)
Comment 5 user6 2011-12-26 01:56:47 UTC Comment hidden (obsolete)
Comment 6 sasha.libreoffice 2012-01-17 07:33:02 UTC
Reproduced on LibO 3.5.0 beta 2 on Fedora 64 bit
Comment 7 Petr Mladek 2012-01-23 09:59:14 UTC
I wonder if the pictures are in a special format. Objects added via the "Drawings" toolbar are saved correctly. So, the missing objects must be something special.

I add some experts on drawings export into CC.
Comment 8 Petr Mladek 2012-01-23 10:04:45 UTC Comment hidden (obsolete)
Comment 9 sasha.libreoffice 2012-01-24 02:34:14 UTC
Created attachment 56069 [details]
simplified testcase

In this attachment only one text frame and one line inside
Somebody managed place drawing object, anchored as character, inside of text frame.
Comment 10 user6 2012-01-26 11:56:18 UTC
As I understand it was drawn in Word as a vector graphics and then I imported it to LO. (You can edit each element during LO; so I wonder why format is meaningful)
Comment 11 user6 2012-01-26 12:08:42 UTC
Created attachment 56200 [details]
input file2

if I copy several vector boxes outside text frame then it reproduced partially.

i.e. vector objects inside text frame are not exported to .doc.
Comment 12 user6 2012-01-26 13:43:43 UTC
Created attachment 56207 [details]
best example of input file

Attached file is created in LO from scratch.
There is one vector object inside box/incut.
And there is one object outside it.

So during exporting to .doc, the object inside box is not saving.
Comment 13 sasha.libreoffice 2012-01-26 21:42:56 UTC Comment hidden (obsolete)
Comment 14 Rainer Bielefeld Retired 2012-05-31 09:10:16 UTC
Already [Reproducible] with "best example of input file " and "LibreOffice 3.3.3  German UI/Locale [OOO330m19 (Build:301) tag libreoffice-] on German WIN7 Home Premium (64bit). Blue rectangle in frame is missing after export.doc, close, reopen
Comment 15 Rainer Bielefeld Retired 2012-05-31 09:16:42 UTC
Same result with "input file".

Can you confirm that only Drawing shapes !in Frame! are affected?
Comment 16 user6 2012-06-07 09:52:21 UTC
Yes, I confirm, only in frame drawing is affected.
Comment 17 user6 2012-06-07 10:01:31 UTC Comment hidden (obsolete)
Comment 18 user6 2012-06-07 10:03:58 UTC
Created attachment 62739 [details]
Still reproduced in LO Win7
Comment 19 Muthu 2012-06-07 22:42:35 UTC Comment hidden (obsolete)
Comment 20 user6 2012-08-08 16:20:18 UTC Comment hidden (obsolete)
Comment 21 user6 2012-12-06 17:11:28 UTC Comment hidden (obsolete)
Comment 22 user6 2013-02-12 10:53:34 UTC Comment hidden (obsolete)
Comment 23 user6 2013-02-12 11:02:12 UTC Comment hidden (obsolete)
Comment 24 Joel Madero 2013-02-12 18:59:50 UTC Comment hidden (obsolete)
Comment 25 Olivier Crête 2013-12-20 00:26:43 UTC
Still happens in

Here are some easy step to reproduce without any special files
1. Create a new Writer document
2. Create a new Drawing
3. In the drawing, draw a rectangle
4. select the rectangle and copy it (ctrl-c)
5. in the writer document, paste the drawing (ctrl-v)
6. in writer, right-click the rectangle and select "Caption"
7. Click ok in the caption dialog
8. Save as a Word .doc document
9. Reload the file using File->Reload
Comment 26 Cédric Bosdonnat 2014-01-20 08:57:39 UTC Comment hidden (obsolete)
Comment 27 Joel Madero 2014-03-25 23:15:44 UTC Comment hidden (obsolete)
Comment 28 QA Administrators 2016-09-20 09:37:14 UTC Comment hidden (obsolete)
Comment 29 Telesto 2016-12-03 16:54:21 UTC
Confirming with:
Build ID: 33f5bc54aaa7fe7aa9335726e30f9c349155e04d
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-12-01_23:21:05
Locale: nl-NL (nl_NL); Calc: CL
Comment 30 Roman Kuznetsov 2018-07-29 11:45:04 UTC
still repro in LO Writer
Comment 31 QA Administrators 2019-07-30 03:15:47 UTC Comment hidden (obsolete)
Comment 32 sdc.blanco 2019-10-28 12:03:56 UTC
Confirm that the problem still exists.
Followed procedure in comment 25.
The area color is lost (because the shape is lost), and the caption moves to the top of the frame (because the shape is lost).

Further information (and better procedure)

1.  Do not need to make a Drawing document as described in comment 25, can just draw a shape into a new document.  (but I tried both versions with same result).

2. Followed the procedure, while watching the "Navigator" window.
    a.  Creating (or copying) a shape gives an Shape1 under Drawing Objects
    b.  Inserting a Caption creates a Frame1 under Textframes
    c.  Save .doc  and reload.
    d.  The shapes are now lost (i.e., do not appear in Navigator), but the text frames remain. 

3.  If the document is saved as .docx, then the shape is lost, but now the Frame1 moves from "Text Frame" to stand under "Drawing Objects" in Navigator.

Version: (x64)
Build ID: f41f4c7f9507aeca13cb9df51f34d80e8ba30a99
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_DK); UI-Language: en-US
Calc: threaded
Comment 33 Telesto 2020-12-23 07:26:22 UTC
*** Bug 139169 has been marked as a duplicate of this bug. ***
Comment 34 Timur 2022-06-07 14:06:40 UTC
*** Bug 121510 has been marked as a duplicate of this bug. ***
Comment 35 Stéphane Guillou (stragu) 2023-04-11 21:23:02 UTC
Already in OOo 3.3, so inherited.

Same as comment 12 in recent master build:

Version: (X86_64) / LibreOffice Community
Build ID: fc6806c4be8585ce0d35a6b581bf8b3dbf858500
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded
Comment 36 Stéphane Guillou (stragu) 2023-12-21 16:08:30 UTC
(In reply to sdc.blanco from comment #32)
> 3.  If the document is saved as .docx, then the shape is lost, but now the
> Frame1 moves from "Text Frame" to stand under "Drawing Objects" in Navigator.
It makes sense to not be able to keep the shape anchored inside the frame, as the frame is converted to a drawing object when saving as DOCX. But I don't reproduce what you see: the shape is kept, just anchored to a page's paragraph instead.

The DOC filter should do the same.
(Note that Office 365 (online) also loses the shape on importing the ODT.)
Comment 37 Gabor Kelemen (allotropia) 2023-12-22 12:43:21 UTC
*** Bug 121508 has been marked as a duplicate of this bug. ***