Bug Hunting Session
Bug 40550 - EDITING: Text selection with Shift+PageDown broken
Summary: EDITING: Text selection with Shift+PageDown broken
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86-64 (AMD64) All
: highest minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 85642 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-01 08:00 UTC by Michael O'Neill
Modified: 2016-05-12 17:14 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
test doc (306.07 KB, application/vnd.oasis.opendocument.text)
2014-08-28 22:06 UTC, running.sun
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael O'Neill 2011-09-01 08:00:26 UTC
To select text, I am used to holding the shift key and using the appropriate navigation key.  Typically, all text from the initial position of the cursor to wherever the navigation keys lead should be selected.

When I attempt to select text by holding the shift key and typing the page down key, I am able to select text the first time I press the page down key.  If I press page down a second time, however, the text is deselected.  After that, the combination of shift and page down will not select any text unless I reposition the cursor with the mouse or, sometimes, the cursor key, although sometimes use of the cursor key will also not select text.

The same bug seems to exist with the page up key.  I have not tried this with all navigation keys or combingations.
Comment 1 Rainer Bielefeld Retired 2011-09-14 22:16:52 UTC
NOT reproducible with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]" 

MAC only?

@Michael O'Neill:
Is the problem really limited to WRITER or do you also observe it with CALC?
Comment 2 Michael O'Neill 2011-09-15 03:11:12 UTC
No, it doesn't happen in calc.

On Sep 15, 2011, at 1:16 AM, bugzilla-daemon@freedesktop.org wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=40550
> 
> Rainer Bielefeld <LibreOffice@bielefeldundbuss.de> changed:
> 
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>            Summary|EDITING:                    |EDITING: Text selection
>                   |                            |with Shift+PageDown broken
>           Keywords|                            |NEEDINFO
>                 CC|                            |LibreOffice@bielefeldundbus
>                   |                            |s.de
> 
> --- Comment #1 from Rainer Bielefeld <LibreOffice@bielefeldundbuss.de> 2011-09-14 22:16:52 PDT ---
> NOT reproducible with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German
> UI [OOO340m1 (Build:302)]" 
> 
> MAC only?
> 
> @Michael O'Neill:
> Is the problem really limited to WRITER or do you also observe it with CALC?
> 
> -- 
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.



Law Office of Michael G. O'Neill
Civil Rights, Labor and Employment and Personal Injury
30 Vesey Street, Third Floor
New York, New York 10007
212 581-0990
Comment 3 Rainer Bielefeld Retired 2011-09-15 03:49:05 UTC
bugzilla-daemon@freedesktop.org schrieb:
> https://bugs.freedesktop.org/show_bug.cgi?id=40550
>

Hi

Please only comment in the Bug reports, not by mail. And never use your 
E-Mail program for reply-comments!

CU

Rainer
Comment 4 sasha.libreoffice 2012-03-02 05:23:11 UTC
@ Michael
Thanks for bugreport
Please, verify if in last version of LibreOffice still reproducible
Comment 5 lordvarkson 2012-05-10 06:47:54 UTC
I can reproduce it in LibreOffice 3.5.2.2 
Build ID: 350m1(Build:202) running on Ubuntu 12.04 i686
Comment 6 sasha.libreoffice 2012-05-10 06:54:30 UTC
It reproducible if copy-paste document from web-browser to Writer. There web-page inserts as table with unseen borders. And Shift+PageDown not works because it is a table.
Comment 7 Roman Eisele 2012-07-21 12:44:00 UTC
After comment #5 and #6, the status should be "NEW".
Comment 8 František 2013-07-17 21:18:26 UTC
reproducible in LO 4.1.0.1 Mac
Comment 9 running.sun 2014-08-28 22:06:46 UTC
Created attachment 105394 [details]
test doc
Comment 10 running.sun 2014-08-28 22:18:19 UTC
confirming. affected document attached. 
this is
Version: 4.2.4.2
Build ID: 420m0(Build:2)
on
Ubuntu 14.04
x86_64
Comment 11 Mattk 2014-12-17 10:19:58 UTC
Confirming exact bug on Ubuntu Libreoffice writer
libreoffice-writer: 4.2.7-0ubuntu2

version 4.2.7.2 Build Build ID: 420m0(Build:2)

unity:7.2.3+14.04.20140826-0ubuntu1
Description:	Ubuntu 14.04.1 LTS
Release:	14.04

x86_64 GNU/Linux

This bug does not occur on Libreoffice calc only writer.
Keyboard shortcut does not appear in LO Writer list or in desktop shortcut.
Comment 12 Juan Manuel Barreto 2015-02-21 01:58:39 UTC
I can reproduce this issue on LibreOffice 4.4.0.3 (Spanish)
Windows 7 Professional 64 bit SP1.

Shift + Page Down selects the text only the first time it is pressed. On next key presses of Page Down, the text is deselected.
Comment 13 Cor Nouws 2015-05-03 13:52:30 UTC
Hi

I can reproduce this in e.g. 4.4.3.2 with attachment https://bugs.documentfoundation.org/attachment.cgi?id=105394

Only documents with a header/footer do show the same problem.
See bug 61224
Working on 32 bits Ubuntu.
Comment 14 Cor Nouws 2015-05-03 13:52:59 UTC
Hi

I can't reproduce this in e.g. 4.4.3.2 with attachment https://bugs.documentfoundation.org/attachment.cgi?id=105394

Only documents with a header/footer do show the same problem.
See bug 61224
Working on 32 bits Ubuntu.
Comment 15 Cor Nouws 2015-05-03 13:53:33 UTC
obviously comment #13 was wrong - apologies
Comment 16 Marc Kaulisch 2015-06-30 13:13:26 UTC
I can confirm that the bug is present in LO4.4.5.0 and LO 5.0.0.2 64bit on Win8.1.
Comment 17 Buovjaga 2015-06-30 13:35:05 UTC
(In reply to Cor Nouws from comment #14)
> Hi
> 
> I can't reproduce this in e.g. 4.4.3.2 with attachment
> https://bugs.documentfoundation.org/attachment.cgi?id=105394
> 
> Only documents with a header/footer do show the same problem.
> See bug 61224
> Working on 32 bits Ubuntu.

We have different experience, then. I get the problem in a fresh document without any headers & footers.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 4fff776a08dd92121ab507a1ab506ac945abaedb
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-28_00:25:54
Locale: fi-FI (fi_FI)

Ubuntu 15.04 64-bit 
Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-06-20_00:06:19
Locale: en-US (en_US.UTF-8)
Comment 18 Buovjaga 2015-06-30 13:36:15 UTC
Updated fields.
Comment 19 Robinson Tryon (qubit) 2015-07-02 15:12:01 UTC
(In reply to Beluga from comment #17)
> We have different experience, then. I get the problem in a fresh document
> without any headers & footers.
> 
> Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
> ...
> Ubuntu 15.04 64-bit 

Beluga: Motivations for marking this highest priority? Is it affecting many users or has bad side effects?
Comment 20 Buovjaga 2015-07-02 15:24:51 UTC
(In reply to Robinson Tryon (qubit) from comment #19)
> Beluga: Motivations for marking this highest priority? Is it affecting many
> users or has bad side effects?

Affects all users on all platforms and wanting to match the highest priority of bug 61224, which was prioritized after Cor discussed with a developer.
Comment 21 Evil Overlord 2015-09-17 15:48:23 UTC
Continues to be an issue in 5.0.1.1 on Windows 10 Pro. See also https://ask.libreoffice.org/en/question/57840/cant-make-long-selection-in-writer-using-pgdn/

Should be a priority, since Shift+PgDn is a natural way to select long stretches of text.
Comment 22 Cor Nouws 2015-10-03 09:28:43 UTC
reading good news in https://bugs.documentfoundation.org/show_bug.cgi?id=94679#c4

When that is applied, should be available in daily's soon and give the opportunity to test and backport :)
Comment 23 Buovjaga 2015-10-07 09:00:40 UTC
(In reply to Cor Nouws from comment #22)
> reading good news in
> https://bugs.documentfoundation.org/show_bug.cgi?id=94679#c4
> 
> When that is applied, should be available in daily's soon and give the
> opportunity to test and backport :)

Still reproduced.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: f830600ece806ec365a4839e79afabe183c5e36d
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-06_22:49:09
Locale: en-US (fi_FI)
Comment 24 m.a.riosv 2015-10-09 21:22:55 UTC
*** Bug 85642 has been marked as a duplicate of this bug. ***
Comment 25 Buovjaga 2015-10-28 10:51:14 UTC
Works now.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: fcc2415ade6ae93710bbbda9f7e163045e323105
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-21_16:55:13
Locale: fi-FI (fi_FI)
Comment 26 Magalaan 2015-11-13 13:30:21 UTC
Not resolved entirely:

Expected behaviour is that cursor movement keys keep changing selection as long as shift is pressed. 

There is still one minor exception. When you do shift pagedown and then any other selection key (like shift [+ ctrtl] + up/down/left/right/home/end) and then pagedown again, it still loses selection.

But I can do any combination of shift + up/down/left/right/home/end without pgup or pgdn and it works perfectly
Comment 27 Buovjaga 2015-11-13 17:24:05 UTC
(In reply to Magalaan from comment #26)
> Not resolved entirely:
> 
> Expected behaviour is that cursor movement keys keep changing selection as
> long as shift is pressed. 
> 
> There is still one minor exception. When you do shift pagedown and then any
> other selection key (like shift [+ ctrtl] + up/down/left/right/home/end) and
> then pagedown again, it still loses selection.
> 
> But I can do any combination of shift + up/down/left/right/home/end without
> pgup or pgdn and it works perfectly

For me it works fine with shift [+ ctrl] + up/down/left/right/home/end.

Please tell us your version information.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: b216cc1b8096eb60c27f67e8c27b7cd756c75e38
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-12_00:06:20
Locale: fi-FI (fi_FI)
Comment 28 Magalaan 2015-11-14 01:27:08 UTC
I use: Version: 5.0.3.2
Build ID: 1:5.0.3~rc2-0ubuntu1~trusty2
Comment 29 Buovjaga 2015-11-14 08:43:24 UTC
(In reply to Magalaan from comment #28)
> I use: Version: 5.0.3.2
> Build ID: 1:5.0.3~rc2-0ubuntu1~trusty2

Ok, so why did you reopen this, if you didn't test with 5.1?
Please confirm with a fresh master build http://dev-builds.libreoffice.org/daily/master/
Comment 30 Magalaan 2015-11-14 18:30:21 UTC
My fault sorry.
Comment 31 Justin L 2015-11-17 09:35:17 UTC
(In reply to Magalaan from comment #28)
> I use: Version: 5.0.3.2

The bugfix didn't make it into the 5.0 line in time for 5.0.3.  It should be fixed in 5.0.4 which is expected to be released after Dec 20, 2015.
Comment 32 Magalaan 2015-11-23 17:04:45 UTC
(In reply to Justin L from comment #31)
> (In reply to Magalaan from comment #28)
> > I use: Version: 5.0.3.2
> 
> The bugfix didn't make it into the 5.0 line in time for 5.0.3.  It should be
> fixed in 5.0.4 which is expected to be released after Dec 20, 2015.

Thanks for the explanation.