Bug Hunting Session
Bug 40558 - Default 'paste' behavior pastes plain text in fixed width font causing formatting nightmare
Summary: Default 'paste' behavior pastes plain text in fixed width font causing format...
Status: RESOLVED DUPLICATE of bug 62950
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-01 09:21 UTC by David C. Rankin
Modified: 2015-02-03 16:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David C. Rankin 2011-09-01 09:21:13 UTC
The default 'paste' behavior in writer should always be to paste as "Unformatted Text". Currently when composing a document, pasting from any source of plain text (e-mail, text editor, etc.), Libre tries to outthink the user and pastes the text in a fixed-width font destroying the current writer document format for the paragraph. This forces the user to use 'Paste Special' to work around Libres attempt to outsmart the user. This is backwards.

With documents now being composed from text from all different sources, text, e-mail, web, etc.., this behavior by Libre constantly changing the font of pasted text to what it thinks the user wants completely destroys efficient copy/paste operations.

ctrl+v, by default should paste text into a writer document using the DESTINATION format and NOT try and copy the SOURCE (or someother) format into an existing document. If in one instance the user wants the SOURCE format, then, and only then, should the user be required to use 'Paste Special' to preserve the source format on paste.

Further, the default paste behavior should be user configurable. If a user wants Libre to constantly try to paste with source formatting from various documents, then there should be a configuration option in Tools >Options >LibreOffice >General > "Copy/Paste Behavior" (or a new heading under LibreOffice called "Copy/Paste") where the user can choose:

Default Behavior:
[ ] Paste with SOURCE format by default
[ ] Paste with DESTINATION format by default (Unformatted Text)

(a feature that can't be turned off -- is a bug)

You simply cannot imagine the amount of inefficiency caused by having to constantly 'paste special' and then having to make a secondary selection of 'how to paste'. When compiling a lengthy document from multiple sources, the current default Libre 'paste with source format' behavior makes the experience a nightmare.

Not that it is as pressing an issue, but a rt-click context menu containing these choices is also a good idea. However, minimize reliane on context menus because any movement of the hands from the keyboard to the mouse and back introduces further wasted effort. The configurable default for ctrl+v is a must in this regard.
Comment 1 Björn Michaelsen 2011-12-23 12:35:46 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 sasha.libreoffice 2012-02-02 02:35:57 UTC
To solve this problem:
do in menu: Tools->Customize
in Dialog "Customise":
select tab Keyboard
in field "Category" select "Edit"
in field "Funciton" select "Paste unformatted text"
in field "Shortcut keys" select "Control+V"
press Modify on right hand side of dialog
press OK

now Ctrl-V will always insert text in destination format
Comment 3 David C. Rankin 2012-04-12 20:51:12 UTC
Still present in 3.5.1-1
Comment 4 strife 2013-03-05 18:02:29 UTC
There really should be another function. Copy in libreoffice should always respect formatting but copy from something like webpage should default to unformatted....


Im currently working on a thesis and copy quotes and stuff from the web, and at the same time moving around text with footers, problem is i sometimes forget to paste special with my own text resulting in footer being deleted.... and thats really bad....
Comment 5 Cor Nouws 2015-02-03 16:56:46 UTC

*** This bug has been marked as a duplicate of bug 62950 ***