Bug Hunting Session
Bug 40732 - Calc: Using ROW() and COLUMN() in array formula fails
Summary: Calc: Using ROW() and COLUMN() in array formula fails
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-09 02:15 UTC by Sören Weber
Modified: 2015-04-22 20:06 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Example (9.30 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-03-27 15:31 UTC, ariel cornejo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sören Weber 2011-09-09 02:15:18 UTC
Having the array forumla 

  ADDRESS(ROW();COLUMN())

in fields A1:B2 fails for all but the A1 field. Excel does it correct. Using only ROW() or COLUMN() works.
Comment 1 Markus Mohrhard 2011-11-01 20:18:38 UTC

*** This bug has been marked as a duplicate of bug 41807 ***
Comment 2 ariel cornejo 2012-03-27 15:31:09 UTC
Created attachment 59129 [details]
Example

Example using both row() and column() in an array formula, compared to using either row() _or_ column().
Comment 3 ariel cornejo 2012-03-27 15:32:52 UTC
This is not the same bug as #41807, which reports a crash when either ROW() or COLUMN() are used in an array formula. This one surfaces whenever both functions are used in an array formula (see attached file), producing #VALUE in all cells except the top left one.
This still happens in the 3.5.1 release.
Comment 4 Joel Madero 2014-11-06 20:33:17 UTC
Never confirmed by QA - moved to UNCONFIRMED

Also updated version as version is oldest version, not newest version, where the bug appears.
Comment 5 Sören Weber 2014-11-07 08:19:44 UTC
I can reproduce the issue with the attached file in the current stable version of LibreOffice Calc 4.3.3.2 (Build-ID: 9bb7eadab57b6755b1265afa86e04bf45fbfc644) on Win 7 32bit

Btw: Couldn't adjust "Version" field above, because latest stable version is missing!
Comment 6 Joel Madero 2014-11-07 16:09:41 UTC
Please don't confirm your own bugs and don't update the version of LibreOffice as version is the oldest version, not newest version, that has the problem.
Comment 7 raal 2014-11-07 17:14:04 UTC
Reproducible with Version: 4.3.4.0.0+
Build ID: fae7fed54206b98cc3aac24abcdac384d3bd9437
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-3, Time: 2014-11-06_02:16:12

With LO 3.5 no #VALUE!
Comment 8 Julien Nabet 2015-04-22 19:56:43 UTC
On pc Debian x86-64, I can reproduce this with LO Debian package 4.3.3 but I don't reproduce this with master sources updated today.
Comment 9 raal 2015-04-22 20:06:40 UTC
works for me, fixed. Closing.

Version: 5.0.0.0.alpha0+
Build ID: 89f5c1516fd3cf96488d97f62065b1ae0bdb9efa
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-04-18_10:10:39