Bug Hunting Session
Bug 41807 - Crash in Row or Column function without parameter, with matrix validation
Summary: Crash in Row or Column function without parameter, with matrix validation
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.3 RC1
Hardware: All All
: medium critical
Assignee: Markus Mohrhard
URL:
Whiteboard: target:3.5 target:3.4.5
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-10-15 00:02 UTC by Jeff
Modified: 2011-11-01 20:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
row function with matrix validation (8.05 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-10-15 00:33 UTC, Jeff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff 2011-10-15 00:02:20 UTC
Hello,

Step to reproduce :
In new spreadsheed, input in cell :
=COLUMN()
validation whith Ctrl+Upper+Entrer (or check "matrix" in wizard)
-> crash

Envisaged results:
Err 511 
Single cell in matrix (expect result whith Excel)

If I use Row or Column function without parameter in matrix function, there is crash.
For example :
=RANK(A1+ROW()/100;A1:A10+ROW(A1:A10)/100)
validation whith Ctrl+Upper+Entrer (or check "matrix" in wizard)
-> crash

=RANK(A1+ROW(A1)/100;A1:A10+ROW(A1:A10)/100)
validation whith Ctrl+Upper+Entrer (or check "matrix" in wizard)
-> work

Best regards
Comment 1 Jeff 2011-10-15 00:33:42 UTC
Created attachment 52354 [details]
row function with matrix validation
Comment 2 pierre-yves samyn 2011-10-15 00:56:44 UTC
Hello

I confirm with Window 7 & LibO 3.4.3 :

=COLUMN()
validation with Shift+Ctrl+Enter (or check "matrix" in wizard)
-> crash

Regression...

Best regards
PYS
Comment 3 vitriol 2011-10-15 01:14:06 UTC
Maybe related/duplicate of Bug 40990?
Comment 4 Jean-Baptiste Faure 2011-10-19 21:29:42 UTC
I confirm the crash on Ubuntu 10.04 x86_64 and master too.
Added the word "crash" to the summary.

Best regards. JBF
Comment 5 Jean-Baptiste Faure 2011-10-19 21:31:14 UTC
(In reply to comment #4)
> I confirm the crash on Ubuntu 10.04 x86_64 and master too.
> Added the word "crash" to the summary.
> 
> Best regards. JBF

And set importance to critical because a crash is always a very bad thing.
Comment 6 Markus Mohrhard 2011-11-01 13:18:23 UTC
ok, I'll look into it
Comment 7 Markus Mohrhard 2011-11-01 14:49:39 UTC
fixed in master and sent patch for 3-4 to ML
Comment 8 Markus Mohrhard 2011-11-01 20:18:38 UTC
*** Bug 40732 has been marked as a duplicate of this bug. ***