Download it now!
Bug 40993 - Calc: Pulling down formula over merged cells unmerges them
Summary: Calc: Pulling down formula over merged cells unmerges them
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: high normal
Assignee: Attila Szűcs
URL:
Whiteboard: target:7.1.0
Keywords:
: 76972 (view as bug list)
Depends on: 59585
Blocks: Cell-Formula Calc-Merge-Split
  Show dependency treegraph
 
Reported: 2011-09-18 10:34 UTC by M
Modified: 2020-10-07 15:11 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
ODS file to reproduce behavior (7.40 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-09-18 10:34 UTC, M
Details

Note You need to log in before you can comment on or make changes to this bug.
Description M 2011-09-18 10:34:12 UTC
Created attachment 51318 [details]
ODS file to reproduce behavior

Hi,
I am using LibreOffice 3.4.3 OOO340m1 (Build:302) on Ubuntu 11.04_64bit. It seems Calc resplits merged cells when you draw a formula over it with the lower right handle. What I did is: 
1.) create two adjacent cells with e.g. 1 and 2 in it. 
2.) When you merge & center cells below it and add e.g. =AVERAGE(). You will get a centered value of 1.5 in the cell. That is fine. 
3.)Drawing the formula down over more merged cells will split them and align the value of 1.5 into the left slice.

See attached file to try it for yourself.

This behavior seems odd. I guess it's probably an unwanted behavior or not?

Cheers
Comment 1 Björn Michaelsen 2011-12-23 12:37:44 UTC Comment hidden (obsolete)
Comment 2 M 2012-01-22 12:51:27 UTC Comment hidden (obsolete)
Comment 3 M 2012-03-09 07:56:07 UTC
Hello,

I tested this on Microsoft Office 2010 to see how it handles this type of setup. In Microsoft office it is not allowed to pull it over unevenly divided cells. I am not sure if it is just a flavor of handling this or it is a bug in LibreOffice. But I think it is probably a bug as you change the cell layout, that you probably set up a priori.
Comment 4 Doug Naphas 2013-11-24 21:53:33 UTC
This is still present in v 4.2.0.0.alpha0+, Ubuntu 12.04, Build ID 960aee493a7bdbda69cbe60049edd9c4cafaab8e.
Comment 5 m.a.riosv 2014-04-03 03:06:07 UTC
*** Bug 76972 has been marked as a duplicate of this bug. ***
Comment 6 m.a.riosv 2014-04-03 03:07:02 UTC
Reproducible:
Win7x64
Comment 7 kloud 2014-06-21 03:02:59 UTC
Still present in v4.2 and v4.3 RC1 on XP 32 bit.

But it's not just formulas. Pulling continuing numbers also does reverse the merging of cells both horizontally and vertically.

It is an important bug, 'cause it makes dragging the handle useless when working with a line of merged cells. At least directly.

This issue is linked to the enhancement proposal in Bug 59585.
Comment 8 QA Administrators 2016-02-21 08:37:02 UTC Comment hidden (obsolete)
Comment 9 M 2016-02-21 18:08:20 UTC
Still the same problem.


Version: 5.1.0.1
Build ID: bcace328aabc4c8c10b56daa87da0a2ee6579b5a
Threads 2; Ver: Linux 4.2; Render: default; 

Locale: en-US (en_US.UTF-8)
Comment 10 Timur 2016-02-26 17:04:27 UTC
*** Bug 76972 has been marked as a duplicate of this bug. ***
Comment 11 Timur 2016-02-26 17:09:10 UTC
This bug is marked to depend on Bug 59585 but it looks the same to me. 
This one is earlier but that one has more simple explanation and I'd prefer it.
Comment 12 QA Administrators 2017-03-06 15:41:35 UTC Comment hidden (obsolete)
Comment 13 raal 2018-12-11 07:13:24 UTC
Still repro Version: 6.3.0.0.alpha0+
Build ID: f3ea5e21bea80004b04edbf0287d4a2e1aaef5d0
Comment 14 Commit Notification 2020-09-30 08:31:14 UTC
Attila Szűcs committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1ed04c2029218619aab2f3422130c890f67f309c

tdf#40993 tdf#59585 sc fill: copy merged cell structure

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 raal 2020-10-07 15:11:17 UTC
verified Version: 7.1.0.0.alpha0+ (x64)
Build ID: 6aa831bf46282d3df8b5f214abed7428bd4bd001
CPU threads: 4; OS: Windows 10.0 Build 17763; UI render: default; VCL: win
Locale: cs-CZ (cs_CZ); UI: en-US
Calc: CL