Bug 41089 - FILESAVE: Impossible with password protection
Summary: FILESAVE: Impossible with password protection
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.5 RC1
Hardware: Other All
: highest blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 44540 (view as bug list)
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-09-21 10:32 UTC by Rainer Bielefeld Retired
Modified: 2012-01-10 12:50 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-09-21 10:32:57 UTC
Steps to reproduce with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID:  d3d1481-3f8994a-2ba0a9f)]"

1. Open new WRITER document from LibO Start Center
2. type xyz
3. Menu 'File -> Save As (LibO or OS dialog, does not matter) -> 
   click PW protection ->  Browse for folder -> insert name' <save>
4. Type and confirm password (without options)  <ok>
   Expected: will be saved
   Actual: "Error saving the document [Name], General Error, 
   General input/output Error"

Save as MSWORD97XP.doc works fine
Worked without problems with 3.4.3
Comment 1 manj_k 2011-12-01 09:35:51 UTC
Not reproducible (UI en-US; on WinXP 32b) with
LibO-dev 3.5.0 · Build ID: 2d0998f-090bcba-45cf606
[master~2011-12-01_08.37.54_libodev35.msi · 01-Dec-2011
http://dev-builds.libreoffice.org/daily/Win-x86@6-fast/master/ ].

Has been saved password-protected (and reopened) w/o any error message.
Works fine (for me).
Comment 2 Claude 2011-12-21 08:02:42 UTC
I confirm error.  Not only saving with password, but it will fail to open a password protected file saved with earlier versions.  I had to uninstall 3.4.5, reinstall 3.4.4 to be able to open the protected odt file.
LibreOffice 3.4.5 RC1
Windows XP SP3
Comment 3 Rainer Bielefeld Retired 2011-12-21 23:20:40 UTC
NEW due to comment 2
Comment 4 Petr Mladek 2011-12-22 02:15:25 UTC
This looks related to the other blocker bug 43868.

Thorsten, I think that your worked on it. Was it solved in libreoffice-3-4, libreoffice-3-4-5, and libreoffice-3-5 branches?
Comment 5 Thorsten Behrens (CIB) 2011-12-22 15:08:56 UTC
Original report sounds unrelated to bug 43868.
Comment 6 Björn Michaelsen 2011-12-23 12:41:20 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 7 manj_k 2011-12-23 15:21:16 UTC
Still reproducible with LibO 3.4.5 RC1
[LibreOffice 3.4.5 · OOO340m1 (Build:501)]
(on Win XP 32b · UI en-US)

Moving back to NEW from NEEDINFO again.

For the record:
Works fine with LibO 3.5.0 Beta2
[LOdev 3.5.0beta2 · Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978]
(on Win XP 32b · UI en-US)
Comment 8 Petr Mladek 2012-01-03 06:51:41 UTC
I have reproduced the problem with 3.4.5-rc1 build. I do not see it with the last build from 3-4-5 branch. I guess that the fix for the bug #43868 helped here as well. I guess that LO tries to read the created zip file after it is saved or so.

Anyway, it should work in 3.4.5-rc2 again.
Comment 9 manj_k 2012-01-05 11:55:44 UTC
Verified - 
FILESAVE with password protection works fine with LibO 3.4.5 RC2 
(tested: Writer · on WinXP 32b).
Comment 10 manj_k 2012-01-06 12:08:03 UTC
*** Bug 44540 has been marked as a duplicate of this bug. ***
Comment 11 Ismael Cedillo 2012-01-10 09:01:56 UTC
I saw that the testes for this report were made on Windows 32b, and I really don't know if with a report for this bug in Windows-32b is enough... but I forgot to mark that it was identified on

Ubuntu 11.10
X86-64 system
and LibreOffice 3.4.5 OOO340m1 (Build:501)

Thanks,
Comment 12 Ismael Cedillo 2012-01-10 09:23:54 UTC
The bug was solved in the 3.4.5 RC2 build 502. 

Thanks
Comment 13 manj_k 2012-01-10 12:50:32 UTC
*** Bug 44540 has been marked as a duplicate of this bug. ***