Download it now!
Bug 41267 - UI - PDF export clears preferences for viewing non-printing characters
Summary: UI - PDF export clears preferences for viewing non-printing characters
Status: RESOLVED DUPLICATE of bug 40482
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-27 09:49 UTC by Tom Enesey
Modified: 2011-09-28 13:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Enesey 2011-09-27 09:49:52 UTC
I generally have the "view non-printing characters" option turned on in the edit menu. Under "Tools --> Options --> LibreOffice Writer --> Formatting Aids --> Display of," I have all non-printing characters checked.

When I export to PDF, all non-printing characters disappear in the edit window, even though the "view non-printing characters" toggle remains on. This is because the first six of the "Display of" tickboxes have been cleared by the PDF export. I have to manually re-check all the boxes in order to see the non-printing characters again.

The entries cleared are: Paragraph end, Custom hyphens, Spaces, Non-breaking spaces, Tabs, and Breaks.

This is 100% repeatable and occurs every time I do a PDF export.

My PDF export options under the "General" section are all turned off because of the "PDF/A-1a" bug that prevents PDFs generated by LibreOffice from opening in Adobe Acrobat (invalid color space). The plain vanilla PDFs open fine.
Comment 1 manj_k 2011-09-28 13:22:31 UTC
Duplicate of 'Bug 40482 - CONFIGURATION: Formatting aids - displayed nonprinting characters become unchecked during PDF export'.

*** This bug has been marked as a duplicate of bug 40482 ***