Bug Hunting Session
Bug 40482 - CONFIGURATION: Formatting aids - displayed nonprinting characters become unchecked during printing and PDF export
Summary: CONFIGURATION: Formatting aids - displayed nonprinting characters become unch...
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All All
: high major
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:3.4.5 target:3.5.0beta3 target...
Keywords: regression
: 41267 41485 41605 42079 43468 43476 43507 44041 44106 44197 44288 44493 44547 44600 44882 45139 49105 (view as bug list)
Depends on:
Blocks: mab3.4 mab3.5
  Show dependency treegraph
 
Reported: 2011-08-30 02:20 UTC by esperantisto
Modified: 2012-05-12 02:11 UTC (History)
34 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description esperantisto 2011-08-30 02:20:39 UTC
I have the button for displaying non-printing characters pressed and all boxes in _Tools → Options → LibreOffice Writer → Formatting Aids → Display of_ ticked, including Paragraph end, Custom hyphens, Spaces, Tabs, Breaks. However, Writer randomly turns them off, i. e. the above characters become invisible in the normal view mode and the respective boxes become unticked.

This happens with any file but without any particular cause I could detect. Most often, it happens after printing a document out or switching to print preview and back, but sometimes also during the regular process of text editing.

The issue was found in LO 2.4.3 RC1 and persists in RC2 in Microsoft Windows 7 Professional Russian/JRE 1.6.0_26, however, I did not notice such a problem in 2.4.2 (on the same platform).
Comment 1 Cor Nouws 2011-09-06 13:36:45 UTC
For me, paragraph end markers can not be made visible with menu or Ctrl-F10. 

However, when I check: 
  Tools > LibreOffice Writer > Formatting aid > check Paragraph ends
then Ctrl-F10 does turn them on/off.
Odd.
Comment 2 manj_k 2011-09-07 14:06:54 UTC
Reproducible with LibO 3.4.3 release (on WinXP 32b):
1. Writer > Ctrl+P (open print dialog)
2. Writer > File > Export as PDF...

The same bug with LibO-dev 3.5.0 
[Build ID: d3d1481-3f8994a-2ba0a9f].

Works fine for me with LibreOffice 3.3.4 
[OOO330m19 (Build:401) tag libreoffice-3.3.4.1].
Comment 3 Michael Höhne 2011-09-07 21:53:13 UTC
The same with LibreOffice 3.4.3 / OOO340m1 (Build:302) under Ubuntu 10.04:

New Document; Export as PDF -> Paragraph end, Custom hyphens, Spaces, Tabs, Breaks will not be shown anymore until you switch them on with and all boxes
in _Tools → Options → LibreOffice Writer → Formatting Aids.
Comment 4 Rainer Bielefeld Retired 2011-09-22 01:17:24 UTC
[Reproducible] with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]" and with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID:  d3d1481-3f8994a-2ba0a9f)]".

Modified Subject due to current knowledge, if there is an additional random effect a new report can be submitted.

@Cédric:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 5 manj_k 2011-09-28 13:22:31 UTC
*** Bug 41267 has been marked as a duplicate of this bug. ***
Comment 6 Roman Eisele 2011-10-02 02:12:10 UTC
Reproducible with LibO 3.4.3 release on WinXP 32b.

As manj_k already pointed out, this happens not only when exporting the document as PDF, but also on printing.

Additional observation: Sometimes only some of the nonprinting characters become invisible (and the corresponding options in the Formatting aids settings dialog become unchecked), sometimes more of them. When printing some document "A.doc" (it’s in DOC format) yesterday, only no-breaking spaces (NBSPs) became invisible (they were displayed like ordinary spaces), but when printing "A.doc" again today, most of the options, including the ordinary spaces, became unchecked. Yes, I know, this sounds odd, but it really happened this way.
Comment 7 Rainer Bielefeld Retired 2011-10-05 11:02:15 UTC
*** Bug 41485 has been marked as a duplicate of this bug. ***
Comment 8 vitriol 2011-10-09 01:37:01 UTC
*** Bug 41605 has been marked as a duplicate of this bug. ***
Comment 9 carles.camara 2011-11-01 00:36:55 UTC
Is there any progress on this? I can confirm that it's still happening
Comment 10 Thomas Bigler 2011-11-03 09:17:42 UTC
Formatting aids - displayed nonprinting characters become unchecked during printing and PDF export. LibO 3.4.4 RC2 Still the same error.
Workaround: 
After PDF-export or printing and *before* closing Writer do
Menu:File:Select Page; Close, 
otherwise the wrong settings will be saved and can only be reset via Tools/Options...
Comment 11 Rainer Bielefeld Retired 2011-11-03 09:38:07 UTC
@Thomas Bigler:
Please do not touch picker fields if you are not absolutely sure that you know for what they are!
<http://wiki.documentfoundation.org/BugReport_Details#Version>

Thank you for the Workaround!
Comment 12 Roman Eisele 2011-11-03 13:04:21 UTC
@Thomas Bigler:
No, "OS/Version" is not "Windows (All)", but really "All": this bug is not only visible on Windows but also e.g. on MacOS X.

@Rainer Bielefeld:
Thanks for correcting the picker fields again.
Comment 13 Thomas Bigler 2011-11-09 05:01:12 UTC
Bug survived in LibO 3.4.4 release...
Comment 14 manj_k 2011-11-09 05:26:40 UTC
@Thomas Bigler:
Please don't change the LibO version, see
→ http://wiki.documentfoundation.org/BugReport_Details#Version
Comment 15 Guki 2011-11-10 12:41:56 UTC
Change version? Will there be an update for 3.4.3 if the problem is found? I think no.

I hope there will be an answer to this terrible bug. I hate it to do this every 10 mins again and again!
Comment 16 ComWebUser 2011-11-13 11:14:24 UTC
I have found the problem still exists on 3.4.4. Using Windows 7 x64 Professional.  The show/hide toolbar button becomes non-functional on first print, and resetting in Options does not fix the problem.  The problem for me persists across sessions and restarts of computer.  I can fix it by deleting everything under .../user/3 and having the program recreate the folder, but that is much too time consuming a workaround for routine use. I am using OO.o 3.3 pending a fix.  Thank you
Comment 17 Jean-Baptiste Faure 2011-11-13 11:35:00 UTC
@ComWebUser: Please don't play with the version number. The bug has been reported for LibO 3.4.3. It is not marked as fixed, so it is clear that is still present in 3.4.4. 
Changing the version number make the initial version in which the bug has been found lost.

Best regards. JBF
Comment 18 ComWebUser 2011-11-13 18:30:51 UTC
My apologies, I am a newbie at bug reporting
Comment 19 Jochen 2011-11-21 13:41:15 UTC
I confirm the problem "displaying non-printing characters" using LO 3.4.4, Windows 7 prof 64 bit and the following macro:
Sub AktuelleSeiteDrucken
   oDoc = ThisComponent
   aPrinterProperties = oDoc.getPrinter()
   oPrinterName = aPrinterProperties(0)
   If IsNull( oPrinterName ) Then
      MsgBox( "Kein Drucker gefunden" )
   Else
      if MsgBox( "Der aktuelle Drucker ist: " & oPrinterName.Value, 1,"Hinweis") = 2 then
            exit sub
        else
            dim aPrintOps(0) as new com.sun.star.beans.PropertyValue
            oDoc = ThisComponent
            oViewCursor = oDoc.CurrentController.getViewCursor()
            aPrintOps(0).Name = "Pages"
            aPrintOps(0).Value = trim(str(oViewCursor.getPage()))
            oDoc.print(aPrintOps())
        endif
    EndIf
end sub 

Question: is this the same problem as Bug 40482?
Comment 20 manj_k 2011-11-21 14:20:04 UTC
@Jochen
"Question: is this the same problem as Bug 40482?"

Yes.
I've tested the macro with LibO 3.4.4 release on WinXP.

A workaround (to get back "displaying non-printing characters"):
1. Open 'Page Preview' (Standardbar)
2. Close 'Page Preview'

Testing the macro with LibO 3.3.4 release works fine.
Comment 21 Lenfort 2011-11-24 00:02:34 UTC
I have this bug on Windows 7 64bit with LO 3.4.3 and LO 3.4.4. Please fix it as soon as possible, because it's very annoying.

I can confim the workaround described by manj_k.
Comment 22 Thomas Thym 2011-11-29 09:02:53 UTC
+1 vote for that bug. (Sadly there is no voting feature here.)
Many of our users here in the company are not that IT-skilled that they could handle the workaround or find the settings in the menu. It would be really great if this bug could be fixed.
Comment 23 tmacchant 2011-12-01 01:26:29 UTC
I have found that displayed nonprinting characters recovered when the file has been closed and reopened.  However, the situation is still annoying. I hope that the bug will be fixed in the near future.
Comment 24 clio 2011-12-02 12:29:54 UTC
*** Bug 43476 has been marked as a duplicate of this bug. ***
Comment 25 manj_k 2011-12-04 13:20:06 UTC
*** Bug 43507 has been marked as a duplicate of this bug. ***
Comment 26 Thomas Thym 2011-12-21 04:53:57 UTC
I just tested 3.5 beta 1.
LOdev 3.5.0, Build-ID: 7362ca8-b5a8e65-af86909-d471f98-61464c4 

The non-printing characters still vanish after pdf export or print. After pdf export the reappear after restart of LO or after pressing the button. However, after print the bug is still there.

Go, go, go LOdevs. It would be awesome if that bug would not see 2012.
Comment 27 Michael Stahl (CIB) 2011-12-21 08:05:53 UTC
this was introduced with the fix for bug 39159:
the view options are not restored for the pages shown in the print preview.

fixed on master:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=89d2733e16ae6233deea6bef3193bd45c89b854c

fixed on libreoffice-3-5:

http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=871ad55dccbd7121e005a66e3c51f55a236d2b04

will propose for 3.4.5
Comment 28 Thomas Thym 2011-12-21 10:07:25 UTC
Good news! That is excellent! 
Thanks for fixing that one.
Comment 29 Terrence Enger 2011-12-21 12:59:06 UTC
*** Bug 43468 has been marked as a duplicate of this bug. ***
Comment 30 vitriol 2011-12-21 23:40:06 UTC
*** Bug 44041 has been marked as a duplicate of this bug. ***
Comment 31 Björn Michaelsen 2011-12-23 13:23:15 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 32 Jochen 2011-12-23 13:33:06 UTC
IMHO not resolved.

OS: Windows XP
LO: 3.5.0 beta2
Comment 33 manj_k 2011-12-23 14:45:45 UTC
Verified: The bugfix works fine with
LOdev 3.5.0beta2+ · Build ID: f47ee3c-7ef74e0-d7a1999
[libreoffice-3-5~2011-12-21_20.57.01_LibO-Dev_3.5.0beta2_Win_x86_install_en-US.msi 22-Dec-2011 · http://dev-builds.libreoffice.org/daily/Win-x86@6-fast/libreoffice-3-5/]
(on WinXP 32b · UI en-US)

... and yes, still a bug with LibO 3.5.0 Beta2
LOdev 3.5.0beta2 · Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978
(on WinXP 32b · UI en-US)
Comment 34 manj_k 2011-12-23 17:09:57 UTC
*** Bug 44106 has been marked as a duplicate of this bug. ***
Comment 35 Jean-Baptiste Faure 2011-12-24 10:22:48 UTC
(In reply to comment #32)
> IMHO not resolved.
> 
> OS: Windows XP
> LO: 3.5.0 beta2

Fix will be in beta3 because it is already in beta2+ where it works well (LibreOffice 3.5.0beta2+ Version ID : 746cde4-7f15fca-1fc8c06-ca8e46d-b96fade). 
Setting back as fixed.

Best regards. JBF
Comment 36 tommy27 2011-12-24 10:43:15 UTC
will it be cherry-picked in LibO 3.4.5 as well?
Comment 37 Jean-Baptiste Faure 2011-12-26 09:30:00 UTC
(In reply to comment #36)
> will it be cherry-picked in LibO 3.4.5 as well?

Perhaps ;-) : http://lists.freedesktop.org/archives/libreoffice/2011-December/022826.html

Best regards. JBF
Comment 38 manj_k 2011-12-27 14:12:41 UTC
*** Bug 44197 has been marked as a duplicate of this bug. ***
Comment 39 manj_k 2011-12-29 13:05:52 UTC
*** Bug 44288 has been marked as a duplicate of this bug. ***
Comment 40 Petr Mladek 2012-01-02 08:44:48 UTC
The fix has been just approved and pushed for 3.4.5-rc2.
Comment 41 Rainer Bielefeld Retired 2012-01-05 23:25:48 UTC
*** Bug 44493 has been marked as a duplicate of this bug. ***
Comment 42 manj_k 2012-01-06 14:18:26 UTC
Works fine (on WinXP 32b · UI en-US) with LibO 3.4.5 RC2
[LibreOffice 3.4.5 · OOO340m1 (Build:502)].
Comment 43 Rainer Bielefeld Retired 2012-01-06 23:53:17 UTC
*** Bug 44547 has been marked as a duplicate of this bug. ***
Comment 44 vitriol 2012-01-09 07:45:50 UTC
*** Bug 44600 has been marked as a duplicate of this bug. ***
Comment 45 manj_k 2012-01-12 09:45:46 UTC
Works fine (on WinXP 32b · UI en-US) with LibO 3.5.0 Beta3
[LOdev 3.5.0beta3 · Build ID: e40af8c-10029e3-615e522-88673a2-727f724].
Comment 46 manj_k 2012-01-23 14:38:04 UTC
*** Bug 44882 has been marked as a duplicate of this bug. ***
Comment 48 manj_k 2012-03-04 15:17:54 UTC
*** Bug 45139 has been marked as a duplicate of this bug. ***
Comment 49 manj_k 2012-04-25 14:51:10 UTC
*** Bug 49105 has been marked as a duplicate of this bug. ***
Comment 50 Roman Eisele 2012-05-12 02:11:55 UTC
*** Bug 42079 has been marked as a duplicate of this bug. ***