Bug 42079 - Nonprinting Character Button (Ctrl+f10) not working
Summary: Nonprinting Character Button (Ctrl+f10) not working
Status: RESOLVED DUPLICATE of bug 40482
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-20 21:19 UTC by Brian Wilson
Modified: 2012-05-12 02:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Wilson 2011-10-20 21:19:41 UTC
On Debian Wheezy with Libreoffice 3.4.3 Build 302.

Libreoffice Writer

Nonprinting Character Button (Ctrl+f10) not working
This button is located in the Standard Toolbar and has the pilcrow for an icon.

I was given a file of poetry to format that had been "pre-formatted" using multiple spaces and carriage returns. (not tabs, styles, or forced page breaks). Somehow in toggling the Nonprinting Character Button on and off, it got stuck in the off position. Neither pressing the button or Ctrl+f10 show the nonprinting characters.

Using apt-get I "purged" libreoffice and libreoffice-writer and then installed them fresh. For some reason the nonprinting character button is still not working.





tags: hidden, view, paragraph mark, invisible
Comment 1 Brian Wilson 2011-10-20 21:39:06 UTC
Ok. 

Tools > Options > Formatting Aids shows a list of nonprinting characters to display.

Somehow in toggling the nonprinting character button on and off (while zooming in and out), the carriage return, tab and space characters were deselected, without me actually going to the Formatting Aids menu and deselecting them.
Comment 2 vitriol 2011-10-20 22:49:17 UTC
(In reply to comment #1)

> Somehow in toggling the nonprinting character button on and off (while zooming
> in and out), the carriage return, tab and space characters were deselected,
> without me actually going to the Formatting Aids menu and deselecting them.

Maybe duplicate of Bug 40482. Check if happens while printing or exporting in PDF in your case.
Comment 3 tester8 2011-11-13 01:50:27 UTC
NOT reproduced with

LO 3.4.4
Ubuntu 10.04.3 x86
Linux 2.6.32-35-generic Russian UI

Can you try with 3.4.4?
Comment 4 sasha.libreoffice 2012-02-04 08:09:44 UTC
> Ctrl+f10 not working
It is not a bug. On Linux so should be

> Nonprinting Character Button not working
Try View->Nonprinting characters

> "pre-formatted" using multiple spaces
Use Edit->Find&Replace and there in field "Search for" enter two spaces and in field "Replace with" enter one space and press "Replace all" several times until all duplicate spaces disappears.
Comment 5 uno_wos 2012-02-22 11:38:31 UTC
Yes. It happened to my also.
Unistalling it will not work, because the "config" is still save.

I think it happens before, but in 3.4.5 an onwards, it does not happend (not sure).

Close completely libreoffice.
Go to:
/home/youruser/.libreoffice/3/

Then you got a folder named "user".
Erase it, or rename it "user.back"

Open again libreoffice.
You get it working again.

I dont know why it happens. I only know how to patch it...

Im not a developer, just a dude ;P
Comment 6 sasha.libreoffice 2012-02-22 21:42:50 UTC
Thanks for additional testing. So, I have some questions:
- not seen all non-printing characters or only spaces?
- it not works on 3.4 and 3.5?
- it installed from libreoffice.org or from distro repo?
- which distro used?
- it reproducible on another computer?
Comment 7 Borut Cadez 2012-03-29 00:31:12 UTC
I can confirm Nonprinting characters are not shown in OSX version of Writer 3.5.1.2 and seems that they are not working.

The issue is that by default all nonprinting characters except Hidden Text are disabled in preferences/writer/Formating Aids.

Perhaps it would be better to enable spaces, tabs, breaks by default.
Comment 8 sasha.libreoffice 2012-03-29 00:55:53 UTC
Thanks for additional testing
Comment 9 Roman Eisele 2012-05-12 02:11:55 UTC
Resetting the version number to 3.4.3, like in original description. Please note that the 'Version' field should contain the FIRST version in which the bug appears (is known to appear), and NOT the last one!

*

I think this issue is really a duplicate of bug 40482, which was fixed in 3.4.4 or 3.4.5. Some arguments:

* Original report was for LibreOffice 3.4.3.
* Not reproducible in LibreOffice 3.4.4 according to comment #3.
* "in 3.4.5 an onwards, it does not happen" according to comment #5.

The only comment which mentions this issue *after* the fix is comment #7 (Writer 3.5.1.2). But Borut Cadez gives an explanation himself: "The issue is that by default all nonprinting characters except Hidden Text are disabled in preferences/writer/Formating Aids." This means, the issue seen by Borut Cadez is an issue about "default" settings, not about the command 'Nonprinting characters' not working. Changing the default settings would be another issue, and an enhancement request, not a bug report. (Sidenote: IIRC, the default settings of LibreOffice 3.5.3 do enable spaces, tabs, breaks by default, so the suggestion of Borut Cadez don't even need an enhancement request.)

Therefore, closing this bug as duplicate of bug 40482.

If you find reasons which show that this is a different issue, or if this issue is still reproducible for you with LibreOffice 3.5.3.2 or better, feel free to reopen this bug report.

*** This bug has been marked as a duplicate of bug 40482 ***