Download it now!
Bug 43468 - printing changes in-memory user options (PRINTING)
Summary: printing changes in-memory user options (PRINTING)
Status: RESOLVED DUPLICATE of bug 40482
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-02 06:48 UTC by Terrence Enger
Modified: 2013-11-27 14:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
archive with referenced .png and .pdf files (642.75 KB, application/x-gzip)
2011-12-02 06:48 UTC, Terrence Enger
Details
screenshots and typescript of console session (345.70 KB, application/gzip)
2011-12-06 10:11 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2011-12-02 06:48:02 UTC
Created attachment 54075 [details]
archive with referenced .png and .pdf files

Export as pdf renders hard hyphens incorrectly and changes screen rendering.

The LibreOffice reported here is commit id 7a37392 (2011-11-23) configured with
    --disable-mozilla
    --enable-symbols
    --enable-dbgutil
    --enable-crashdump
    --disable-build-mozilla
    --without-junit
running on ubuntu-natty.

To observe the problem ...

(*) Download hyphen_rendering.odt, attached to bug 43234
    <https://bugs.freedesktop.org/attachment.cgi?id=54071>.  This
    document was created with the cited build of LO.  I entered the
    hard hyphens by typing ctrl-minus.

(*) Open that file in LibreOffice.  Observe ...

     a) Hard hyphens are displayed against grey background.  This is
        the behaviour that I am used to.

     b) Hard hyphens cause less horizontal spacing than normal
        hyphens, abutting or even overlapping the adjacent characters.
        I think hard hyphens (except for treatment of line boundaries,
        of course) should cause the same horizontal spacing as regular
        hyphens.

     c) Within each date punctuated with hard hyphens, the hard hyphen
        following the month is narrower than the hard hyphen following
        the year.  I think all the hard hyphens should cause the same
        horizontal spacing.

    Attached 1748.png and 1749.png show this result at two scales.

    By the way, LO 3.3.4 as delivered with ubuntu-natty, shows the
    same thing this far but no farther.

(*) Export the document to pdf.  Observe that hard hyphens are not
    visible.  The hard hyphens should be visible.

    Attached 1751.pdf shows my result.

(*) Observe that the screen no longer shows the hard hyphens.  The
    hard hyphens should be visible.

    Attached 1735.png shows my result.

(*) Position cursor in front of date in Heading 1 with hard hyphens.
    Press <cursor-right> ten times.  Observe that each (invisible)
    hard hyphen uses up a <cursor-right>.  I find this behaviour a bit
    surprising but correct.

(*) Close the file.

(*) Open the file.  Observe that hard hyphens are again visible.
Comment 1 Rainer Bielefeld Retired 2011-12-04 22:51:13 UTC
NOT reproducible with "LibreOffice 3.4.4  - WIN7 Home Premium (64bit) German UI [Build ID: OOO340m1 (Build:402)]" (hard hyphens are invisible)

With Server installation of MSVC Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [Build ID:  a286353-090bcba-3bf3b94]" Win-x86@6 – 2011-12-02_22:36:35):

a) I can confirm
b) I see the effect. But I do not know what "hard hyphens" are used for
c) I doubt, sample document shows a bad example because numbers around hard 
   hyphens are different. Using 2011-11-11 I see no difference 


@Terrence Enger:
Please contribute help or similar describing "hard hyphens"
Comment 2 Terrence Enger 2011-12-05 04:43:40 UTC
Oh my, I was badly confused.

The keystrokes ctrl-minus actually insert a soft hyphen, which LO help
text calls "definite separator" or "custom hyphen".  I am changing the
summary accordingly and setting the bug status back to UNCONFIRMED.

When my build-in-progress has finished, I shall look at the help text
for non-printing characters.  Meanwhile, I find it "funny" to have two
different renderings, but until I can look at my Writer options, I do
not have an opinion about which rendering is right.

(Note to self ... Repeat twenty-five times: the keystrokes for
non-breaking hyphen are ctrl-shift-minus.)

@Rainer:
I am sorry for contributing noise.
Comment 3 Terrence Enger 2011-12-06 10:11:45 UTC
Created attachment 54155 [details]
screenshots and typescript of console session

Here are observations on commit id 3a9271b (roughly 2011-12-05
02:56Z), going one level deeper into the funny behaviour.  Short
version: printing changes in-memory user options.

To observe the problem ...

( 1) Start LibreOffice.  Program displays Writer document
     "Untitled 1".

( 2) Take menu options Tools > Options > "LibreOffice Writer" >
     "Formatting Aids".  The program displays a dialog box which I
     call "the dialog" hereafter.

( 3) Note your settings now, as the rest of this procedure is going to
     destroy them.

( 4) Check everything that can checked  Click <OK>.

( 5) In "Untitled 1", type "asdf".

( 6) On the toolbar, click the icon "Print File Directly ([...])".

( 7) Display the dialog.  Observe that the following "Display of"
     options are now unchecked:
      - Paragraph end
      - Custom hyphens
      - Spaces
      - Non-breaking spaces
      - Tabs
      - Breaks.

    1236.png in the attached archive shows what I saw.

( 8) Click <Cancel>.

( 9) Close the program, discarding changes to "Untitled 1".

(10) Run the program.

(11) Display the dialog.  Observe the everything is checked.  1238.png
     in the attached archive shows what I saw.

My console output from these steps is in lines 125 to 150 in
20111205_1437_run in the attached archive.
Comment 4 Terrence Enger 2011-12-21 12:59:06 UTC
Note to self:  When your understanding of the bug changes, you should search bugzilla again.

*** This bug has been marked as a duplicate of bug 40482 ***