Bug Hunting Session
Bug 41290 - dictionaries do not install in daily builds as of 28/9/2011
Summary: dictionaries do not install in daily builds as of 28/9/2011
Status: CLOSED DUPLICATE of bug 41237
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.4.0 Beta5
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-28 03:59 UTC by Susan Cragin
Modified: 2012-01-09 12:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
installation log for DEBS without Dictionaries, and then dictionaries separately (14.81 KB, text/plain)
2011-10-05 04:35 UTC, Susan Cragin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Susan Cragin 2011-09-28 03:59:39 UTC
This is more of a problem than it looks because the Ubuntu apt daemon can't deal with it and crashes. 

Errors were encountered while processing:
 libo-dev3.5-dict-en_3.5.0-1_amd64.deb
 libo-dev3.5-dict-es_3.5.0-1_amd64.deb
 libo-dev3.5-dict-fr_3.5.0-1_amd64.deb
susan@susan:~/Downloads/DEBS$
Comment 1 Rainer Bielefeld Retired 2011-10-03 10:27:19 UTC
Seems to be Linux due to report.
@Susan Cragin
Please check your LibO version selection(Looks like "Libo-Master") and contribute a complete build identifier.
Comment 2 Susan Cragin 2011-10-03 10:55:25 UTC
I have been getting builds from 
http://dev-builds.libreoffice.org/daily/Linux_x86_64_Release_Configuration/master/current/

This is the one I tried today. 
http://dev-builds.libreoffice.org/daily/Linux_x86_64_Release_Configuration/master/current/master~2011-10-01_12.06.37_LibO-Dev-SDK_OOO350m1_Linux_x86-64_install-deb_en-US.tar.gz

I have tried all of them, I think, within the past week. 
All report the same problem with installation. 

I use Ubuntu 64-bit oneiric with all current updates.
Comment 3 Susan Cragin 2011-10-03 11:05:57 UTC
https://bugs.launchpad.net/ubuntu/+source/dpkg/+bug/865581

Have also filed a bug with Ubuntu.
Comment 4 Susan Cragin 2011-10-03 14:20:55 UTC
Here's what happens when I try to force-install one of the dictionaries. It's the same error I get, repeated 3 times, when I do the regular install. 


susan@susan:~/Downloads/DEBS$ sudo dpkg -i --force-all libo-dev3.5-dict-es_3.5.0-1_amd64.deb
(Reading database ... 206129 files and directories currently installed.)
Preparing to replace libo-dev3.5-dict-es 3.5.0-1 (using libo-dev3.5-dict-es_3.5.0-1_amd64.deb) ...
Unpacking replacement libo-dev3.5-dict-es ...

ERROR: exception occurred raising singleton "/singletons/com.sun.star.deployment.ExtensionManager": loading component library failed: file:///opt/lo-dev/program/../program/libdeployment.so

unopkg failed.
ERROR: Registration of extensions failed!
dpkg: warning: subprocess old post-removal script returned error exit status 1
dpkg - trying script from the new package instead ...

ERROR: exception occurred raising singleton "/singletons/com.sun.star.deployment.ExtensionManager": loading component library failed: file:///opt/lo-dev/program/../program/libdeployment.so

unopkg failed.
ERROR: Registration of extensions failed!
dpkg: error processing libo-dev3.5-dict-es_3.5.0-1_amd64.deb (--install):
 subprocess new post-removal script returned error exit status 1

ERROR: exception occurred raising singleton "/singletons/com.sun.star.deployment.ExtensionManager": loading component library failed: file:///opt/lo-dev/program/../program/libdeployment.so

unopkg failed.
ERROR: Registration of extensions failed!
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 1
Errors were encountered while processing:
 libo-dev3.5-dict-es_3.5.0-1_amd64.deb
susan@susan:~/Downloads/DEBS$
Comment 5 Björn Michaelsen 2011-10-04 02:14:41 UTC
Looks like you are trying to install extensions before libreoffice itself and thus registering the extension in libreoffice fails (as it is not there yet).
Comment 6 Susan Cragin 2011-10-04 04:00:38 UTC
(In reply to comment #5)
> Looks like you are trying to install extensions before libreoffice itself and
> thus registering the extension in libreoffice fails (as it is not there yet).

That may be. All I do is navigate to the DEB file and then the only command I give is as follows;
sudo dpkg -i l*.deb
Comment 7 Susan Cragin 2011-10-05 04:35:08 UTC
Created attachment 51998 [details]
installation log for DEBS without Dictionaries, and then dictionaries separately

I tried removing the dictionaries from the DEBS file and then installing. That worked without error (see attached). 
I put the dictionaries in another folder DICTS and then tried force-installing them. 
It did not work, showing the same errors as before. 
So maybe the install order is not the problem.
Comment 8 Susan Cragin 2011-10-07 05:17:27 UTC
This bug is a duplicate of bug 41237. 
That bug notes that a potential work-around exists at
http://www.piprime.fr/1476/supprimer-manuellement-paquet-debian-ubuntu/
Comment 9 Björn Michaelsen 2011-12-23 12:39:57 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 10 Susan Cragin 2011-12-24 04:55:20 UTC
this bug has been fixed and should be closed.
Comment 11 manj_k 2012-01-09 12:41:37 UTC
Due to the comments #8, #10:
RESOLVED DUPLICATE
CLOSED

*** This bug has been marked as a duplicate of bug 41237 ***