Bug 41321 - FILEOPEN: Imported Word bullets not correct in Mac OS X
Summary: FILEOPEN: Imported Word bullets not correct in Mac OS X
Status: RESOLVED DUPLICATE of bug 50284
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
3.3.4 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
QA Contact:
Whiteboard: BSA
Depends on:
Reported: 2011-09-29 01:54 UTC by mrry04
Modified: 2012-12-18 17:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

The zip file contains the 5 files as describe in my reaction. (64.80 KB, application/zip)
2012-03-03 11:10 UTC, mrry04
screenshot showing buggy bulleted list display (42.53 KB, image/png)
2012-04-18 04:29 UTC, Alex Thurgood

Note You need to log in before you can comment on or make changes to this bug.
Description mrry04 2011-09-29 01:54:16 UTC
THIS IS A 'WRITER' ITEM, but if I choose that on the bug report page and want to submit the bug I get the error 'there is no component named 'WRITER' in the 'LibreOffice' product.

Problem description: 
Main bullets and some of the sub level bullets are not imported correctly from a Word 97-2000 doc file. They and their distance to te text show up as an arc.

In the past versions of OpenOffice I know this type of import errors also occured. Regretfully this is one of the main causes why I cannot use this software for my customers. (If they see things like this, for them it is a confirmation that they can't switch to OO / LO)!!!!
In MHO this is a far more important issue than all kind of fancy new features. At least when you want to increase your install base!

Steps to reproduce:
1. Create a bulleted list in Word.
2. Save as Word doc.
3. Open in LibreOffice.

Current behavior:
See above. Bullets become arcs (or other signs).

Expected behavior:
Bullet should stay bullet.

Apache OOo Bugzilla – Bug 94727
Apache OOo Bugzilla – Bug 92011
Comment 54 is a good description of the bullet I see.
Comment 1 sasha.libreoffice 2012-03-02 06:48:27 UTC
Thanks for bugreport
Please, verify if in last version of LibreOffice still reproducible

Please, answer: Word opens correctly and Writer not -- on the same computer?

Please, attach sample Word document that demonstrates this problem
Comment 2 mrry04 2012-03-03 11:10:46 UTC
Created attachment 57981 [details]
The zip file contains the 5 files as describe in my reaction.

As reqeusted by Sasha.
For more info see comment.
Comment 3 mrry04 2012-03-03 11:18:34 UTC
My previous comment related to the zip file disappeared. 
Therefore again:

The error is in LibreOffice 3.4.5 and 3.5.0 still reproducible (regretfully).

In the zip file you'll find:

- the original Word file with a  bulleted list.
- a pdf version of the word file.
- the Word file opened in LO 3.4.5
- the Word file opened in LO 3.5.0
- a pdf version of the odt file in LO 3.5.0 -> Strange (but may be the key to the solution): here the arcs are gone and replaced by bullets again.

I hope this helps and that a solid solution will be found.
I stick to my opinion that this is a key element in the acceptance of LibreOffice as a professional alternative for MS Office!

Kind regards and good luck!
Comment 4 sasha.libreoffice 2012-03-05 01:10:27 UTC
Thanks for attachment
I see on screenshot from attachment that problem exist, instead of circle becomes "infinity". But I can not reproduce problem on Windows and Linux. May be it is MacOSX specific problem. Changing OS to it.
I will retain status Unconfirmed to attract more testers to this bugreport

@ Marcel
If available, please, verify this problem on another computer
Comment 5 Alex Thurgood 2012-03-07 13:01:35 UTC
Putting myself on CC, will try and test on my Mac tomorrow, but I have already encountered such problems in the past, most notably with NeoOffice which had (still has) similar problems.

Comment 6 mrry04 2012-04-16 05:09:36 UTC
Hello Sasha,

I really do not understand why this issue still has the status 'unconfirmed'.
In the mean time (years) there are so many mentions of this behaviour, to name just a FEW:

etcetera etcetera
and in the current list of most annoying bugs (3.5.2) it is also metioned.

A lot of people with a more IT background also indicate the cause of this issue.

P.S. I am not angry or so but disappointed because I think that most people are not interested in all kind of new features, but want to have the basic things up and running smoothly! A real prerequisite for real success of LibreOffice IMHO.

Kind regards,
Comment 7 sasha.libreoffice 2012-04-16 06:42:26 UTC
>I really do not understand why this issue still has the status 'unconfirmed'.
I do not change status to New because it not reproducible on Windows and Linux.
I retain status Unconfirmed for attract more testers to this bugreport (Unconfirmed bugreports appears on beginning of search results)
Nobody visited this bugreport because currently we have 5091 opened bugreports. It takes several years to revisit all bugreports.
Sorry for such situation.
Comment 8 Alex Thurgood 2012-04-18 04:25:10 UTC
Confirming, I have this problem almost every time I save an ODF doc to Word format, and then re-open that in NeoOffice, LO, OOo or Symphony. It is a very, very, old problem, at least 6 or 7 years old from what I recall, i.e. it was also present in OOo.

Comment 9 Alex Thurgood 2012-04-18 04:29:37 UTC
Created attachment 60245 [details]
screenshot showing buggy bulleted list display
Comment 10 Alex Thurgood 2012-04-18 04:30:36 UTC
Have enclosed screenshot showing buggy display
Comment 11 Alex Thurgood 2012-04-18 04:31:49 UTC
Have set release to 3.3.4 because the problem exists there too, and I don't have any older versions of LO.

Comment 12 Alex Thurgood 2012-04-18 04:49:09 UTC
Also tested on :

OOo 3.2.1 : buggy display
OOo 3.3.0 : buggy display

NeoOffice 3.1.2 : no problem, correct display of Word doc bullet points
NeoOffice 3.2.1 : no problem, correct display of Word doc bullet points
Symphony 3.0.1 : no problem correct display of Word doc bullet points

LO 3.3.4 : buggy display
LO 3.5.1 : buggy display
LO 3.6 master : buggy display

Comment 13 sasha.libreoffice 2012-04-18 04:54:00 UTC
Thanks for additional testing
Comment 14 Roman Eisele 2012-05-23 10:28:57 UTC
In general, this is a duplicate of bug 34814, therefore I mark this report as a duplicate of the (fixed) bug 34814. The fix should appear in the forthcoming LibO 3.5.4 (and in 3.6, of course).

But please note that this issue IMHO is NOT fixed especially in LibreOffice for MacOS X. If you can confirm that this issue is still not fixed in LibreOffice 3.5.4 or better for MacOS X, please refer to the special bug 50284. If you could leave a note on the report page for bug 50284, that this bug still affects you even after installing LibO 3.5.4 or better, this would help to confirm that report (and maybe to fix it ;-).

*** This bug has been marked as a duplicate of bug 34814 ***
Comment 15 Caolán McNamara 2012-12-18 17:01:41 UTC
looks good for me now on master version of macosx

*** This bug has been marked as a duplicate of bug 50284 ***