Bug 41447 - Based on Bug 40449 - SPELLCHECK does not recognize text language
Summary: Based on Bug 40449 - SPELLCHECK does not recognize text language
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-04 05:48 UTC by rk601
Modified: 2011-12-25 03:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen shot LibO-dev 3.5.0 mixed-language spell checking is inconsistent on OSX 10.6.8. (429.37 KB, application/zip)
2011-10-04 05:48 UTC, rk601
Details
Mixed Language Screen-shot Example (130.21 KB, image/png)
2011-10-04 05:49 UTC, rk601
Details
reload: Screen shot LibO-dev 3.5.0 mixed-language spell checking is inconsistent on OSX 10.6.8. (429.80 KB, application/zip)
2011-10-04 07:11 UTC, rk601
Details
Screenshot A: mixed_language.odt_ with_bug_fdo#40449_A.png (73.78 KB, image/png)
2011-10-05 13:47 UTC, manj_k
Details
Screenshot B: mixed_language.odt_ with_bug_fdo#40449_B.png (52.08 KB, image/png)
2011-10-05 13:48 UTC, manj_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rk601 2011-10-04 05:48:31 UTC
Created attachment 51935 [details]
Screen shot LibO-dev 3.5.0 mixed-language spell checking is inconsistent on OSX 10.6.8.

As per Caolán McNamara (2011-10-04 05:36:34 PDT) request:

Here is a new bug report to test for mixed-language spell checking (see Bug 40449).

Open Attached Sample document (based on original "sample1.odt"), please see the
original report in Bug 40449!

LibO-dev 3.5.0 mixed-language spell checking is inconsistent on OSX 10.6.8.
please see the following:

LibO-dev 3.5.0 
Build ID: fdbe98e-3f7a742-4eb4f62-260b7c1
On OSX 10.6.8

Located at:

http://dev-builds.libreoffice.org/daily/MacOSX_10.6.7_Intel_no-moz/master/2011-10-01_13.36.19/

with

master~2011-10-01_13.36.19_LibO-Dev_OOO350m1_MacOS_x86_install_en-US.dmg

LibO-dev 3.5.0 mixed-language spell checking is inconsistent on OSX 10.6.8.

Please follow these steps to reproduce:

1. Open attached sample document
2. Activate auto spell check
   Expected: English/German words underlined
   Actual: inconsistent underlining

Checking dialogs (see screenshots in document) shows that Spell Check is
inconsistent or at least gets confused with English/German and does not
recognize text language.

Might have same roots like "Bug 39365 - Spell check does not work after copy /
paste, modified language not recognized"
Comment 1 rk601 2011-10-04 05:49:33 UTC
Created attachment 51936 [details]
Mixed Language Screen-shot Example

It appears that uppercase words are another mixed language example. See words
within the red rectangle within the attachment.
Comment 2 Rainer Bielefeld Retired 2011-10-04 06:03:51 UTC
@rk601@yahoo.com:
What information can you contribute that your problem is identical with the one from "Bug 40449 - SPELLCHECK does not recognize text language"

I can confirm that spell check works completely unreliable with  Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: 81607ad-3dca5fd-da627d2)]", but the appearance is completely different tho report, there no language was indicated in the spell check dialog, here I see the text language, but spell check does not work either.

Can you please be more specific than "gets confused" and give some concrete information like "'an inncorrect spelln should show as incorrect' is indicated as GERMAN with 3.4, but Zulu in 3.5"?

Most important: Tell us your observation concerning text language in spell check dialog!

Please file Bug reports with status UNCONFIRMED if your are not absolutely sure that you contributed all required background information, that the problem will be reproducible with information you can provide or that your enhancement request will be accepted!
Comment 3 Rainer Bielefeld Retired 2011-10-04 06:11:55 UTC
@Reporter:
Folder "__MACOSX" ffrom test kit contains 2 pictures I can't open. What should they tell?
Comment 4 rk601 2011-10-04 07:11:00 UTC
Created attachment 51959 [details]
reload: Screen shot LibO-dev 3.5.0 mixed-language spell checking is inconsistent on OSX 10.6.8.
Comment 5 manj_k 2011-10-04 08:40:47 UTC
As far as I can see:

1. Your attached 'mixed_language.odt' is formatted with the language attribute 'German (Germany)' for all applied styles:
- Default
- EmailAdresse
- Frame contents
- Table Contents
- Überschrift Brief 1
- etc.

It is formatted as an unilingual text document.

Therefore: 
The text language has been recognized correctly as 'German (Germany)'.
Nearly all 'English' words get the red wavy lines for 'misspelled', because they are misspelled 'German' words. You should apply the language attribute 'English (USA)'--or similar--for these words/sentences/paragraphs, e.g. via:
- Status bar / language field 
- Tools > Language > For...
- Menu Format > Character > Font > Language
- Paragraph or Character styles (F11)


2. Some supposed 'English' words are also correct 'German' words, e.g.:
Real, Image, an, Part, Type, Private, Business, See, etc.
Therefore: no red wavy lines, not misspelled.


3. Spell check dictionaries are--unfortunately--not infallibly... ;)


Your summary 'SPELLCHECK does not recognize text language'
doesn't match the attached text document 'mixed_language.odt'.

Tested with the last working LibO Master for Windows:
LibO Master - LibO-dev 3.5.0 Build ID: 8cc839d-3dca5fd-4525197
[master~2011-09-12_16.09.34_LibO-Dev_OOO350m1_Win_x86_install_en-US.exe].
Comment 6 manj_k 2011-10-05 13:45:20 UTC
When I open your attached 'mixed_language.odt' with LibO Master [LibO-dev 3.5.0 Build ID: d3d1481-3f8994a-2ba0a9f / master~2011-09-06_02.34.59']--affected by bug 40449--I get a different result, compared to your attached screenshots 'Spelling01.png' and 'Spelling02.png'.

I have attached the corresponding screenshots:
- mixed_language.odt_ with_bug_fdo#40449_A.png
- mixed_language.odt_ with_bug_fdo#40449_B.png

Maybe, a less complex text document could show your issue more precise?
Comment 7 manj_k 2011-10-05 13:47:13 UTC
Created attachment 52021 [details]
Screenshot A: mixed_language.odt_ with_bug_fdo#40449_A.png
Comment 8 manj_k 2011-10-05 13:48:10 UTC
Created attachment 52022 [details]
Screenshot B: mixed_language.odt_ with_bug_fdo#40449_B.png
Comment 9 Rainer Bielefeld Retired 2011-10-05 21:27:04 UTC
My main problem currently is that I don't have German dict. for my Masters, only some English, French, Spanish. So I can't reproduce your checks. How can I add a German dictionary?
Comment 10 manj_k 2011-10-05 22:05:33 UTC
@Rainer Bielefeld;
You'll find some European dictionaries on 
http://dvd.de.libreofficebox.org/extensions/

Download link 'de-DE Frami':
http://dvd.de.libreofficebox.org/assets/addons/dic.oxt/dict-de_DE-frami_2011-06-03.oxt

My way:
Tools > Extension Manager > Add... (only for me) [= installed in the user profile]
Comment 11 Rainer Bielefeld Retired 2011-10-05 22:39:56 UTC
Thx!
I installed "dict-de_DE-frami_2011-06-03.oxt" and now my results are identical with manj_k's from 2011-10-05 13:47 / 2011-10-05 13:48

I agree, we have to many imponderables here, we need a much more simple sample document, starting with few words and 1 language.
Comment 12 Caolán McNamara 2011-11-14 07:11:18 UTC
double-checking here, I come to the some conclusion as comment #c5, i.e. the document claims all text to be German. We definitely *had* two or three bugs which impacted spellchecking. I think those are fixed and ok now. I don't think there remains a problem here. If there is, please feel free to reopen with a sample reproducing document.
Comment 13 Björn Michaelsen 2011-12-22 05:51:01 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.
Comment 14 manj_k 2011-12-25 03:52:49 UTC
CLOSED