Bug 41454 - VIEWING: Dialog Positioning on a multi-screen/multi-workspace configuration
Summary: VIEWING: Dialog Positioning on a multi-screen/multi-workspace configuration
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.0 RC2
Hardware: x86-64 (AMD64) Linux (All)
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 60199 (view as bug list)
Depends on:
Blocks: Desktop-Environment
  Show dependency treegraph
 
Reported: 2011-10-04 08:47 UTC by Norm
Modified: 2017-09-05 10:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Norm 2011-10-04 08:47:32 UTC
On a multi-screen (or multi-workspace) configuration, when opening a password-protected file, the "Enter Password" dialog does not appear as expected in front of the blank page on the current screen/workspace; instead it shows up in front of some other screen/worksace if there is already an open libreoffice file displayed.  It is therefore difficult to find where this dialog is hiding if there are multiple documents open in multiple screens/workspaces, meanwhile the user is left staring at a blank outline of the desired unopened document, perhaps not realizing that it will remain blank until the password dialog is found and answered.

Thanks, Norm
Comment 1 Björn Michaelsen 2011-12-23 12:39:42 UTC Comment hidden (obsolete)
Comment 2 Jean-Baptiste Faure 2012-01-28 13:55:57 UTC
Made summary more informative to attract more testers.
Only one screen in my case.

Best regards. JBF
Comment 3 Norm 2012-01-30 08:31:36 UTC
verified that this problem still exists in 3.5.0 RC2.

Note: multi-screen configuration not needed -- this problem can be seen with Workplace Switcher.  Open 1st document in one workspace (producing window#1), switch to another workspace and open 2nd document that requires a password: a blank outline window#2 will appear for the 2nd document, but the password entry dialog will appear in front of window#1 -- i.e., out of view of the current workspace.  If there are multiple documents open in different workspaces, it can be a challenge to find which one holds the password entry dialog for the latest attempt to open a document ...

thanks, Norm
Comment 4 Joel Madero 2012-06-18 13:33:21 UTC
Confirmed this bug, marked as NEW. Also adding VIEWING
Comment 5 Joel Madero 2014-05-21 16:32:30 UTC
*** Bug 60199 has been marked as a duplicate of this bug. ***
Comment 6 Joel Madero 2014-05-21 16:33:09 UTC
Updated title to reflect duplicate bug
Comment 7 QA Administrators 2015-06-08 14:42:25 UTC Comment hidden (obsolete)
Comment 8 Norm 2015-06-24 13:36:22 UTC
problem gone sometime before my current version 4.2.8.2 of libreoffice using multiple screens/workspaces on Ubuntu trusty64.

Password dialog now appears on primary screen and displays document on same screen after correct password entered, even when there is another document already open and displayed on a different workspace or screen.

Thanks to whoever fixed this.