Bug 60199 - Opening encrypted file changes workspaces
Summary: Opening encrypted file changes workspaces
Status: RESOLVED DUPLICATE of bug 41454
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Desktop-Environment
  Show dependency treegraph
 
Reported: 2013-02-02 18:54 UTC by Mark Hull-Richter
Modified: 2017-09-05 10:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Hull-Richter 2013-02-02 18:54:35 UTC
When I open an encrypted file in any given workspace, if I have any other LO file open in a different workspace, LO jumps to that workspace, even if the open file is minimized, and prompts for the password there.  It does not switch back to the workspace where the file is actually opened.

To reproduce:

1. Open any LO file (say in workspace #1).
2. Go to another workspace (say #2).
3. Open an encrypted LO file.  This typically occurs if done from a shell command line (e.g., xdg-open or gnome-open). It does NOT happen from within a file manager.

LO will jump back to workspace 1 to prompt for the second file's password, then NOT jump back to workspace 2.

Expected behavior:

Preferably do not jump to another workspace at all.

If not, jump back when the password is entered.
Comment 1 Joel Madero 2014-05-21 16:32:30 UTC

*** This bug has been marked as a duplicate of bug 41454 ***