Bug 41994 - Silent Installation to an alternative directory fails
Summary: Silent Installation to an alternative directory fails
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Win-Installer-MAB
  Show dependency treegraph
 
Reported: 2011-10-19 02:45 UTC by Chris Woollard
Modified: 2012-05-24 21:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Woollard 2011-10-19 02:45:23 UTC
I have been trying to automate installation of LibreOffice 3.4.3 from a script to silently deploy to multiple computers.

In our configuration applications get installed to D:\apps

It seems that the below msiexec INSTALLDIR parameter is ignored with the current LibreOffice 3.4.3 Release package.

msiexec /i libreoffice34.msi INSTALLDIR="d:\apps\LibreOffice" /qr

I have tried with the standard Windows Installer 3 and I have upgraded to the latest 4.5 installer. Both have the issue.

I think this is a problem with the msi package rather than the computers. This is because other MSI packages happily install using this parameter.
Comment 1 Andras Timar 2011-10-24 05:41:09 UTC
There is no INSTALLDIR custom property in libreoffice34.msi. You should have used the INTALLLOCATION custom property, that is what we have instead. 

The command

msiexec /i libreoffice34.msi INSTALLLOCATION="d:\apps\LibreOffice" /qr

works fine.
Comment 2 Chris Woollard 2011-10-24 05:48:13 UTC
Thanks for that.

Is this documented anywhere?

I couldn't find it when I was searching.

Thanks
Chris


On 24 October 2011 13:41, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=41994
>
> Andras Timar <timar74@gmail.com> changed:
>
>           What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>             Status|UNCONFIRMED                 |RESOLVED
>         Resolution|                            |NOTABUG
>
> --- Comment #1 from Andras Timar <timar74@gmail.com> 2011-10-24 05:41:09
> PDT ---
> There is no INSTALLDIR custom property in libreoffice34.msi. You should
> have
> used the INTALLLOCATION custom property, that is what we have instead.
>
> The command
>
> msiexec /i libreoffice34.msi INSTALLLOCATION="d:\apps\LibreOffice" /qr
>
> works fine.
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
> You reported the bug.
>
Comment 3 Andras Timar 2011-11-23 07:58:09 UTC
(In reply to comment #2)
> Thanks for that.
> 
> Is this documented anywhere?

http://wiki.services.openoffice.org/wiki/Documentation/How_Tos/Automatic_Installation_on_Windows

Surely, we need to document it better in LibreOffice wiki ASAP.