Bug Hunting Session
Bug 42099 - PRINTING: set option Tools > Options > Writer > Print Automatically inserted blank pages default to OFF
Summary: PRINTING: set option Tools > Options > Writer > Print Automatically inserted ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Cor Nouws
URL:
Whiteboard: target:4.0.0
Keywords:
: 50081 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-21 13:02 UTC by Paul From Brooklyn
Modified: 2019-01-23 10:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul From Brooklyn 2011-10-21 13:02:41 UTC
Using Writer with Windows XP and HP LaserJet 4 with HP accessory envelope feeder to do merge prints.  Printing worked fine in OOO 3.2, although I had issue with merge print failing to print final fields.  Merge issue is fixed in both current releases of LO (3.3.4 and 3.4.3), but Writer wants to print a blank envelope after each printed one.  I tried printing to a file, and the file looks fine, but when you try to print that file, it's the same issue -- blanks between printed envelopes.  I took the output file from LibreOffice and opened it in OOO 3.2, and that prints the blank envelopes, too, so it's likely a page-size format problem in whatever output from LibreOffice.  I suspect the envelope height may be misdefined at 4.13". The actual height for a #10 envelope is 4.125".  Are these parameters accessible anywhere without having to rebuild the app from source?
Comment 1 Paul From Brooklyn 2011-10-22 08:15:59 UTC
Okay.  Nothing wrong with the envelope size, but there's still a problem.  Found the checkbox for inserting blank pages.  It shouldn't default to "on".  There are two checkboxes, though.  One in the File/Printer Settings/Options menu, the other in the print dialog, under the Writer option tab.  Both must be unchecked.  They don't seem to talk to each other.  They're also not talking to something else.  If print to a file is done, and then you try to print the file, the page number selection is all screwed up.  It's as if it's counting pages including the non-existing blank pages.  Some part of whatever keeps track of page numbers to print is assuming that checkbox is always ticked.  To repeat, this is a problem specifically in merge-printing.
Comment 2 sasha.libreoffice 2012-03-06 04:55:11 UTC
Thanks for bugreport
Please, verify if in last version of LibreOffice still reproducible
And if still exist then attach document, produced by merging
(remove all confidential information from document and ensure that it still demonstrates this problem)
Comment 3 Rainer Bielefeld Retired 2012-03-28 03:42:44 UTC
I think this one is a DUP of or related to "Bug 31606 - Exporting a selection of pages to PDF has pagerange wrong because of blank pages"
Comment 4 Cor Nouws 2012-11-11 20:38:11 UTC
(In reply to comment #3)
> I think this one is a DUP of or related to "Bug 31606 - Exporting a
> selection of pages to PDF has pagerange wrong because of blank pages"

No, it definitely is the wish to have the option Tools > Options > Writer > Print AUtomatically insert blank
Comment 5 Cor Nouws 2012-11-11 20:41:18 UTC
(In reply to comment #3)
> I think this one is a DUP of or related to "Bug 31606 - Exporting a
> selection of pages to PDF has pagerange wrong because of blank pages"

No, it definitely is the wish to have the option Tools > Options > Writer > Print Automatically inserted blank pages default to OFF
Comment 6 Cor Nouws 2012-11-11 20:43:13 UTC
*** Bug 50081 has been marked as a duplicate of this bug. ***
Comment 7 Not Assigned 2012-11-12 09:57:04 UTC
Cor Nouws committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bca28d7a8020948803f9879aaff7eb16774dc548

fdo#42099 set option Writer Print Automatic.inserted blank pages default OFF



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.