Bug Hunting Session
Bug 42125 - Tabs and fill Characters are lost after store as Word2007 file (*.docx)
Summary: Tabs and fill Characters are lost after store as Word2007 file (*.docx)
Status: RESOLVED DUPLICATE of bug 46938
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Paragraph Tab-Character
  Show dependency treegraph
 
Reported: 2011-10-23 03:39 UTC by ajs1965
Modified: 2018-07-11 15:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Zip-file of the descibed files (22.86 KB, application/zip)
2011-10-23 03:39 UTC, ajs1965
Details
result file with LO 4.3.6.2 (5.56 KB, application/zip)
2015-04-19 19:26 UTC, ajs1965
Details
Resultfile with LOO 5.2.1 (25.64 KB, application/zip)
2016-09-21 10:14 UTC, ajs1965
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ajs1965 2011-10-23 03:39:10 UTC
Created attachment 52648 [details]
Zip-file of the descibed files

Used version: LibreOffice 3.4.3 OOO340m1 (Build:302)
Operation System: Windows XP SP3

The following problem was found during work with Word2007 files (*.docx).

The attached source file (Johannes_Gutenberg.docx) was modified with the following steps:

1. add a border to the first line;

2. for the complete text (without first line) add a spacing below the paragraph;

3. remove all existing tabs in the part of the timetable and add a new tab with (3 cm) and fill character "....".

4. Store this file as Johannes_Gutenberg1.docx, Johannes_Gutenberg1.doc and Johannes_Gutenberg1.odt.

5. Close the file Johannes_Gutenberg.docx;

6. Open the result files.

Check the result:

docx: The new tabs and fill character in the timetable are missing. In this paragraph I found the old one from the source file (Johannes_Gutenberg.docx);

doc (Word 97/2000/XP/2003), odt: The new format exist.
Comment 1 dE 2012-04-21 21:17:36 UTC
I confirm this.
Comment 2 Ronildo Matsuura 2012-08-07 13:06:20 UTC
I am having the same problem!
Comment 3 QA Administrators 2015-04-19 03:22:07 UTC Comment hidden (obsolete)
Comment 4 ajs1965 2015-04-19 19:25:25 UTC
On request I have checked this old bug and found with Libre Office 4.3.6.2 the following behaviour:

After I had reopened the doc-file the new tabs (3cm) are in the paragraph, but now also the standard tabs (1.25 cm) are readded by Libre Office. So the spacing is not correct, see the new result file Johannes_Gutenberg2.docx.
Comment 5 ajs1965 2015-04-19 19:26:40 UTC
Created attachment 114925 [details]
result file with LO 4.3.6.2
Comment 6 ajs1965 2015-04-19 19:32:18 UTC
Sorry one is missing: Operating System is now Window 7 prof. 64-bit with SP1.
Comment 7 dE 2015-09-05 12:10:55 UTC
In 2012 I verified this to be present on Linux.
Comment 8 QA Administrators 2016-09-20 10:28:56 UTC Comment hidden (obsolete)
Comment 9 ajs1965 2016-09-21 10:14:21 UTC
Created attachment 127509 [details]
Resultfile with LOO 5.2.1
Comment 10 ajs1965 2016-09-21 10:14:53 UTC
Now I make a regression with Libre Office version 5.2.1.2. Info from Help/Info about LibreOffice:

Version: 5.2.1.2
Build-ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU-Threads: 2; BS-Version: Windows 6.2; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group

Now I used Window 10 Pro Version 1511 (incl. latest patch stack).

With this Environment the behaviour is changed:

- The .odt-file is correct (can used as reference);

- in the .doc-file the border around the characters in the first line is wrong;

- in the .docx-file some tabs are missing.

All files are archived and attached as zip-file (Bug_42125_160921.zip).
Comment 11 Alex Thurgood 2017-09-18 06:57:48 UTC
*** Bug 112460 has been marked as a duplicate of this bug. ***
Comment 12 Justin L 2018-07-11 15:16:39 UTC

*** This bug has been marked as a duplicate of bug 46938 ***