Download it now!
Bug 42166 - PDF export of an empty Calc document gives an error
Summary: PDF export of an empty Calc document gives an error
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:4.4.0
Keywords:
: 49151 56248 73683 78601 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-24 08:05 UTC by Bernhard Donaubauer
Modified: 2014-08-07 07:21 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Donaubauer 2011-10-24 08:05:54 UTC
Create a new spreadsheet save it and export the empty spreadsheet to pdf. If you do so LibreOffice throws an error.
Comment 1 Laubrino 2012-04-23 05:36:38 UTC
It happend to me too. 
ErrorCode 3088. 
LibreOffice 3.5.2 release on win7
Comment 2 tommy27 2013-09-17 18:47:19 UTC
I confirm this in LibO 4.1.1.2 under Win7 64bit

anyway I wonder what's the point of converting to PDF an empty file...
is there a real-life situation where you would do that?
Comment 3 Bernhard Donaubauer 2013-09-18 05:47:41 UTC
Here is my use case.

We use LO to generate reports for our employees in the field.

These are the steps:
a) We generate a ods - File with Perl and XSLT.
b) We convert the ods via LO to pdf.
c) We send the report in ods and pfd format.

If the report is empty step b fails. Think of an report with customer complaints. If no customer complains the report ist empty.
Comment 4 Laubrino 2013-09-18 07:06:55 UTC
(In reply to comment #2)
> anyway I wonder what's the point of converting to PDF an empty file...
> is there a real-life situation where you would do that?

We use it for generating document previews by a computer program. Whatever a user uploads to our system we convert it to PDF and then render to images. If a user uploads an empty file, the process fails.
Comment 5 tommy27 2013-09-18 07:54:09 UTC
Ok. does "empty file upload" happen frequently?

as a workaround you could use an .ods template with some text in it (like an header) so even if no notes are added the file wouldn't be empty
Comment 6 Laubrino 2013-09-18 08:59:54 UTC
I don't know, I wouldn't say that.
But what's the odds? Emty document means one blank page. So why the same output is not generated to PDF? One empty page. 

I cannot use any workaround. Imagine that a user uploads an empy document and you will show him some non-empty page (?)
Comment 7 tommy27 2013-09-18 11:10:19 UTC
I reproduce the same bug with OpenOffice 3.3.0 so I change version field to "inherited from OOo".

interestingly only Calc cannot export empty documents to pdf.
Writer, Draw and Impress are unaffected.

adding Calc expert to CC-list.
Comment 8 ign_christian 2013-09-23 09:35:44 UTC
*** Bug 49151 has been marked as a duplicate of this bug. ***
Comment 9 Maxim Monastirsky 2014-02-02 15:56:47 UTC
*** Bug 73683 has been marked as a duplicate of this bug. ***
Comment 10 Maxim Monastirsky 2014-05-12 13:51:26 UTC
*** Bug 78601 has been marked as a duplicate of this bug. ***
Comment 12 Maxim Monastirsky 2014-08-07 07:21:33 UTC
*** Bug 56248 has been marked as a duplicate of this bug. ***