Bug Hunting Session
Bug 56248 - PDF Export of Selection stops with error message
Summary: PDF Export of Selection stops with error message
Status: RESOLVED DUPLICATE of bug 42166
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.2.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-21 09:46 UTC by Sebastian Armbrust
Modified: 2014-08-07 07:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Error Message on pdf Export (in german) (31.12 KB, image/jpeg)
2012-10-21 09:46 UTC, Sebastian Armbrust
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Armbrust 2012-10-21 09:46:43 UTC
Created attachment 68866 [details]
Error Message on pdf Export (in german)

Problem description: 

PDF Export of selection leads to error message.

Steps to reproduce:
1. open ods File
2. do nothing with the file
3. Select File -> Export to PDF
4. In the Common Tab select radiobutton Selection under Range.

Current behavior:

Error message (see attachment)

Expected behavior:

Export of current sheet in he given directory.

Note: Error doesn'thappen if one selectes a range by hand!!!

Platform (if different from the browser): 

Windows 7 (AMD64) German, Libreoffice 3.6.2.2 (Build ID: da8c1e6). This bug was also valid in v.3.6.1
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Comment 1 Rainer Bielefeld Retired 2012-10-21 10:41:05 UTC
NOT reproducible as a general problem with "LibreOffice 3.6.3.1” English UI/ German Locale [Build-ID: f8fce0b] on German WIN7 Home Premium (64bit)

@Sebastian Armbrust
Thank you for your report – unfortunately important information is missing.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? If you believe that that  is really sophisticated please as for Help on a user mailing list
Please:
- Write a meaningful Summary describing exactly what the problem is
- Attach a sample document (not only screenshot) or refer to an existing 
  sample document in an other Bug with a link; to attach a file to this 
  bug report, just click on "Add an attachment" right on this page.
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a document related step by step instruction containing every 
  key press and every mouse click how to reproduce your problem 
  (similar to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
   -- concerning your PC 
   -- concerning your LibO Locale setting)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  –- Whether your problem persists when you renamed your user profile 
     before you launch LibO (please see
     <https://wiki.documentfoundation.org/UserProfile#User_profile_location>)
  –- Extensions that might be related
  -- everything else crossing your mind after you read linked texts
Comment 2 Sebastian Armbrust 2012-10-21 10:52:15 UTC
The error is not related to a specific file. It is even reproducale with a new created file via start splash screen.

Deleting the user profile doesn't make a difference.

Simply:

- Start LO
- Create a new file
- Select File -> Export to pdf
- Select "Seelction"
- Choose your path
-> error message apears

Environment is a standard install with 3 additional extension:
-CT_Calc
-CT_Writer
-Duden Korrektor

I will install 3.6.3 RC1 and test further
Comment 3 Sebastian Armbrust 2012-10-21 11:01:44 UTC
In Version 3.6.3.1 (Build ID: f8fce0b) error is still existing
Comment 4 Joel Madero 2013-05-30 16:17:48 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 5 Sebastian Armbrust 2013-06-23 14:47:18 UTC
Tested it with a couple of file and could not reproduce the error if i apply it to previously saved files.

However bug occurs on a new and empty calc file given that one didn't enter anything. Related to the error message that no print preview is possible due to lack of data.
Comment 6 retired 2013-06-24 09:17:39 UTC
Sebastian: Thanks for the update.

I can confirm this problem.

* open a new spreadsheet
* File > Export as PDF
* General > Range > All or Selection Pages (enter 1)

results in:
Error saving the document Untitled1:
Write Error.
The file could not be written.

Setting to NEW.
Comment 7 Owen Genat (retired) 2014-07-14 11:14:48 UTC
Using the instructions from comment 0, comment 2, and comment 6:

- Debian 7 x86_64 running v4.3.0.2 Build ID: 14ed55896fdfcb93ff437b85c4f3e1923d2b1409 the error message is displayed as indicated. 
- Crunchbang 11 x86_64 running v4.4.0.0.alpha0+ Build ID: 3fdd4f069d5436cf39708004af7fda8175fbc4c2 there is no error message and the empty PDF is produced as expected.

Seems like v4.4 may include a fix for this issue.
Comment 8 Maxim Monastirsky 2014-08-07 07:21:33 UTC

*** This bug has been marked as a duplicate of bug 42166 ***