Bug Hunting Session
Bug 42169 - Formatting oddity in pivot table output.
Summary: Formatting oddity in pivot table output.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.5 target:3.4.5
Keywords:
: 38327 41540 41577 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-24 10:28 UTC by Kohei Yoshida
Modified: 2012-02-01 05:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
test document (10.26 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-10-24 10:28 UTC, Kohei Yoshida
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kohei Yoshida 2011-10-24 10:28:36 UTC
Created attachment 52701 [details]
test document

Open the attached document, and take a look at the pivot table output on the 2nd sheet.  In the cells where the column labels appear, you see date values instead of version numbers such as 3.3.0, 3.3.1 and 3.4.0.  In the source range those version numbers are given as text strings.

Apparently the format in those cells shouldn't be of date.
Comment 2 Kohei Yoshida 2011-11-07 08:10:55 UTC
*** Bug 38327 has been marked as a duplicate of this bug. ***
Comment 3 Kohei Yoshida 2011-11-07 12:55:56 UTC
The fix will go into 3.4.5 as well.
Comment 4 Nikos 2011-11-08 02:11:27 UTC
Maybe someone could check if that means https://bugs.freedesktop.org/show_bug.cgi?id=41577 and https://bugs.freedesktop.org/show_bug.cgi?id=41540 are also resolved.
Comment 5 Kohei Yoshida 2011-11-08 05:29:18 UTC
*** Bug 41540 has been marked as a duplicate of this bug. ***
Comment 6 GerardF 2011-11-20 11:04:44 UTC
*** Bug 43109 has been marked as a duplicate of this bug. ***
Comment 7 Rainer Bielefeld Retired 2011-11-27 02:35:44 UTC
*** Bug 41577 has been marked as a duplicate of this bug. ***
Comment 8 Peter van Ieperen 2012-02-01 02:53:16 UTC
The problem as described is fixed.
But now, if you've got date-cells, they too get converted to text.

I believe this can't be the idea of this fix in 3.4.5?
Comment 9 Kohei Yoshida 2012-02-01 05:39:05 UTC
(In reply to comment #8)
> The problem as described is fixed.
> But now, if you've got date-cells, they too get converted to text.
> 
> I believe this can't be the idea of this fix in 3.4.5?

3.4.x is too old.  Get 3.5 RC.