Download it now!
Bug 43109 - PIVOTTABLE: DataPilot - Problem with leading zeros
Summary: PIVOTTABLE: DataPilot - Problem with leading zeros
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: Other All
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: BSA target:3.7.0 target:3.6.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-20 05:39 UTC by Uwe Rettstadt
Modified: 2012-07-07 05:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Simple pivot table with leading zeroes in row-grouping fields (9.39 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-04-13 03:41 UTC, Frank Richter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Rettstadt 2011-11-20 05:39:14 UTC
Problem description: 

A Column (Format code: Text) contains Numbers with leading zeros.
This column is the source for the datapilot, but there the leading zeros aren`t shown.

The same problem exists, if the numbers contain a leading "+".

(No problems by using OpenOffice Calc).
Comment 1 GerardF 2011-11-20 11:04:44 UTC

*** This bug has been marked as a duplicate of bug 42169 ***
Comment 2 Frank Richter 2012-04-13 03:41:36 UTC
Created attachment 59899 [details]
Simple pivot table with leading zeroes in row-grouping fields
Comment 3 Frank Richter 2012-04-13 03:43:44 UTC
I think, this bug is not really a duplicate.
The issue in 42169 is fixed, just verified in 3.5.2
Leading Zeroes still get lost, when used in grouping fields in pivot tables.
Comment 4 Not Assigned 2012-07-07 05:06:55 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6935b6d9bc08ccb780bd80254ba9b26caf6ab27e

fdo#43109: Don't check for simple number when text format is requested.
Comment 5 Kohei Yoshida 2012-07-07 05:12:26 UTC
This is now fixed.
Comment 6 Not Assigned 2012-07-07 05:13:25 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ccd4a408683062185802f7635836a49cdb692cf9&g=libreoffice-3-6

fdo#43109: Don't check for simple number when text format is requested.


It will be available in LibreOffice 3.6.